locked
Unable to Set Startup Type to Automatic (Delayed Start) for WLAN AutoConfig service RRS feed

  • Question

  • I would like to know how to set the Startup type to Automatic (Delayed Start) for the Wlan Autoconfig service on Windows 7 (32-bit). When I tried to do this, I got this error message:

    C:\>sc config wlansvc start= delayed-auto

    "The Delayed auto-start flag could not be set."
    "Error 87: The parameter is incorrect."

    How can I set the Startup type to Automatic (Delayed Start)?

    Thanks.

    Wednesday, September 3, 2014 8:47 AM

All replies

  • Your syntax is correct. The issue is with the type of service.

    According to this page: http://forum.sysinternals.com/the-delayed-autostart-flag-could-not-be-set_topic30715.html

    "Many services are members of service groups. Many of these groups have entries in the ServiceGroupList in the registry that controls the order in which the services are started. Many services must be started in a specific order. Services that are members of such a group cannot be set to Delayed start."


    Tuesday, June 23, 2015 4:50 PM
  • I stumbled upon this error a few days ago. 

    You can try to set the startup type in the registry, as shown on this blog:

    http://www.itexperience.net/2017/07/03/sync-host-the-parameter-is-incorrect/

    I believe delayed-auto is value '3'.





    • Edited by .Christian Friday, August 3, 2018 1:10 PM
    Thursday, July 6, 2017 7:01 AM
  • Actually youre making a mess of it all,simply open cmd or run,type: services.msc  in msc,scroll to the service,double click,reset it to "delayed start" exit msc.....
    Tuesday, July 11, 2017 5:04 PM