none
Changing the Windows 7 downloads folder back to default? RRS feed

  • Question

  • Hi there.

    Completely new to these forums, so apologies if this is posted in the wrong place.

     

    I recently (re)installed Windows 7, on a Solid-state drive. As I obviously don't want it being rapidly filled up with downloads, I moved my downloads folder to D:, a 1TB hard drive. However, I forgot to direct it to 'D:\Downloads,' and instead it is now located in the root of the dive. This means that my default downloads location is D:... which is incredibly annoying, as having stuff pile up in the root of a drive is something I hate. I can't change its location, as now instead of 'Downloads' on the start menu, I now have 'Windows 7 Storage I' replacing it, and if I right click>properties, the HDDs properties menu comes up, instead of the downloads one. How can I move my Downloads default to another folder, or at least reset it to default?

     

    Thanks.

    Tuesday, October 26, 2010 4:43 PM

Answers

  • Are you sure you right-click on the folder but not in the blank part of the window? You can single click on the folder Downloads, then right-click on the folder, select Properties->Location and click the button Restore to Default.
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by blootack Saturday, October 30, 2010 10:48 PM
    Friday, October 29, 2010 6:13 AM
    Moderator

All replies

  • Make sure the Downloads folder is created on your D drive and change the key located in the registry key below.  There value won't be named downloads but you can determine which value it is by looking at the data.  Should have D: as the value.  You will want to change it to D:\Downloads

     [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders]

    • Marked as answer by blootack Tuesday, October 26, 2010 5:24 PM
    • Unmarked as answer by blootack Tuesday, October 26, 2010 5:36 PM
    Tuesday, October 26, 2010 5:12 PM
  • Make sure the Downloads folder is created on your D drive and change the key located in the registry key below.  There value won't be named downloads but you can determine which value it is by looking at the data.  Should have D: as the value.  You will want to change it to D:\Downloads

     [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders]

    Thanks, but it doesn't seem to have worked. The D: drive still shows up in start menu, and downloads still save (by default) to here.
    Tuesday, October 26, 2010 5:35 PM
  • Blootack,

    Did you log off after making this change to the registry?

    Regards,

    Craig Huck, www.integritasystems.com

    Tuesday, October 26, 2010 8:23 PM
  • I restarted, which I assume has the same effect :)
    Wednesday, October 27, 2010 3:06 PM
  • Are you sure you right-click on the folder but not in the blank part of the window? You can single click on the folder Downloads, then right-click on the folder, select Properties->Location and click the button Restore to Default.
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by blootack Saturday, October 30, 2010 10:48 PM
    Friday, October 29, 2010 6:13 AM
    Moderator
  • Hi,

    Launch internet explorer and press CTL+J. A pop-up windows will open with showing details of all running & finished download. At the left bottom corner of this pop-up window, select the Option option. One more pop-up windows will open where you can change your default download location. Then OK and Close.

    Hope it will help :)

    Friday, July 20, 2012 5:48 AM