locked
ccmsetup's version does not match ccmeval's version (x64 only) RRS feed

  • Question

  • I'm seeing a Client Check error on all of my 64-bit servers in ConfigMgr 2012. Under the "Client Check Detail" tab there's an error which says "ccmsetup's version does not match ccmeval's version."

    I double checked on one of the servers and the file versions I get are:

    \Windows\CCM\ccmeval.exe - 5.00.7711.0000 (SCCM.120220-1803)

    \\ccm-server\SMS_XXX\Client\ccmsetup.exe - 5.00.7711.0000 (SCCM.120220-1724)

    I installed the client manually on two of the servers but the rest were installed via client push.

    What can I do to fix this error?

    Thanks

    Tuesday, May 1, 2012 8:02 PM

Answers

  • These seemed to be the result of manually installing the configmgr 2012 client on boxes that already had the 2007 client installed. Doing a client push from the server to client seems to fix it.
    • Marked as answer by PerlStalker Tuesday, May 22, 2012 2:02 PM
    Monday, May 21, 2012 8:40 PM

All replies

  • Hi,

    I've manually installed the CM 2012 client on x64 based OS [Win 2008 R2] and I've not seen that error. What's the OS version on these 2 machines? What command line have you used to install the client? Did a Beta/RC CM 2012 client was installed before? What ccmsetup.log says?


    Bechir Gharbi | http://myitforum.com/myitforumwp/community/members/bgharbi/ | Time zone : GMT+1

    Wednesday, May 2, 2012 1:26 PM
  • The machines are Win 2008 R2. They did not have the beta or RC clients on them but they did have 2007 clients on them. I installed two clients manually but all of the others were installed via client push and they all show the same problem.

    The log shows that the client installation succeeded. Everything works. I can push updates, applications, etc. I just get that weird client health error.

    Wednesday, May 2, 2012 2:06 PM
  • Anything useful in ccmeval.log on those clients (%windir%\CCM\Logs)?

    Torsten Meringer | http://www.mssccmfaq.de


    Wednesday, May 2, 2012 2:17 PM
  • Not much. There's a line that says it's evaluating the rule, then the "ccmsetup and ccmeval version mismatch" error. The next line is:

    "Result: Not Yet Evaluated, ResultCode: 601, ResultType: 202, ResultDetail:"

    (There's nothing after ResultDetail.)

    Wednesday, May 2, 2012 3:40 PM
  • Ditto, seeing the same thing.

    James  

    Friday, May 4, 2012 3:12 PM
  • I am seeing the same thing on my installtion.
    Friday, May 4, 2012 3:34 PM
  • Hi,

    I see you mention the ccmsetup.exe in site folder.

    Can you check the version of ccmsetup.exe in client machine? It is %windir%\ccmsetup\ccmsetup.exe in your client machine.

    Below are the versions which ccmeval compares:

    %windir%\ccm\ccmeval.exe

    %windir%\ccmsetup\ccmsetup.exe

    Tuesday, May 15, 2012 1:29 AM
  • Hi,

    Can you check file version of Windows\ccmsetup\ccmsetup.exe? Maybe ccmeval cannot find a ccmsetup locally..

    Tuesday, May 15, 2012 1:34 AM
  • %windir%\ccmsetup\ccmsetup.exe shows an older file version: 4.00.6487.2000 (SCCM.090918-0032)

    If that's what's being compared, can I simply delete that file or copy the one off of the site server?

    Tuesday, May 15, 2012 8:04 PM
  • I am having the same issue..... was there a solution to this?
    Monday, May 21, 2012 4:25 PM
  • These seemed to be the result of manually installing the configmgr 2012 client on boxes that already had the 2007 client installed. Doing a client push from the server to client seems to fix it.
    • Marked as answer by PerlStalker Tuesday, May 22, 2012 2:02 PM
    Monday, May 21, 2012 8:40 PM
  • I concur, this appears to be a result of upgrading the SCCM client from 2007 to 2012. After pushing the SCCM 2012 client and selecting "Always install the client Software" and "Install the client software from a specific site" check boxes, I receive this error. New builds (Bare metal)via SCCM OSD where the legacy SCCM client do not exist do not show this error.

    I suspect remnants of the legacy client remain during the install of the new SCCM client.

    Tuesday, May 22, 2012 2:51 AM
  • Hi, I also see this error. Clients affected by this are mostly "Active" but client check result is "failed".

    Mostly Windows 7 64 bit machines.

    I tried a puch installation but it did not do much. Even with the "Always Install..."

    Kinda ruins the health overview :/

    Monday, July 9, 2012 9:39 AM
  • I was seeing the same client check failed message "ccmsetup's version does not match ccmeval's version" and thanks to this thread I was able to figure out why. I was testing deploying 2012 clients as a package in 2007. I did do a client push to 2 of them from 2012 and that fixed the client check error. I went back and tried a different install command line and found a combo that works. Try installing the SCCM 2012 client with ccmsetup.exe SMSSITECODE=xxx RESETKEYINFORMATION=TRUE. My client check passed after installing this way. the SMSSITECODE may not be necessary, it is the RESETKEYINFORMATION that makes it work. 
    • Edited by slarocko Tuesday, September 4, 2012 4:55 PM
    Tuesday, September 4, 2012 4:55 PM
  • I tried everything above, including the push install and the RESETKEYINFORMATION=TRUE option for ccmsetup.exe.  At first I thought the push installation worked, but after a while, the client check would fail with the same "ccmsetup's version does not match ccmeval's version" error.  I checked the version of the ccmsetup.exe on the target machine and indeed, the file version was 4.0.6487.2000 instead of the expected 5.0.7711.0000.  I double-checked my installation source and both my manual copy and the copy on the MP were correct.  I tried removing the CCM client using ccmsetup.exe /uninstall, removing the c:\windows\ccmsetup\ folder entirely, then reinstalling.  Again, the error would return.

    So what the heck to do from here?  Well, the installer (and SCCM in general) is very good at logging everything.  Look through your c:\windows\ccmsetup\ccmsetup.log file.  My log showed the correct version (5.0.7711.0000) of the ccmsetup.exe being downloaded from the specified source, installed, and then rebooting the machine (I was using the /forcereboot switch in my manual installation).  After the reboot, there was a log entry showing that ccmsetup had started again, but this time, it was version 4.0.6487.2000.  I immediately knew what the issue was.  We had an entry in our startup script for our workstations that runs ccmsetup.exe version 4.0.6487.2000 for our SCCM 2007 hierarchy.  Consequently, everytime the computer rebooted, it would attempt to install the older version over the newer version.  This would overwrite the ccmsetup.exe in c:\windows\ccmsetup\ with the older version, the older installation would fail, and I'd eventually end up with the "ccmsetup's version does not match ccmeval's version" error.

    I would suggest looking for any installation commands in your startup scripts.  You might even have to look at your client push settings in your SCCM 2007 hierarchy as I bet that could cause the same issue if the older client is pushed to a machine with the newer client.

    • Proposed as answer by Anchovie Monday, October 15, 2012 7:44 PM
    Monday, October 15, 2012 7:44 PM
  • Another possible couase could be if you have WSUS client installation still active in 2007. This was actually the cause in my environment.
    Monday, October 15, 2012 11:30 PM