locked
Permission errors in the virtual environment RRS feed

  • Question

  •  

    Hello,

     

    I have a odd error when sequencing. Basically I sequence on a Windows XP SP2 environment with XML, .NET Framework etc installed locally.

     

    Now, loads of odd permissions error have been showing up. Good to know is that all applications are deployed to a Windows 2003 TS environment.

     

    What happens? Well apparently any file created in the virtual environment only has permissions by the local administrator group. Everything else is wiped.

     

    How have I noticed this? Well, profile-data (%APPDATA%) for MS Project 2007 can't be saved and some errors are given in relation to files not beeing saved. When the user is member of the local administrator group, it works though.

     

    To be honest, I am not sure this is a virtual-issue but more a TS issue - however it only happens in virtual-folders and never on the local ones.

     

    What have failed?

    Spotfire DXP, Project 2007, Navision 3.7 etc etc.

     

    Any ideas?

     

    /Nicke

    Wednesday, October 22, 2008 2:18 PM

Answers

  •  

    Well, sometimes its easier than you thought - however your looking at wrong places.

     

    Client was set to save user-data in a directory where the user has no permissions, moved the application to a different TS-server with a different settings and everything works well...

     

    Just awaiting the RFC to pass through and all servers can be utilized...

    Friday, October 24, 2008 1:27 PM

All replies

  • As you are talking about permissions, I assume that you are using 4.5?

     

    /Kalle

     

    Wednesday, October 22, 2008 7:31 PM
    Moderator
  • During sequencing in 4.5 there is an option before you save to Apply Security Descriptors or something like that.  Reopen the packages and get rid of that check box.  Then resave and test those applicatoins out again.  It could be that the permissions captured are causing the problem.   Deselecting that check box takes it back to the same behavior before 4.5.  Which is where the user will have admin rights in the virtual environment.

     

    mattmcdermott

     

    Wednesday, October 22, 2008 8:49 PM
    Moderator
  •  

    Hello,

     

    Sorry, using the 4.1.something client.

     

    4.5 is awaiting implementation, but not yet though....

    /Nicke

    Thursday, October 23, 2008 2:49 PM
  •  

    Well, sometimes its easier than you thought - however your looking at wrong places.

     

    Client was set to save user-data in a directory where the user has no permissions, moved the application to a different TS-server with a different settings and everything works well...

     

    Just awaiting the RFC to pass through and all servers can be utilized...

    Friday, October 24, 2008 1:27 PM