locked
How to associate the databases restored with Tivoli with Sharepoint RRS feed

  • Question

  • Hello,

    I have two sharepoint environment:

    6 servers in production

    2 servers in test

    All Databases from production have been restored to the Test Server using Tivoli not SharePoint Backup.

    How to associate the databases restored with Tivoli and their SharePoint links, site environment?

    Thanks,

    Dom


    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 / Forefront Client Security / Forefront Identity Manager

    Friday, November 30, 2012 12:14 AM

Answers

  • Hello,

    The conflict for Teams.Mednet.Ucla.edu has been resolved

    The IDs conflicting were

    http://ProdServer:3323/_admin/oldcntdb.aspx?DatabaseId=%7B 44403609-F969-4798-BE64-B33D96890347 Team Mednet on ProdServer current ID trying to be restored...

    http://TestServer:43338/_admin/oldcntdb.aspx?DatabaseId=%7B 44403609-F969-4798-BE64-B33D96890347 SIte restored from DPM previously (before the abandon of DPM replaced by TSM)

    After deletion of the restore done from DPM the restore from TSM works.

    Thanks,

    Dom


    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 / Forefront Client Security / Forefront Identity Manager

    • Marked as answer by Felyjos Saturday, December 1, 2012 4:48 AM
    Saturday, December 1, 2012 4:48 AM

All replies

  • Hi Dom,

    You may refer to this Tivoli documentation to restore SharePoint data:
    http://publib.boulder.ibm.com/infocenter/ieduasst/tivv1r0/topic/com.ibm.iea.tsm/tsm/6.2/clientfunctions/tsm_sp_demo_ho.pdf
    http://publib.boulder.ibm.com/infocenter/tsminfo/v6/index.jsp

    And I would like suggest you to connect Tivoli support for more consultation.

    http://www-947.ibm.com/support/entry/portal/Overview/Software/Tivoli/Tivoli_Storage_Manager_for_Microsoft_SharePoint?S_CMP=rnav

    Thanks & Regards,
    Emir Liu
    TechNet Subscriber Support in forum
    If you have any feedback on our support, please click here.


    Emir Liu
    TechNet Community Support

    Friday, November 30, 2012 8:15 AM
  • Hello,

    Unfortunately I am not using Tivoli for SharePoint but only Tivoli for SQL and then the work has to be done in SharePoint for the rest...

    I have the databases restored on the new server.

    SharePoint is running on the new server.

    I have no web application, no site collection seen within sharepoint???

    What are the next steps in SharePoint to be able to use them?

    - First time?

    - Next Time when already the  web applications have been previously restored?

    I tried also the following command line

    c:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\BIN>stsa
    dm -o addcontentdb -url http://windows7.ad -databasename WSS_window
    s7_content -databaseserver VOTSPRSTR2\MSSQLSERVER

    The server instance specified was not found.  Please specify the server's addres
    s and port.

    But I am getting an error

    Thanks,

    DOm


    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 / Forefront Client Security / Forefront Identity Manager



    • Edited by Felyjos Friday, November 30, 2012 6:41 PM
    Friday, November 30, 2012 3:01 PM
  • Hello,
     
    - Restore all Databases with Tivoli
    - Create a Web Application in Sharepoint for each databases to be restored
    - Remove Content Database WSS_xxxx
    - Add Content Database by changing the name WSS_xxxx by the datbase restored.

    It works on 13 databases so far...
    Two sites do not get their site collection populated !!!
    1 Site is having an ID conflict ...
    The attach operation cannot continue because another object in this farm already contains the same ID.
    Each object in a farm must have a unique ID. In order to proceed with the attach operation you must
    assign a new ID to this database. To attach this database with a new ID, use the "stsadm.exe -o addcontentdb" operation with the -assignnewdatabaseid parameter. Note that if this new database and an existing database contain the same site collections, attaching this database will likely result in orphaned site collections due to conflicts between the two databases. 

    WHere can I list the ID used by the database and see which other database is using the same ID?

    All idea are welcome,
     
    Thanks,
     Dom


    • Edited by Felyjos Friday, November 30, 2012 11:39 PM
    Friday, November 30, 2012 11:05 PM
  • Hello,

    The conflict for Teams.Mednet.Ucla.edu has been resolved

    The IDs conflicting were

    http://ProdServer:3323/_admin/oldcntdb.aspx?DatabaseId=%7B 44403609-F969-4798-BE64-B33D96890347 Team Mednet on ProdServer current ID trying to be restored...

    http://TestServer:43338/_admin/oldcntdb.aspx?DatabaseId=%7B 44403609-F969-4798-BE64-B33D96890347 SIte restored from DPM previously (before the abandon of DPM replaced by TSM)

    After deletion of the restore done from DPM the restore from TSM works.

    Thanks,

    Dom


    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 / Forefront Client Security / Forefront Identity Manager

    • Marked as answer by Felyjos Saturday, December 1, 2012 4:48 AM
    Saturday, December 1, 2012 4:48 AM