locked
Incompatibility Issues with Windows 7 and the TS-L633B DVD-RW Drive RRS feed

  • General discussion

  • There appears to be an incompatibility issue with Windows 7 Home Premium (32 & 64 Bit) and the TSSTcorp CDDVDW TS-L633B ATA Device.  The system works properly with the original system configuration (i.e. Gateway Laptop Model NV5421U with Windows Vista Home Premium 64-Bit), it also works properly when doing an original system recovery, using the disks, to factory default.  However, when the system is upgraded to Windows 7 Home Premium, both the 32 & 64 bit versions were tried, the device becomes extremely unreliable and often disconnects from the system (i.e. it is not visible in both the device manager and in the My Computer window).  Because the system is new, I wrote to Gateway about it and I am still waiting on a response.  Anybody recognizing this as a problem as well?
    • Changed type Arthur Xie Thursday, October 29, 2009 7:45 AM
    • Changed type Arthur Xie Thursday, October 29, 2009 7:46 AM
    • Changed type Arthur Xie Thursday, October 29, 2009 7:48 AM
    Wednesday, October 28, 2009 1:06 PM

All replies

  • Check the Gateway Support website to see of there is a firmware update for the optical drive.  Some optical drives required a firmware update to be compatible with Win 7.
    Wednesday, October 28, 2009 2:16 PM
  • Yea I'm having the same issue on my gate laptop. It works fine when i uninstall my driver and reinstall but then shortly disconnects from system... god its really annoying. I'm thinking that contacting microsoft about the issue may be a better way to go especially since I've heard gateway isn't operating anymore? Keep me posted if possible. thanks
    Friday, October 30, 2009 7:25 AM
  • Yea I'm having the same issue on my gate laptop. It works fine when i uninstall my driver and reinstall but then shortly disconnects from system... god its really annoying. I'm thinking that contacting microsoft about the issue may be a better way to go especially since I've heard gateway isn't operating anymore? Keep me posted if possible. thanks

    Except Microsoft will not provide the solution if it requires a firmware update to the optical drive - that will have to come from the manufacturer/vendor or through Gateway.  Microsoft does not initate software, firmware, nor drivers for other manufacture's/vendor's hardware.

    You can go to the Support website http://www.samsungodd.com/Eng/ and check for a firmware update.
    Friday, October 30, 2009 3:06 PM
  • I thought the same thing and have been looking for a firmware update without success.  Let me know if you come across a firmware update for the device.

    Friday, October 30, 2009 5:45 PM
  • As far as I know, Gateway was taken over by Acer, but I could be wrong.  You can still get support though.  However, I just found out that my unit is currently being supported by Revonate; Phone number 1-866-243-1450.
    Friday, October 30, 2009 5:49 PM
  • Thanks for the tip, will check it out
    Friday, October 30, 2009 5:50 PM
  • Except Microsoft will not provide the solution if it requires a firmware update to the optical drive - that will have to come from the manufacturer/vendor or through Gateway.  Microsoft does not initate software, firmware, nor drivers for other manufacture's/vendor's hardware.

    You can go to the Support website http://www.samsungodd.com/Eng/ and check for a firmware update.

    Ok thanks thats good to know. I checked that site wasn't able to find any firmware updates for ts-l633b cd/rw... I suppose it hasn't been released yet =/. I did however find a quick fix for the issue but it involves turning off the ALPM feature which is responsible for telling the drive when not to run in order to save power... I use this laptop to take notes in class and need all the power management i can get so this is not an option for me.

    If anyone happens to come across firmware update for the ts-l633b please let me  know. thanks
    Friday, October 30, 2009 5:57 PM
  • As far as I know, Gateway was taken over by Acer, but I could be wrong.  You can still get support though.  However, I just found out that my unit is currently being supported by Revonate; Phone number 1-866-243-1450.

    Yea I was told that my gateway warranty was supported by Accer so i assumed they took over too.. I have a gateway NV5814u. have you contacted Renovate? did they say anything about the firmware?
    Friday, October 30, 2009 6:11 PM
  • hello, i'm found firmware in the website samsung odd but in the korean version of the site : check to this link :
    http://www.samsungodd.com/kor/Firmware/FWDownload/FWDownload.asp?FunctionValue=view&no=703&SearchWord=&SearchMode=&PageNumber=1&product_code=SCR
    i've just installed but i don't know yet if it works definitively !

    Tuesday, November 3, 2009 5:56 PM
  • seeing that it's still don't work, i've found another site more interesting here : [html] http://news.softpedia.com/news/Windows-7-RTM-Can-Render-DVD-Drives-Inaccessible-121924 [/hmtl]
    sorry for my bad english i'm french
    Tuesday, November 3, 2009 6:24 PM
  • seeing that it's still don't work, i've found another site more interesting here : [html] http://news.softpedia.com/news/Windows-7-RTM-Can-Render-DVD-Drives-Inaccessible-121924 [/hmtl]
    sorry for my bad english i'm french

    http://news.softpedia.com/news/Windows-7-RTM-Can-Render-DVD-Drives-Inaccessible-121924.shtml
    Tuesday, November 3, 2009 7:49 PM
  • Hello,

    Thanks for the feedback on this.  The article you found directly addresses the issue and the specific problem at hand.  In fact, Microsoft actually identified the specific problem (i.e. the Adaptive Link Power Management (ALPM) feature) and offered a workaround for the problem if the firmware update is not yet available for the DVD device.  I have looked for the firmware update for the "TSSTcorp CDDVDW TS-L633B ATA Device", but have not been successful.  I will try the workaround offered by Microsoft as per the article and see if this helps.

    Thanks again

    Wednesday, November 4, 2009 11:18 AM
  • I am having the exact same problem with the same DVD drive.

    I have tried the workaround via cmd.exe and it didnt work, device still disconnects itself once the tray has been opened.

    Any help with this would be greatly appreciated.

    Also cannot find updated firmware

    Thanks

    EDIT 1: ok, I think I have found the firmware update and for those that it might help it is here

    http://support.dell.com/support/downloads/download.aspx?c=us&l=en&s=gen&releaseid=R224827&SystemID=INSPIRON1545&servicetag=&os=WLH&osl=en&deviceid=19335&devlib=0&typecnt=0&vercnt=1&catid=32&impid=-1&formatcnt=1&libid=32&typeid=-1&dateid=-1&formatid=-1&fileid=321761

    This firmware is for the Dell inspiron 1545, not sure if it will help those with different laptops but I would guess it is pretty standard.

    However, it hasnt helped in my situation as the flash downloader requires that the drive is active, in my case the drive disconnects and therefore the application locks up and appears to be useless.



    EDIT 2: I rebooted the laptop with the DVD tray open, for some reason when I accessed 'my computer' the DVD drive was displaying.

    I then ran the firmware update (I was on TS-L633B (D200), the firmware updated me to TS-L633B (D400). The problem now seems to be solved and the drive is displaying just fine.

    For reference I am running windows 7 Ultimate.

    Hope this helps people.
    • Edited by rob25uk Friday, November 6, 2009 6:40 PM updates to issue
    Friday, November 6, 2009 6:15 PM
  • You could put the DOS update on a DOS bootable flash drive and try updating the firmware that way.

    http://support.dell.com/support/downloads/download.aspx?c=us&l=en&s=gen&releaseid=R224827&SystemID=INSPIRON1545&servicetag=&os=WLH&osl=en&deviceid=19335&devlib=0&typecnt=0&vercnt=1&catid=32&impid=-1&formatcnt=1&libid=32&typeid=-1&dateid=-1&formatid=-1&fileid=321761

    DOS based firmware flash update for TSST TS-L633B slim 8x DVD+/-RW:-

    1. Unzip the TS-L633B_D400.zip into your USB key.
    2. In "Dos" folder, just type "TSDNDOS.EXE L633BD400.BIN".
    3. Just wait for the firmware update completion, you should see "UPDATE SUCCESSFUL" (At this time please reboot your computer) !!
    Friday, November 6, 2009 6:37 PM
  • seeing that it's still don't work, i've found another site more interesting here : [html] http://news.softpedia.com/news/Windows-7-RTM-Can-Render-DVD-Drives-Inaccessible-121924 [/hmtl]
    sorry for my bad english i'm french

    http://news.softpedia.com/news/Windows-7-RTM-Can-Render-DVD-Drives-Inaccessible-121924.shtml

    OK, I tried this workaround and it works perfectly.  Thanks.
    Saturday, November 7, 2009 10:01 AM
  • I am having the exact same problem with the same DVD drive.

    I have tried the workaround via cmd.exe and it didnt work, device still disconnects itself once the tray has been opened.

    Any help with this would be greatly appreciated.

    Also cannot find updated firmware

    Thanks

    EDIT 1: ok, I think I have found the firmware update and for those that it might help it is here

    http://support.dell.com/support/downloads/download.aspx?c=us&l=en&s=gen&releaseid=R224827&SystemID=INSPIRON1545&servicetag=&os=WLH&osl=en&deviceid=19335&devlib=0&typecnt=0&vercnt=1&catid=32&impid=-1&formatcnt=1&libid=32&typeid=-1&dateid=-1&formatid=-1&fileid=321761

    This firmware is for the Dell inspiron 1545, not sure if it will help those with different laptops but I would guess it is pretty standard.

    However, it hasnt helped in my situation as the flash downloader requires that the drive is active, in my case the drive disconnects and therefore the application locks up and appears to be useless.



    EDIT 2: I rebooted the laptop with the DVD tray open, for some reason when I accessed 'my computer' the DVD drive was displaying.

    I then ran the firmware update (I was on TS-L633B (D200), the firmware updated me to TS-L633B (D400). The problem now seems to be solved and the drive is displaying just fine.

    For reference I am running windows 7 Ultimate.

    Hope this helps people.

    My system is a Gateway laptop.  However, I am still going to check the revision levels, and try the update if they are different.  Let let you know how it goes.  Thanks.
    Saturday, November 7, 2009 10:02 AM
  • I did what Rick Dee recommended, and it seems to be working, I have Win7 x64 on a Dell 755 Core2Duo. The dell driver will work on a gateway system too just make sure you indicate the your operating system is either 32 or 64 bit. I couldn't get it working like jeandemo because I could only get it to show up for 3 seconds in windows. I had to go the dos route. I know it is painful but when you have to upgrade 300+ machines you have no choice but to figure it out. I'm going to deploy updates while on Vista for this before we move to 7. Oh in Vista Enterprise this was never an issue and we have been running on that since spring this year, not sure why Ultimate has issues. Thanks, Rick and Jean!
    Thursday, November 12, 2009 4:44 PM
  • On the Dutch Packard Bell site I found the following instructions: 
    click Start, type REGEDIT.
     Look for and remove 
  • HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlClass{4D36E965-E325-11CE-BFC1-08002BE10318}LowerFilters
  • HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlClass{4D36E965-E325-11CE-BFC1-08002BE10318}UpperFilters

  • Restart the computer.

     It solved my problem; perhaps it will help other people.







Tuesday, November 24, 2009 2:14 PM
  • i have the same problem Im using dell inspirion 1545 and it came with windows vista bussiness dell has updated the firmware but there is still another problem the dvd drive has to be recognised by the program inorder to work now how do u do that

    Sunday, November 29, 2009 3:52 PM
  • It didn't work with me I have Dell inspiron 1545 with Windows 7 ultimate 64 bit. It still the same proplem any idea to help fix this problem.
    Friday, February 5, 2010 11:30 PM
  • JoomlaTech wrote:

    It didn't work with me I have Dell inspiron 1545 with Windows 7 ultimate 64 bit. It still the same proplem any idea to help fix this problem.

    Exactly what didn't work for you?  Exactly which DVD drive do you have?
    Saturday, February 6, 2010 2:31 PM
  • I'm getting the same problem with a Samsung R510 Laptop, I spoke to Samsung UK and they didn't know anything about the problem even though I told them to look at the KB article.

    I found this:
    http://www.samsungodd.com/eng/Firmware/FWDownload/FWDownload.asp?FunctionValue=view&no=630&SearchWord=&SearchMode=&PageNumber=1&product_code=SDW&os_no=

    But I cannot seem to get it to work on any system I tried on my XP Mode Ultimate system and it just starts then stops, doesn't perform anything.

    I have contacted Samsung Optical Europe they said that they would email me a solution for the drive but I'm not hopeful in getting anything from them. Samsung UK said they could take the machine in and do the firmware update on the drive, but that means they will have the computer for a few weeks then when I should be able to download and do the update myself.

    I have used the work around for now and that seems to be OK. It would be nice to get a working firmware update though.

    Tuesday, February 23, 2010 3:39 PM
  • Dear Rick
    Sorry I had really busy schedule but appreciate your question. The proplem is I download the TSST TS-L633B 12.7 SATA Trayload 8X DVDRW but it didn't work. My labtop is Dell inspiron 1545 with windows 7 ultimate. And I don't know exactly how to do the update through Dos. Can you explain the details ?

    Thank you so much
    Wednesday, February 24, 2010 5:01 AM
  • I too have a Samsung R510 and Samsung are ignoring me.  This is problem is so annoying as since installing Windows 7 I can't reinstall Adobe CS4 software and am unable to work.  I've been battling with this for days.  I had come across the Windows regedit fix, but don't have the 'upper' and 'lower' entries.   Tried installing the Samsung Firmware available on the Downloads  - no difference.  I will try this work around......Is Windows 7 really worth it? I want my life back!
    Saturday, February 27, 2010 8:54 PM
  • Can Anyone Help Me too?

    I have a Samsung R509. Using XP or Vista my TS-L633B works fine. When i tried to install Windows 7 my CD DVD Driver is gone to holidays...

    I've downloaded your firmware but .. when i run that program inside, i'm not able to find anything

     

    i need your help thx

    Sunday, March 21, 2010 12:41 PM
  • I already fixed this problem in my Lenovo G550. Everything would be fine with that latest (SC01) firmware available at: http://www.samsungodd.com/Eng/Firmware/FWDownload/FWDownload.asp?SearchMode=TOTALSEARCH&SearchWord=TS-L633B<sup>*</sup> but it fits only pure Samsung-branded drives. In my Lenovo I had TSST TSL633B LE03 drive, so One Click Firmware Update couldn't work because of that LE03 part of the drive's name.

    What I finally did was extracting 'TS-L633B_SC01.exe' (you can use 7zip to do it) onto my hard drive (this file is just compressed archive).

    TS-L633B_SC01.exe consists of two packed files:

    • TSDNWIN.EXE
    • TS-L633B_SC01.bin (which is the firmware itself)

    Then I opened the BIN file in HEX editor and replaced all of the 'SC' and 'SC01' words with 'LE' and 'LE03'.

    Yes, It's very risky but it works for me :) Finally I just ran TSDNWIN.EXE and used modified BIN file.

    Sorry for my English.

    http://www.samsungodd.com/korlib/download.asp?no=&fname=TS-L633B_SC01.exe&path=/UploadFiles/FW/FWDOWNLOAD/ - for 'direct' download.

    Sunday, March 21, 2010 7:34 PM
  • i'm not able to find firmware, i have TDSWIN.EXE bot not firmware and i think that i will not able to use HEX Editor, have u your files already modified?

    thx very much
    Sunday, March 21, 2010 11:40 PM
  • IM HAVING THE SAME PROBLEM WITH MY DELL INSPIRON 1545 DVD DRIVER
    Saturday, April 17, 2010 11:25 PM
  • It is very easy solution to this problem
    to download this software "is the original uncompressed firmware from Samsung"

    http://www.4shared.com/file/00bUvpcX/TS-L633B_SC01.html

    Unpack the drive C:
    Hit star \ Accessories \ Command Prompt "press the right mouse button" run as administrator
    Type

    cd \
    Powercfg.exe-setacvalueindex 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c-9041 0012ee47-4b5d-9b77-535fba8b1442 DAB60367-4fbc-53FE-825E-521D069D2456 0

    Powercfg.exe-setdcvalueindex 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c 0012ee47-9041-4b5d-9b77-535fba8b1442 DAB60367-53FE-825E-4fbc-521D069D2456 0

    Powercfg.exe-setacvalueindex 381b4222-f694-41f0-9685-ff5bb260df2e 0012ee47-9041-4b5d-9b77-535fba8b1442 DAB60367-4fbc-53FE-825E-521D069D2456 0

    Powercfg.exe-setdcvalueindex 381b4222-f694-41f0-9685-ff5bb260df2e 0012ee47-9041-4b5d-9b77-535fba8b1442 DAB60367-4fbc-53FE-825E-521D069D2456 0

    Powercfg.exe-setacvalueindex a1841308-3541-bc81-4fab-f71556f20b4a 0012ee47-9041-4b5d-9b77-535fba8b1442 DAB60367-4fbc-53FE-825E-521D069D2456 0

    Powercfg.exe-setdcvalueindex a1841308-3541-bc81-4fab-f71556f20b4a 0012ee47-9041-4b5d-9b77-535fba8b1442 DAB60367-4fbc-53FE-825E-521D069D2456 0

    restart your computer

    Hit star \ Accessories \ Command Prompt "press the right mouse button" run as administrator

    cd \
    Tsdnwin.exe -nocheck
    I choose software
    TS-L633B_SC01.bin
    And after the trouble

    Friday, May 21, 2010 10:18 AM
  • It appears I could fix this issue on my ACER Aspire 5738G x32 with upgrade to Win 7.

    Deleting upper & lowewr filters did no good, FixWin did not help.

    I went to ACER service & support section and downloaded and ran (as administrator) the following drivers

      Chipset   Intel   Chipset Driver   9.1.1.1015   4.7 MB   2009/10/01

      SATA   Intel   SATA Driver AHCI   8.9.0.1023   21.4 MB   2009/10/22.

    Make sure you power down your system to allow for the new driver to load.

    Only doing "restart" did not work. Only after full power up I coulfd get the message that the new driver for TSSTcorp CDDVDW TS-L633B ATA got loaded.

    Since then I tried loading, ejecting, writing & erasing DVD & CD's, bot Read ONly and Rewritable. No way to reproduce the previous problem.

    I hope it can be of any help to someone.

    Thursday, May 27, 2010 1:56 PM
  • I have posted a solution that worked for me at my blog. Try it out and see if it works for you as well. Solution is for Dell inspiron.  

    http://maunilpatel.blogspot.com

    Wednesday, July 14, 2010 6:51 AM
  • There appears to be an incompatibility issue with Windows 7 Home Premium (32 & 64 Bit) and the TSSTcorp CDDVDW TS-L633B ATA Device.  The system works properly with the original system configuration (i.e. Gateway Laptop Model NV5421U with Windows Vista Home Premium 64-Bit), it also works properly when doing an original system recovery, using the disks, to factory default.  However, when the system is upgraded to Windows 7 Home Premium, both the 32 & 64 bit versions were tried, the device becomes extremely unreliable and often disconnects from the system (i.e. it is not visible in both the device manager and in the My Computer window).  Because the system is new, I wrote to Gateway about it and I am still waiting on a response.  Anybody recognizing this as a problem as well?

    Since this is so old, maynot be of use, but did anyone having these issues try the upper/lower filters registry fix? that seems to always work for me, when the drive just disappears from My Comptuer.

     

    http://support.microsoft.com/kb/929461/en-us

    Tuesday, July 27, 2010 7:30 PM
  • Just asking: the Dell Inspiron - is it Inspiron 1545 or anything else?

    the driver link you gave - would it work with Dell Inspiron 1545 bought on July 2009?

    Sunday, August 22, 2010 5:26 PM
  • Thanks for the link, Rick! this was the one that actually worked so far!! :D
    Sunday, August 22, 2010 6:45 PM
  • Microsoft informou os clientes das questões relacionadas com a mais recente iteração do cliente Windows, em que o Windows 7 não jogar bonito com a unidade de DVD. Acordo com a empresa de Redmond, os usuários têm relatado problemas em que o Windows 7 é incapaz de reconhecer a unidade de DVD após a instalação. Questões também têm sido chamaram a atenção da Microsoft sobre upgrades de Windows 7. Ao mesmo tempo, os problemas parecem afectar Windows Server 2008 R2, além de Windows 7.

    "Este problema ocorre porque o driver SATA (Msahci.sys) implementa nova funcionalidade de gestão de energia que é conhecida como ALPM (Adaptive Link Power Management). Algumas unidades ópticas não se comportam corretamente com ALPM habilitado e podem não ser reconhecidas pelo computador,"Microsoft, explicou.

    A empresa de Redmond também fornecido uma pequena lista de dispositivos que Windows 7 não pode reconhecer após o download, ou após uma atualização. "O seguinte é uma lista de alguns modelos de drive de DVD que são conhecidos por apresentam esse problema: TSST TS-L633B e PLDS DS-8A3S," Microsoft afirmado.

    A Microsoft não oferece uma actualização para este problema, mas os clientes afetados por este problema específico podem acessar e implementar um hotfix através do suporte da Microsoft. Como alternativa, o software gigante documentou um workaround manual projetado para permitir que os usuários finais manualmente resolver o problema. Os clientes Windows 7 precisará manualmente desativar os planos de energia ALPM ativos em suas máquinas e elaborar um plano de energia nova.

     

    “To manually disable the existing ALPM power plans on the computer, at a command prompt, type the following commands and then press ENTER after each command:
    powercfg.exe -setacvalueindex 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c 0012ee47-9041-4b5d-9b77-535fba8b1442 DAB60367-53FE-4fbc-825E-521D069D2456 0

    Powercfg.exe -setdcvalueindex 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c 0012ee47-9041-4b5d-9b77-535fba8b1442 DAB60367-53FE-4fbc-825E-521D069D2456 0

    Powercfg.exe -setacvalueindex 381b4222-f694-41f0-9685-ff5bb260df2e 0012ee47-9041-4b5d-9b77-535fba8b1442 DAB60367-53FE-4fbc-825E-521D069D2456 0

    Powercfg.exe -setdcvalueindex 381b4222-f694-41f0-9685-ff5bb260df2e 0012ee47-9041-4b5d-9b77-535fba8b1442 DAB60367-53FE-4fbc-825E-521D069D2456 0

    Powercfg.exe -setacvalueindex a1841308-3541-4fab-bc81-f71556f20b4a 0012ee47-9041-4b5d-9b77-535fba8b1442 DAB60367-53FE-4fbc-825E-521D069D2456 0

    Powercfg.exe -setdcvalueindex a1841308-3541-4fab-bc81-f71556f20b4a 0012ee47-9041-4b5d-9b77-535fba8b1442 DAB60367-53FE-4fbc-825E-521D069D2456 0,” Microsoft explained.

     

    A operação de criação de um novo plano de energia é bastante simples. Os usuários precisam fazer o seu caminho para painel de controle, opções de energia e no painel de navegação, selecione Criar um plano de energia. Os clientes poderão adaptar o novo plano de energia de acordo com suas preferências e até mesmo dar-lhe o rótulo de sua escolha.

    Tuesday, August 24, 2010 11:04 PM
  • Hi Binek. Can u pls send me the BIN file that u already modified. Cause i dunno how to modified it. How to open the BIN file? What is the HEX editor? Thanks.
    Monday, October 11, 2010 6:45 PM
  • As I have just discovered, Samsung TS-L633B AC01 in my Acer Aspire 4736 is not compatible with windows 7 as described in http://support.microsoft.com/kb/975270

    Fortunately, you can crossflash Samsung TS-L633B AC01 to the latest SC01 firmware. Download the latest firmware here: http://www.samsungodd.com/korLib/popup/Download.asp?path=FWDownload&fname=TS-L633B_SC01.exe

    Extract the file using winrar or others. Two files will be extracted: Tsdnwin.exe and TS-L633B_SC01.bin. You won't be able to update the firmware because of different OEM version (AC01 and SC01).

    Therefore you need to force flashing by creating a shortcut to Tsdnwin.exe, edit the shorcut's property 'target' field and add "-nocheck" parameter, e.g: C:\Some Folder\Tsdnwin.exe -nocheck Execute the shortcut and flash your drive.

    Note: Instead of creating a shortcut you can also execute Tsdnwin.exe -nocheck from command prompt. Flashing under XP environment as in BartPE, WinBuilder or similar is beneficial as the drive does not keep disappearing like when under windows 7.

    Wednesday, October 13, 2010 2:08 AM
  • In my Lenovo I had TSST TSL633B LE03 drive, so One Click Firmware Update couldn't work because of that LE03 part of the drive's name.
    Thursday, October 14, 2010 5:31 PM
  • really this work for me on ACER Aspire 5738g, x32

    but the new chipset chipset driver, ahci driver i have found to an another site  

    http://www.nodevice.com/driver/download.html# 

    into the acer site support and services exist old driver chipset driver 9.1.1.1011 not exist new driver 9.1.1.1015 also and for ahci driver...

    thnx so much Dany_m5 for your helpful 

    Friday, November 26, 2010 3:01 PM
  • Yes, i'm currently experiencing the same problem with my ACER Aspire 4736Z laptop when the OS was upgraded to Windows 7
    Monday, January 10, 2011 6:08 PM
  • Thanx Rob25uk:

    I tried the second option but with the DVD drive open but it did not work.  However, I found pushing the open button made the drive appear.  I opened the drive and repeatedly pushed the open button until the firmware update completed.  The system rebooted and the drive has remained there.

    I am running Windows 7 professional on this system.  I have not had any problem with my Dell running Windows 7 Ultimate

     

    Wednesday, January 12, 2011 12:32 AM
  • Thanx Rob25uk:

    I tried the second option but with the DVD drive open but it did not work.  However, I found pushing the open button made the drive appear.  I opened the drive and repeatedly pushed the open button until the firmware update completed.  The system rebooted and the drive has remained there.

    I am running Windows 7 professional on this system.  I have not had any problem with my Dell running Windows 7 Ultimate

     

    Thanks Swampmice

     I did the exact same process and it worked for me.

    Tuesday, January 18, 2011 9:43 AM
  • I tried the second option but with the DVD drive open but it did not work.  However, I found pushing the open button made the drive appear.  I opened the drive and repeatedly pushed the open button until the firmware update completed.  The system rebooted and the drive has remained there.

    really works thank

    Sunday, February 6, 2011 2:20 AM
  • EDIT 2: I rebooted the laptop with the DVD tray open, for some reason when I accessed 'my computer' the DVD drive was displaying.

    I did the trick and it worked! Can you believe this? YES! Why? Because it is Microsoft. The problem is with the SC01. My previous verison was SC00 (TS-L633B_SC01.bin).

     

    I have Samsung R510, like some of you here. I read thru all the posts and everyone help me somehow, so thank you, guys! I appreciate it!

    Saturday, March 5, 2011 9:43 PM
  • Thanks Dany, I did what you suggested and it worked for me...
    Wednesday, March 30, 2011 6:37 PM
  • This is funny Rob25uk....i have the same model, same windows and same issue..i did exactly the same, restarted with the drive opened and did the firmware...only difference is that mine was D400 already so i did it anyway and then restarted the system. Now it looks fine :) thx for the open drive tip!!
    Tuesday, April 19, 2011 11:17 PM
  • You could put the DOS update on a DOS bootable flash drive and try updating the firmware that way.

    http://support.dell.com/support/downloads/download.aspx?c=us&l=en&s=gen&releaseid=R224827&SystemID=INSPIRON1545&servicetag=&os=WLH&osl=en&deviceid=19335&devlib=0&typecnt=0&vercnt=1&catid=32&impid=-1&formatcnt=1&libid=32&typeid=-1&dateid=-1&formatid=-1&fileid=321761

    DOS based firmware flash update for TSST TS-L633B slim 8x DVD+/-RW:-

    1. Unzip the TS-L633B_D400.zip into your USB key.
    2. In "Dos" folder, just type "TSDNDOS.EXE L633BD400.BIN".
    3. Just wait for the firmware update completion, you should see "UPDATE SUCCESSFUL" (At this time please reboot your computer) !!


    YEAH!!!!! THANK'S A LOT MAN!!! It works perfectly, I was angry with this problem, but now is everything perfect. (Sorry my english).

    Amigos brasileiros, caso alguém tenha esse problema e caia nesse forum, essa dica resolveu totalmente.

    Sunday, May 22, 2011 11:02 PM
  • I had the same problem with my Acer Aspire, Win 7 Pro and the TSST TS-L633B drive.

    I contacted Acer and they sent me the following :-

     

    Why does the DVD drive or Blu-Ray drive disappear after upgrading to Windows 7?

    After upgrading to Windows 7, the notebook may not detect the DVD drive or Blu-Ray drive due to a compatibility problem between the Windows 7 driver and the Optical Drive firmware. Updating the storage driver may resolve the issue.

    SOLUTION

    Updating the storage driver:

    1. Visit the Download section of Acer support website.
    2. Select Product Family, Product Line and then your specific Product Model.
    3. Click the Operating System drop-down arrow and select your current version.
    4. Select the Driver tab and then click the orange arrow next to Intel SATA AHCI Driver version 8.9.0.1023 or later.
    5. Click Save and select where you want to download the file.
    6. For additional information on how to install the downloaded driver, please visit Installing a downloaded driver on Windows Vista or Windows 7.

    MORE INFORMATION

    For Aspire Timeline 4810T and 5810T, it is also recommended to download the OpticalDriver PM application. Follow these steps:

    1. Visit the Download section of Acer support website.
    2. Select Product Family, Product Line and then your specific Product Model.
    3. Click the Operating System drop-down arrow and select your current version.
    4. Select the Application tab and then click the orange arrow next to OpticalDrive PM.
    5. Click Save and select where you want to download the file.
    6. For additional information on how to install the downloaded driver, please visit Installing a downloaded driver on Windows Vista or Windows 7.

    The storage driver was downloaded and it worked perfectly for me and should work for gateway laptops.

     

    Friday, October 21, 2011 1:50 PM
  • I had the same problem with my Samsung laptop. I solved the problem by installing the updated IMSM driver package (Intel Matrix Storage Manager) provided by Samsung on its driver download site. During the installation prozess an updated cd-rom driver for the TSST TS-L633B as well as an updated hard disk driver were loaded.
    • Edited by kalanag Sunday, January 1, 2012 9:58 AM
    Sunday, January 1, 2012 9:56 AM
  • For DELL 1545 Just update to the latest AHCI driver from Intel. It solved the problem right away , pronto!

    Go to your Pc "DELL-PC" in my case, go to file and then system properties, then device manager, go to IDE ATA/ATAPI controllers

    ,go to intel ICH9-E/M  SATA AHCI Controller and update software. Place the updated software in a folder you can easily remember it will decompress to a folder named AHCI.

    This for Win7 and DELL 1545 laptop. , But you can work out for any other pC laptops and other brands.

    If yours is a DELL that has ICH7 or 8 it will not give you this problem due to the idiosync. of WIn 7 or 8. I have another old DELL that was upgraded frpm VISTA  Home premium to Win7 it has no problems with the CDRW drive this I found out that it had ICH7 that was upgraded through the installation. happy trying. DO NOT upgrade to a different ICH version I dont know what will happen to your PC maybe it wont bootup.

    Thursday, May 10, 2012 12:21 PM