locked
Mouse and Audio stutter/freezes with Intel ICH9R AHCI drivers RRS feed

  • General discussion

  • edit: Initially (in original post) I suspected the random mouse and audio stutter/freezes were from a driver update. However between a reboot during these updates I had disconnected an eSATA cable from a drive that was not powered. It turns out the ICH9R when running in AHCI or RAID mode with appropriate drivers installed has problems with some HDDs when the drive isn't powered but the SATA data cable is connected. This is quite normal in SATA enclosures which I have plenty.

     

    What makes this more puzzling is that the stutter/freezes are very tiny and hard to notice IF you don't have any PCI cards connected. With a Intel 100 Mbit PCI NIC connected these stutters became real blocking issue that would have prompted me to return this Gigabyte G33 motherboard (Also affects P35) to the shop had I noticed this issue sooner. I'm not yet sure whether this stutter w/ AHCI/RAID issue affects only the Gigabyte boards but what is certain is that it does affect these in quantity based on how there's others reporting the exact same issue if googling around.

    Wednesday, September 26, 2007 12:05 PM

All replies

  • edited the first post after further experiments and research

    Wednesday, September 26, 2007 12:44 PM
  • This issue has been confirmed not to be limited to just my system.

     

    http://forums.microsoft.com/msdn/showpost.aspx?postid=1196678&siteid=1&sb=0&d=1&at=7&ft=11&tf=0&pageid=5

     

     androidi wrote:

    Same problem here, it's not limited to Vista, also happens on XP/2003 both 32/64 bit. I'm 99% sure it's to do with the Intel AHCI/Matrix storage driver. It'd be interesting to know what your motherboard brand/model is. Mine is Gigabyte DS2R and I've seen reports of this issue on other forums as well. I'm using the integrated Intel graphics and every component is Intel except Audio Realtek and Network Broadcom. The issue goes away by disabling AHCI/RAID but you lose hot-swap of SATA drives and NCQ.

     

    The primary indicator for this issue is that if any of the SATA ports has a drive that is plugged in but not powered up (and not powered down by the AHCI driver programmatically) then you get this global stutter/studder/hickups/choppy. In audio it sounds like tiny repeats. How bad it is seems to depend on what drive brand is plugged in etc so on some combinations it's very tiny and doesn't happen that often, on other drives it's more constant and easy to detect.

     

    I'd suggest you report at:

    http://supportmail.intel.com/scripts-emf/welcome.aspx?id=

    Chipsets/Chipset software/Matrix storage Technology

     

    btw. My AHCI BIOS/OROM version that is shown on boot with AHCI/RAID enabled is iSRC 1.07 08042006, what's yours?

     

     

     nada_clue wrote:

    Though most posts in this thread involve laptops and many of them attempt to isolate the problem in wireless network adapters, let me assure you the same problem can show up in a desktop with wired-ethernet-only. (Admittedly, it's a Realtek onboard gigabit LAN, and Realtek has been fingered by a number of you for its drivers, at least its audio drivers.)

     

    On a brand new core2-quad P35 chipset machine with 4GB ddrII, with a completely clean install of Vista 32 business, I have been suffering intermittent global stuttering. It affects not only audio (of any sort, through any player, whether or not dsp-enhanced) but also video (you can see it in screen saver motion, for instance) and even cursor or mouse movement (hit and hold the spacebar in a text editor and watch the stuttering fun begin!). It's intermittent but not random; that is, it can disappear for a while after I apply one of my stab-in-the-dark fixes (read on) but can come back and then generally remains until I re-apply a fix. It's been like this since about day 1. Well, maybe day 2 or 3.

     

    I've seen so many variants of this problem posted in so many forums, with so many theories, that I could spend the next three months doing nothing but troubleshooting it, assuming I had the budget and time to try endless substitute components or re-builds from scratch, but there's no assurance any or all of that would actually fix it. I do have the Intel Storage Matrix AHCI drivers pre-installed, and Intel itself vaguely alludes to possible 'degraded performance in Vista' with regard to those drivers--is this what they're talking about? They don't say. I do have an Nvidia 8800gts, and Nvidia forums are full of complaints about unacceptable issues with their video drivers, but again it's vague, no smoking gun for global stuttering. I have tried THREE different audio configurations--the onboard realtek hi-def; an x-fi elite; and a c-media based Omega Claro card. I have the problem with all of them. Discovering how musical the c-media card is was a happy accidental side effect of this miserable odyssey, but it really just makes it more frustrating, since I now want to listen to music more than ever but can't find a permanent solution to this vexing problem.

     

    One of the weirdest symptoms is that the stuttering can re-appear (if it has been gone for a few days) just by connecting an external SATA drive, even if the drive is not turned on! Equally weird: simply going into the BIOS and just looking, changing nothing, exiting without saving, can cause it to reappear upon re-boot!

     

    And to ice this cake of weirdness, here are some things that can make it go away (sometimes, at least for a while): removing the external SATA drive and rebooting; removing and re-seating the cards on the motherboard; and clearing the BIOS (jumper or pull out the battery) and then re-entering all the same settings as were there already.

     

    The symptoms are driving me nuts, as audio is one of my main uses for a computer, but it's the HUH? quality of these various actions that can seem to make the problem disappear or re-appear that are really threatening my sanity. If anybody can sift a better clue out of these ashes of frustration than I can, I wish you would post it.

    Monday, November 5, 2007 7:54 AM
  • Hi androidi,

     

    Been pulling my hair out (not much remaining, not much to start with..) over this problem for the last week.  THANK YOU for you post!

     

    I've built a system where I can clone between raid, ahci and legacy mode on the ich9r controller and support ahci (hot swap) on the jraid controller.  Tested and everything worked great.  But of course my testing had all drives that were connected to the ich9r attached and powered - no mouse stutter.  Proceeded to do a full build using raid0 and built my image.

     

    Then cloned to a single ahci (ich9r) drive but wanted to leave the array in tact, so just removed power to those drives leaving the interface cables attached,, you know the rest.  Task Manager cpu would jump up every few seconds, mouse stutter/freeze and then cpu would drop.  My first thought - the problem was associated with iastor.  Latest drivers installed, searched and searched no hits on my problem.  Then thought I needed to set ahci instead of raid in the bios - nope.  Then thought maybe upgrade the bios - no joy.  Then thought it was somehow related to my build so went back to a basic F6 install - still broken.  So thought ok, I'll turn the ich9r into an ide controller - no raid/ahci and turn ide legacy support back on.  Built the drive and the same problem - mouse stutter!  What's left I asked myself - maybe it's a native ich9r problem and not an iastor problem.  My very next search found your post.

     

    So, this was on a Gigabyte P35-DS3P with latest F9 bios.

     

    Thanks again,

     

    P2


    Tuesday, January 29, 2008 9:01 PM
  • An update.  I reported the problem to Intel and here's their response:

    "This is not an issue with the Intel(R) 82801IR I/O Controller Hub (ICH9R) at all. We have tested different motherboards based on this I/O Controller Hub and we have not replicated such issue.
    Please contact your motherboard manufacturer, in this case Gigabyte*."

    Maybe, however it seems Asus have the exact same problem with their ich9r implementation....

    http://www.xtremesystems.org/forums/archive/index.php/t-156336.html

    In my case ATM  it's only a minor inconvenience for me to disconnect interface cables from non-powered drives attached to the ich9r.

    Cheers,
    P2

    Wednesday, January 30, 2008 9:22 PM
  • Same problem here.  I'm using an Asus P5K-E motherboard (P35 chipset) & XP pro.  I knew that running in non-raid mode fixed the problem & was already blaming the Intel Matrix RAID drivers.  I run a hot-swap SATA enclosure in one of my 5.25 bays.  Sure enough, if a drive is in place & powered up, no problem.  Turn the drive off, stuttering returns.


    I don't see how this can be a motherboard issue but I've been wrong before.  Just wanted everyone to know that this problem is definitely not just a Gigabyte thing.  If anyone makes any headway please post your solution.  Thanks

    Sunday, February 17, 2008 9:20 PM
  • Thanks guys for reporting back. I'm shopping for another motherboard right now with ICH9R and will report here if the problem exists in whatever I get or whether Intel is just shipping broken units of the ICH with this problem.

     

    The only 100% working solution I know is to get $20 4-port Silicon Image chip based SATA controller. I did found one from ebay and there's no problem using it, hot swap and everything is good however it has no NCQ support but given recent very thorough tests I can conclude that NCQ is only good to use if you have a very new Seagate 7200.11 SATA model. With other brands and models the NCQ implementation in drives seems thrown in as afterthought and will either worsen or not affect perf.

    Sunday, February 24, 2008 7:50 AM
  • I'm getting the exact same problems on a Abit IP-35 Pro motherboard, which is also ICH9R based.

     

    Other hardware (perhaps there's a pattern to that as well):

     

    Intel Q6600

    Nvidia 8800 GTS 640mb

    4x2GB PC2-6400 Memory

    Running 2 samsung T166 320GB discs in raid 0.
    Wednesday, February 27, 2008 7:12 PM
  • So to add a wrench to the theories.  I've got the Asus P5K with a Quad core processor, 4 gigs ram and a 3850 video card and the difference is I have a single ATA hard drive and single ATA DVD drive.  Running windows vista basic.  Choppy video and audio with all video players and pretty much any type of video I can find as well as any audio.  Problem is also with video in games and audio in games as well.  Jumpy mouse as well.  Suggestions very welcome...
    Friday, February 29, 2008 7:17 AM
  •  androidi wrote:
    It turns out the ICH9R when running in AHCI or RAID mode with appropriate drivers installed has problems with some HDDs when the drive isn't powered but the SATA data cable is connected.

    The new Intel® Matrix Storage Manager ver 8.2.0.100 (released 6/2/2008) seems to fix this. Finally..
    Been waiting for Intel to fix this thing for a great while now. About bloody time.
    Sunday, June 1, 2008 5:15 AM
  • I am using 8.2.0.1001 and I am still having the stuttering issue.
    Wednesday, July 2, 2008 5:33 AM
  • I put together a build over a month ago:


    Thermaltake W0116RU 750W Complies with ATX 12V 2.2 & EPS 12V version Power Supply 

    Microsoft Windows Vista Ultimate SP1 64-bit

    Western Digital Caviar SE16 WD5000AAKS 500GB 7200 RPM SATA 3.0Gb/s Hard Drive

    EVGA 512-P3-N845-AR GeForce 8800GTS (G92) KO 512MB 256-bit GDDR3 PCI Express 2.0 x16 HDCP Ready SLI Supported Video Card

    OCZ Reaper HPC 4GB (2 x 2GB) 240-Pin DDR2 SDRAM DDR2 1066 (PC2 8500) Dual Channel Kit Desktop Memory Model OCZ2RPR10664GK

    Intel Core 2 Quad Q9300 Yorkfield 2.5GHz LGA 775 95W Quad-Core Processor Model BX80580Q9300 - Retail

    GIGABYTE GA-X48-DS4 LGA 775 Intel X48 ATX Intel Motherboard

     

    The GA-X48-DS4 has an ICH9R.  I spent the better part of a month trying to figure out how to get ACHI and then RAID enabled since I installed both Vista and XP with both functions disabled in the BIOS setup.  After finding many many threads, and trying many things, I was able to get XP to boot without reinstalling.  I had already given up and reinstalled Vista by then...

     

    So I finally get RAID working yesterday, put my two 500G mirror set in from my old machine and I notice that the thing is locking up and stuttering occasionally.  I came across many threads like this one while researching how to get the OSes to boot, and figured there is NO WAY this problem still exists today.  How wrong was I!?

     

    I was playing Hellgate London last night, after playing for a month with ACHI/RAID disabled and not having a problem, it was freezing and the sound was stuttering for 2-3 seconds at a time.  I am seeing the same thing doing normal things today-- copying files around, tying into a text editor.  My brand new, well-powered quad core machine just LOCKS UP for 2 seconds doing menial tasks

     

    I too have the 8.2.1001 version of Interl Matrix Storage Manager installed.  My motherboard has 2 gigabit ethernet ports and the specs from Gigabyte show "Realtek 8111C chip".  All signs say I am in this boat.

     

    Sigh.

    Sunday, July 6, 2008 10:26 PM
  • I just rebuilt my P35-DS3P box and thought id enable AHCI for a laugh - after almost 12 months of running in IDE with no problems, Vista becomes unusable even with 8.2.1001. Sound stutter, mouse lag etc etc

    I simply dont get this, how can people get away it?

    Sunday, August 3, 2008 1:09 PM
  • It is outrageous that such annoying, obvious, and widespread problems such as these have yet to be addressed by either Intel or Microsoft.

     

    Monday, August 4, 2008 6:47 PM
  • SOLUTION:

     

    Intel has created the following Matrix drivers:

     

    8.5.0.1032

     

    As far as I can tell, I am no longer experienceing the stuttering everytime a hard drive spins up.

     

    I lost the download link unfortunaetly, but try here:

     

     

    http://www.msfn.org/board/Integration-of-Intel-Sata-and-Raid-drive-t107504.html&st=240&p=784410

    Saturday, August 9, 2008 4:09 AM
  •  

    After further testing I can confirm that I am no longer experiencing the studder/freezing everytime a hard driver powers up.

     

    Now only if Intel would fix the drivers to detect when an ESATA connection is plugged in.....

    Saturday, August 9, 2008 10:34 PM
  • pczeilon said:

    Same problem here.  I'm using an Asus P5K-E motherboard (P35 chipset) & XP pro.  I knew that running in non-raid mode fixed the problem & was already blaming the Intel Matrix RAID drivers.  I run a hot-swap SATA enclosure in one of my 5.25 bays.  Sure enough, if a drive is in place & powered up, no problem.  Turn the drive off, stuttering returns.


    I don't see how this can be a motherboard issue but I've been wrong before.  Just wanted everyone to know that this problem is definitely not just a Gigabyte thing.  If anyone makes any headway please post your solution.  Thanks



    This problem is actually not with the ICH9R chipset drivers, but with the ancillary JMicron eSATA RAID drivers.  The version of the JMicron driver on asus.com is completely outdated and does not contain a critical fix for write-back cache latency (shame on you, asus).  Note: this JMicron driver is an issue even if you don't have any eSATA drives connected. 

    First, update to the latest JMicron JMB36X drivers -- get the one with write back cache disabled:
        ftp://driver.jmicron.com.tw   ( ftp://driver.jmicron.com.tw/jmb36x/Win2k_xp_Vista/JMB36X_WinDrv_R1.17.47.07_eSATA_WriteCacheDisabled..zip )

    Second, make sure you have the latest Intel Matrix Raid Manager and INF Update Utility installed:
        http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldId=16023&lang=eng
        http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldId=17268&lang=eng


    I personally have 2x750GB drives in Intel Matrix RAID 1 configuration, and I was experiencing occasional stutter in video playback until I updated the JMicron drivers.  Note: this is an issue for any motherboards with a JMicron eSATA controller, not just the Asus P5K-E.  (See Abit IP-35 Pro complaint above).
    Tuesday, February 17, 2009 12:51 AM
  • Ok I know it's been 1 year since the last post but I must thank you guys for getting me to finaly know what was the annoying problem that kept messing my mouse while being on Windows.

    I got a DFI board with P35 chipset and that loosy "ICH9R". I used to be in AHCI then was sick of this mouse issue and something else (Bug on my mobo if I use AHCI I must go in bios then do save&exit or else my computer won't boot) so I went back to IDE but now with a SSD drive I must stay in AHCI to be able to use TRIM on Win7 and get the full potential of my drive but the issues all came back until I saw this thread. Heh can hardly believe I been tolerating this bug for ~6 months if it's not even more.

    Right now I have a (OCZ Agility 2 50GB) and (WD Black 1TB) on Sata-II inside my case but if I kept my external (WD Green 1TB) drive powered off even if I would unplug the eSata cable from the rear bracket of the PCI card (cause my mobo don't have eSata plug), the Sata cable that goes from the mobo to the PCI card (the cable inside) if I kept that one connected then the mouse bug would come back so now either I would have to open my computer pannel everytime I want to use my external case or else I must leave it powered-on. So stupid... my next upgrade is definitely going to be with AMD's X6 1055T and chipset 880G.

    Edit: I confirm that using the very lastest Intel's INF drivers and the (Intel Rapid Storage 9.6) which is the new version of the Matrix Storage program, it didn't fix the issue at all if I kept a "powered-off" sata cable connected on the board.

    Saturday, May 8, 2010 8:12 PM
  • Ok it's been 2 years since this topic was opened.

    I just want to say that i also had problems with the old ICH9R drivers, specially when transferring high volume files. The system would freeze, making impossible to listen a simple mp3. Now, with the new RST Drivers, the problem was solved.

    My motherboard is an Asus Formula Rampage with an X48 and ICH9R. The system works perfectly now :)

    Tuesday, June 22, 2010 10:49 PM
  • Just to keep it fresh...

    Same issue using ICH10R (v. 11.2.0.1066) on an Acer WG43M board.  Disabled the Intel Storage Matrix Manager and all is well.  It's a low profile Gateway with one SATA drive.

    Saturday, January 25, 2014 6:27 PM