none
MDT rebooting before getting to task sequence selection RRS feed

  • Question

  • I have a Windows 10 (1709) image setup on a USB from MDT 6.3.8450.  Works fantastic on all new and recent machines.  However, on SOME older machines, when we boot off the USB, the Windows Deployment Toolkit greyish screen pops up, sits for a few seconds, then reboots.  Keeps rebooting over and over. 

    I did some digging and finally found this old thread - https://social.technet.microsoft.com/Forums/en-US/b8b4fd55-1564-4f5e-9c09-3b97121725df/computer-restart-at-splash-screen-when-deploying-image?forum=mdt

    So I did an F8 as soon as I got to that screen and I was able to get to a dos prompt.  I checked for logs, but not finding anything.  So I ran the litetouch.wsf in debug mode as per the above thread.  Last few lines of output below, nothing really meaningful above it.

    No task sequence is in progress.
    Unable to connect to BCDstore.
    Not running within WinPE or WinRE.
    ......
    SMS Task Sequencer already found on X:\Deploy\Tools\X64
    Copying D:\Deploy\Control\\TS.XML to X:\Deploy\Tools\X64

    And the copy fails because the path is messed up - it's missing the task sequence, which I'm not getting a chance to select.  So not sure if my troubleshooting is even any good.  Does litetouch.wsf/vbs run AFTER selecting a task sequence (I would think so.)  If so, I'm guessing there's something else going on.

    Below is my customsettings.  Again, this works fine on all new machines, so. . .?

    [Settings]
    Priority=Default
    Properties=MyCustomProperty

    [Default]
    OSInstall=Y
    SkipCapture=YES
    SkipAdminPassword=YES
    SkipProductKey=YES
    TimeZoneName=Eastern Standard Time
    SkipDomainMembership=YES
    SkipTimeZone=YES
    SkipBitLocker=YES
    SkipUserData=YES
    SkipLocaleSelection=YES
    KeyboardLocale=en-US
    UserLocale=en-US
    UILanguage=en-US
    SkipSummary=YES
    SkipBDDWelcome=YES
    SkipComputerBackup=YES

    Friday, June 29, 2018 7:35 PM

All replies

  • Hello,

    Is same Offline Media worked in all new machines? Make Sure TS.xml file present in Media under DeploymentShare\Control\<TaskSequenceid>. Try to remove the [x86] section while creating Media, then execute the deployment and see what does it effect


    • Edited by JiteshKumar Saturday, June 30, 2018 5:27 AM
    Saturday, June 30, 2018 5:27 AM
  • I've seen this happening when there are some remnants of an older TS on the HDD. As a Workaround, try opening cmd and then running diskpart:

    diskpart
    sel dis 0
    clean
    exit
    wpeutil reboot


    Cheers,
    Anton

    Vacuum Breather Blog | Wing Commander Saga | Twitter

    Note: Posts are provided "AS IS" without warranty of any kind. If posts are helpful please don't forget to rate them as "Helpful" or as "Answer".

    • Proposed as answer by DBHSITAdmin Friday, September 28, 2018 5:39 PM
    Monday, July 2, 2018 7:58 AM
  • Haven't been able to test this yet, but ts.xml is definitely present. This offline media will boot properly on all newer machines, and even some of the oldest machines we have. Just a handle it had issues with. Had to get the user setup, so stuck with what was on the machine for the time being versus a clean build.
    Wednesday, July 18, 2018 2:45 PM
  • Can't find a ts.xml on the existing drive anywhere. Hesitant to wipe the drive because if we can't get it built, then we have nothing. Will test this theory on a problem machine the next time we can get our hands on one and will try with a spare drive. Thanks for the idea.
    Wednesday, July 18, 2018 2:46 PM
  • I just ran into this exact issue while trying to change some deployment shares around. The task sequence screen never appeared, just the Microsoft Deployment Toolkit background, and then a reboot. I interrupted the process on the next boot with F8 and was unable to find the MININT folder to see the logs. I ran "cscript.exe x:\deploy\scripts\litetouch.wsf /Debug:true /DebugCapture" and saw the line "Copying D:\Deploy\Control\\TS.XML to X:\Deploy\Tools\X64" with the double slashes preceeding TS.xml hinting that the task sequence ID was missing.

    Following your diskpart steps resolved this upon the next boot.

    Friday, September 28, 2018 5:46 PM
  • This helped me enourmously. I would never have guessed to look on the client machine for the problem. Kind of stupid design, really, because you want to boot WinPE to be completely independent from the state of the machine to be imaged. Oh well. Cheers!
    Wednesday, June 5, 2019 2:02 PM
  • I had the same problem as DBHSITAdmin and the diskpart solution fixed it. thanks!
    Tuesday, October 22, 2019 9:49 PM