locked
How to preserve taskbar icon thumbnail preview? RRS feed

  • Question

  • Hi,

    The graphics of my computer is not very fast and the total physical of RAM is 4GB. In windows 7 32-bit Home Premium, sometimes when there are many programs loaded and the memory usage reaches close to 3GB, the system would drastically slow down, making it difficult even for switching between windows.

    At such time Windows 7 would always prompt me whether to “use basic color themes”. I gave a try, but found that a convenient feature which shows thumbnail preview of application windows when hovering mouse over the taskbar icon, has gone.

    In addition, I have also found choose “Windows 7 Basic” in color theme also disables taskbar icon thumbnail preview.

    This by far is the only feature I need for desktop graphics. I would like to ask: when performance enhancement is required so that one want to turn off all fancy graphics, is there a way to preserve the this taskbar icon preview feature?

     

    Thanks and regards,

    Bob

    Wednesday, November 30, 2011 5:07 PM

All replies

  • As far as I can see, you need 32-bit color mode to show the previews. I tested my own by changing it to 16-bit, and instead of the thumbnail preview, I now only see a text box.

    Here's a little bit of information about it: http://windows.microsoft.com/en-US/windows7/What-is-the-Aero-desktop-experience

    ___________________________________________________________________

    Please vote my post as helpful if you think it was, and mark it as
    an answer if it answered
    your question. That will help others
    with the same problem finding the answer. - Thanks.

    Wednesday, November 30, 2011 6:15 PM
  • Ole,

    I think I am always using 32-bit mode. I cannot open the webpage and it loads very slowly.

     

    Bob

    Wednesday, November 30, 2011 6:23 PM
  • Try this:

    1. Right-click Computer and select Properties
    2. Click Advanced System Settings
    3. Click the Settings button under Performance
    4. Select Adjust for best performance and click Apply
    5. Check Enable desktop composition & Use visual styles on windows and buttons and click Apply
    6. Click OK and close the windows you just opened

    ___________________________________________________________________

    Please vote my post as helpful if you think it was, and mark it as
    an answer if it answered
    your question. That will help others
    with the same problem finding the answer. - Thanks.


    Wednesday, November 30, 2011 6:49 PM
  • Ole,

    I have tried this. Thumbnail preview is not enabled, but this would bring the performance issue back.

     

    Bob

    Wednesday, November 30, 2011 6:55 PM
  • Hmm, perhaps your computer and/or video adapter is just not fast enough for that many applications open at the same time.

    What kind of processor do you have?

    Have you tried defragmenting the hard disk?

    ___________________________________________________________________

    Please vote my post as helpful if you think it was, and mark it as
    an answer if it answered
    your question. That will help others
    with the same problem finding the answer. - Thanks.

     

    Wednesday, November 30, 2011 7:10 PM
  • Ole,

    It is an ordinary desktop computer with integrated video card. Perhaps it is just slow.

     

    Bob

    Wednesday, November 30, 2011 7:58 PM
  • Bob,

    You can see the basic system info, if you right-click Computer and select Properties.

    ___________________________________________________________________

    Please vote my post as helpful if you think it was, and mark it as
    an answer if it answered
    your question. That will help others
    with the same problem finding the answer. - Thanks.

     

    Wednesday, November 30, 2011 8:17 PM
  • Bob,

    You can see your basic system info by right-clicking Computer and select Properties.

    Should look like this:

    ___________________________________________________________________

    Please vote my post as helpful if you think it was, and mark it as
    an answer if it answered
    your question. That will help others
    with the same problem finding the answer. - Thanks.

     

    Wednesday, November 30, 2011 9:34 PM
  • Bob,

    You can see your basic system info by right-clicking Computer and select Properties.

    Should look like this:

    ___________________________________________________________________

    Please vote my post as helpful if you think it was, and mark it as
    an answer if it answered
    your question. That will help others
    with the same problem finding the answer. - Thanks.

     

    Wednesday, November 30, 2011 9:53 PM
  • Ole,

    Do you mean this:

    ?

     

    Bob

    Thursday, December 1, 2011 8:35 AM
  • Yes, that's it.

    Your system is pretty good actually. So that's not the problem.

    How much free disk space do you have on your hard drive. If you are low on disk space, Windows won't have enough room for its paging file (virtual memory), and everything will slow down.

    What is your paging file set to?

    1. Right-click Computer and select Properties
    2. Click Advanced system settings
    3. Click the Settings button under Performance
    4. Click the Advanced tab

    EDIT: If you have plenty of free hard disk space, you can increase the size of the paging file, which may let you open up many windows without slowing down the system as much (or any) as it does now.

    ___________________________________________________________________

    Please vote my post as helpful if you think it was, and mark it as
    an answer if it answered
    your question. That will help others
    with the same problem finding the answer. - Thanks.

     


    Thursday, December 1, 2011 1:40 PM
  • Ole,

    This is the virtual memory setting:

    Wouldn't it be better to let Windows manage the virtual memory, as what is being done currently?

    Bob

    Thursday, December 1, 2011 4:10 PM
  • In most cases yes, but since you like to have many windows open at once, increasing the paging file could help with your slowness.

    Currently, you have a little less the 2X your physical memory (RAM) located for your paging file (Virtual Memory) = 7.5 GB.

    I'd suggest setting it to:

    • Initial size (MB): 12,288   <- 12 GB (3X your RAM)
    • Maximum size (MB): 16,384   <- 16 GB (4X your RAM)

    You have plenty of hard disk space (146,460 MB) available, so you should be good.

    You will be prompted to reboot.

    If however you don't feel this change has helped at all, I'd recommend going back and letting Windows automatically manage the size of the paging file again.

    ___________________________________________________________________

    Please vote my post as helpful if you think it was, and mark it as
    an answer if it answered
    your question. That will help others
    with the same problem finding the answer. - Thanks.


    Thursday, December 1, 2011 4:17 PM
  • Ole,

    Virtual memory (VM) uses harddrive space, and is in principle hundreds of times slower than my DDR3 1333MHz memory. When the total memory requirement of all applications plus the Windows system gets close to physical memory size, if VM is enabled then Windows will put some applications’ resources (stack, etc.) onto harddrive, and retrieve them when they are being called again.

    So I think that VM does is to increase the “virtual” memory size at the cost of speed. The decision on which application should be saved to harddrve uses algorithms like maintaining a record and finding the most infrequently used application. However, if the applications are randomly accessed, I wonder whether such an algorithm would still work.

    I in fact have many PDF documents opening at the same time, each using less than 30MB RAM. There are also many other applications running at the same time.

    What is your recommendation if taking above points into discussion?

     

    Bob


    • Edited by Bob Sun Thursday, December 1, 2011 5:30 PM
    Thursday, December 1, 2011 5:07 PM
  • Bob,

    You cannot hurt anything by increasing the paging file, and if it doesn't help you with your slowness, you can just change it back again.

    I just grabbed my "A+" book by David L. Prowse from my book shelf, and it says "if a user runs a lot of programs simultaneously, then increasing the page file might be the answer for performance issues".

    So again, I'd recommend you trying that, and see if it helps.

    Also, I'm sure there's a good reason why you have that many PDF documents open simultaneously, but having that many windows open, especially PDF files, I can understand why your otherwise fast system would fall to its knees.

    If you absolutely have to have all those open, try increasing the paging file.

    ___________________________________________________________________

    Please vote my post as helpful if you think it was, and mark it as
    an answer if it answered
    your question. That will help others
    with the same problem finding the answer. - Thanks.

    Thursday, December 1, 2011 5:25 PM
  • "A+" book by David L. Prowse from my book shelf, and it says "if a user runs a lot of programs simultaneously, then increasing the page file might be the answer for performance issues".

    This is a very general description. What is the theory behind this?

     

    Bob

    Thursday, December 1, 2011 5:29 PM
  • I personally do not know much more about paging files than I've already explained, but you can find tons of information on the Internet if you're interested in more detailed and specific information.

    Here's a blog that might interest you: http://blogs.technet.com/b/askperf/archive/2007/12/14/what-is-the-page-file-for-anyway.aspx

    ___________________________________________________________________

    Please vote my post as helpful if you think it was, and mark it as
    an answer if it answered
    your question. That will help others
    with the same problem finding the answer. - Thanks.

    Thursday, December 1, 2011 5:42 PM