none
Connection dropped between DPM and Agent during consistency check, following DPM 2012 SP1 to DPM 2012 R2 RRS feed

  • General discussion

  • Recently I have updated a DPM 2012 SP1 standalone server to DPM 2012 R2. That it’s self was a challenge... Following the upgrade most of the protection groups required consistency checks. For some time I have been having problems performing these consistency checks on remote servers over a 10Meg link.

    On the DPM server I would kick off a ping to the remote host, then start a consistency check. Within a few seconds I would start to get dropped pings, and very large ping response times, 3000ms plus. Within 3 minutes the pings would time out completely and no connections can be made to the remote server, RDP etc. However any other server on the network can connect to the remote client. Eventually the DPM jobs times out and sometime later the pings also return.

    The resolution to this has taken some digging but this is what I have found. The DPM agent update does not seem to fully work and requires a reinstall. Here is my process:

    • Logon to remote client server
      • Install .net 4 (a raw install of the client requires this, may not be needed when done via DPM)
      • Via Add Remove Programs, remove DPM agent
      • Clean up Reg
        • Delete "HKLM\SOFTWARE\Microsoft\Microsoft Data Protection Manager"
        • Delete "HKLM\System\CurrentControlSet\Services\DPM**" (However this key is not there for me)
    • Back onto DPM Server
      • Modified protection groups as required to remove all instances of the client server
      • Remove Agent for client server
      • Install agent via DPM (watch for the glitch right at the end where it does a failed, then succeed…)
      • REBOOT client server
      • Add back into protection group
      • Consistency check kicked off automatically

    This seems to have fixed the issue.

    Tuesday, October 28, 2014 4:03 PM