locked
Time zone data missing " " (0x80070002) RRS feed

  • Question

  • hello 

    I am learning to sysprep using answer file on windows server 2019 but it goes wrong. Error Time zone data missing " " (0x80070002)
    But i don't understand why
    Sorry my english is not good

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-International-Core" processorArchitecture="wow64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>en-US</InputLocale>
                <SystemLocale>en-US</SystemLocale>
                <UILanguage>en-US</UILanguage>
                <UserLocale>en-US</UserLocale>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <AutoLogon>
                    <Password>
                        <Value>QQBxAGEAbwBAACMARgAuADEAMgAwAFAAYQBzAHMAdwBvAHIAZAA=</Value>
                        <PlainText>false</PlainText>
                    </Password>
                    <Enabled>true</Enabled>
                    <LogonCount>1</LogonCount>
                    <Username>Administrator</Username>
                </AutoLogon>
                <OOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <HideLocalAccountScreen>true</HideLocalAccountScreen>
                    <HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
                    <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                    <NetworkLocation>Work</NetworkLocation>
                    <ProtectYourPC>3</ProtectYourPC>
                    <SkipMachineOOBE>true</SkipMachineOOBE>
                    <SkipUserOOBE>true</SkipUserOOBE>
                    <UnattendEnableRetailDemo>false</UnattendEnableRetailDemo>
                </OOBE>
                <UserAccounts>
                    <AdministratorPassword>
                        <Value>QQBxAGEAbwBAACMARgAuADEAMgAwAEEAZABtAGkAbgBpAHMAdAByAGEAdABvAHIAUABhAHMAcwB3AG8AcgBkAA==</Value>
                        <PlainText>false</PlainText>
                    </AdministratorPassword>
                </UserAccounts>
                <TimeZone></TimeZone>
            </component>
        </settings>
        <settings pass="specialize">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <CopyProfile>true</CopyProfile>
                <TimeZone>Pacific Standard Time</TimeZone>
                <ProductKey></ProductKey>
                <ComputerName>*</ComputerName>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="wim:d:/server2019/sources/install.wim#Windows Server 2019 SERVERSTANDARD" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>
    

    Friday, October 2, 2020 3:02 PM

All replies

  • You can try to add your Time Zone in your CustomSettings INI. instead.

    That takes priority over the unattend as it is.

    TimeZone=020
    TimeZoneName=Central Standard Time

    is what I have in my CS.INI
    I'm not sure what TimeZone # is for Pacific but add these two lines in your CS.INI for your zone.

    Also, be sure to add

    SkipTimeZone=YES above those two lines:

    SkipTimeZone=YES
    TimeZone=020
    TimeZoneName=Central Standard Time


    • Edited by the1rickster Friday, October 2, 2020 5:32 PM
    • Proposed as answer by the1rickster Monday, October 5, 2020 1:44 PM
    Friday, October 2, 2020 5:23 PM
  • ้hi , now i try delete  but it is work! thank you for your help

      <TimeZone>Pacific Standard Time</TimeZone>


    • Edited by Manisit Saturday, October 3, 2020 4:32 AM
    Saturday, October 3, 2020 4:32 AM