none
Cannot open start menu on SERVER 2016 RRS feed

  • Question

  • Hi all,

    I have a Server 2016 Std server which is a DC and I cannot open the start menu or settings.

    In app logs i've got:


    ID: 5673 Source:

    AppsActivation of app Microsoft.Windows.ShellExperienceHost_cw5n1h2txyewy!App failed with error: The app didn't start. See the Microsoft-Windows-TWinUI/Operational log for additional information.


    Event id 1000 for shellexperiencehost.exe crashing.

    I've done an SFC /scannow and a restore health with DISM to no avail.

    I have also tried in safe mode, another profile and DISM using a DVD.

    When i try the start menu troubleshooter it tells me

    "Microsoft.Windows.ShellExperienceHost" and "Microsoft.Windows.Cortana" applications need to be installed correctly."

    

    Thanks.



    Wednesday, July 19, 2017 3:17 PM

All replies

  • Hi,

    Please check if the following similar thread helps.

    Server 2016 start menu will not open

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/b73d80c5-fee3-44df-ae21-89c4efc4e9e5/server-2016-start-menu-will-not-open?forum=ws2016

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, July 20, 2017 7:58 AM
    Moderator
  • Hi,

    I created the GPO and assigned it, logged out/in and it still doesnt work. I dont have entries in that event log.

    I have these events:

    ID: 5985

    ActivateApplicationForContractByAppIdAsUserWithHost of the app Microsoft.Windows.ShellExperienceHost_cw5n1h2txyewy!App for the Windows.Launch contract failed with The app didn't start..

    ID: 5961

    Activation of the app Microsoft.Windows.ShellExperienceHost_cw5n1h2txyewy!App for the Windows.Launch contract failed with error: The app didn't start..

    ID: 5990

    Activation via contract helper of the app Microsoft.Windows.ShellExperienceHost_cw5n1h2txyewy!App for the Windows.Launch contract failed with Server execution failed.

    Do you think I have an issue with the apps within C:\Windows\systemapps ?

    I just ran this to no avail:

    Get-AppxPackage -AllUsers| Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

    Thursday, July 20, 2017 4:27 PM
  • Anyway, I got Microsoft support on the case and my issue is now resolved.


    Issue was with permissions.


    Remember, this is for a domain controller running SERVER 2016.

    Go to Run > dcomcnfg > Component Services > Computers > My Computer > Right click Properties

    Go to the COM Security tab > Access Permissions > Edit Default

    There should be 3 users in there with these permissions:

    SELF - Local Access, Remote Access

    SYSTEM - Local Access

    Administrators (<domain>\administrators) - Local Access & Remote Access

    OK out of that.

    Go to Launch and Activation Permissions > Edit Default

    There should be 3 userse in there with these permissions:

    SYSTEM - Allow all

    Administrators (<domain>\Administrators) - Allow all

    INTERACTIVE - Allow all


    Friday, July 21, 2017 3:17 PM
  • Hi,

    Thanks for your posting here and sharing the resolution in the forum as it would be helpful to anyone who encounters similar issues.

    If there is anything else we can do for you, please feel free to post in the forum.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, July 21, 2017 4:06 PM
    Moderator
  • https://justforadmins.blogspot.com/2016/09/fixed-windows-10-start-button-does-not.html

    This resolved my issue. Please do this.

    Friday, February 23, 2018 4:02 PM
  • This...this right here was the only solution that helped me with my Start Menu/Settings issue!

    Perfect, thank you!

    Monday, February 3, 2020 1:34 PM