none
[SPDelegateManager] [Debug] What does it mean? RRS feed

  • Question

  • hi Can anyone tell me what this mean in my log files? it occure just after my project wep application WCF code (/PWA/SecurityCheckUserPagePermission) is executed. Also why is my PWA code takes ~5 secs to run that timy code?

    Please HELP!!!!

     

    10/03/2011 14:39:52.54 w3wp.exe (0x306C)                       0x1E38 SharePoint Foundation         Monitoring                     b4ly High     Leaving Monitored Scope (ExecuteWcfOperation:http://schemas.microsoft.com/office/project/server/webservices/PWA/SecurityCheckUserPagePermission). Execution Time=4861.85059833023 7a9edc40-d827-4303-8f89-bf512f36f254

    10/03/2011 14:39:52.57 SPUCWorkerProcessProxy.exe (0x3430)     0x321C SharePoint Foundation         Upgrade                       fbv7 Medium   [SPUCWorkerProcessProxy] [SPDelegateManager] [DEBUG] [3/10/2011 2:39:52 PM]: Registering [Microsoft.Office.Word.Server.Service.Upgrade.QueueDatabaseSequence] for [Microsoft.Office.Word.Server.Service.QueueDatabase], Phase: 2147483647, Order: 11.  

    10/03/2011 14:39:52.57 SPUCWorkerProcessProxy.exe (0x3430)     0x321C SharePoint Foundation         Upgrade                       fbv7 Medium   [SPUCWorkerProcessProxy] [SPDelegateManager] [DEBUG] [3/10/2011 2:39:52 PM]: Registering [Microsoft.Office.Word.Server.Service.Upgrade.ServiceAppSequence] for [Microsoft.Office.Word.Server.Service.WordServiceApplication], Phase: 2147483647, Order: 11.  

     

     

    Monday, October 3, 2011 4:46 AM

All replies

  • Hi there,

    Are you trying to debug the WCF code which you have written for SecurityCheckUserPagePermission ?
    Did you try to debug & see, on which step does it take more time? 

    MSDN's article is good to understand the debugging the WCF:
    http://msdn.microsoft.com/en-us/library/ff843379.aspx#pj14_PSIExtension_Debugging
    If your WCF is running slow, it might be with many factors like something related to code (looing throgh or LINQ based) or might be a slow performance of system.

    WCF services on project Server 2010: A good starter
    http://msdn.microsoft.com/en-us/library/ee767691.aspx


    Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82
    Monday, October 3, 2011 6:03 AM
  • it is fresh installation of Project server 2010 and i did not write any code or debugging anything.

     

    my PWA site runs really slow and log shows this report.

    please help....

    Tuesday, October 4, 2011 12:16 AM
  • If it is a new installation and there is no data, it will be worth to disconnect the farm and rebuild new the farm with new config database

     

     

    Thanks,

    Hrishi

    Sr Consultant at DeltaBahn LLC

     

    Tuesday, October 4, 2011 1:33 PM
    Moderator
  • i mean fresh Project server installation and not Sharepoint. any other clue? thanks
    Wednesday, October 5, 2011 2:38 AM