locked
Joining a new server to an existing farm RRS feed

  • Question

  • Hi,

    I currently have a WSS 3 farm with only one WFE. The new server is a Windows 2003 STD 64 bits. The problem is that when i try to add the server to the farm it stops at STEP 2 with the error: Exception: System.UriFormatException: Invalid URI: The hostname could not be parsed. I'm 100% sure of the SQL server name and the Config database. I tried adding the server using the PSconfig.exe, same thing.

    The only thing weird that i found is in the PSCDiagnostics logs, it doesn't give the right Admin Content Database. The real Admin content Database doesn't have a GUID after it since we created the farm with PSConfig.exe two years ago. And everytime a try to add the server to the farm, it's a different GUID for the content database!

    Creating connection string for config db DBDV_WSS3_Dev_Config server SQLSERVERNAME

    Creating connection string for admin content db SharePoint_AdminContent_37b6399e-2680-406b-9168-aeffdcfcd30b server SQLSERVERNAME

     

    Thank you!


    Monday, July 4, 2011 8:46 PM

Answers

  • Hi,

    try following method

    1.  Log on locally to the server you want to remove.
    2.  Open a Command Promt to C:\program files\common files\microsoft shared\web server extensions\12\bin
    3.  Type the following command: psconfig -cmd configdb -disconnect


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Monday, July 11, 2011 9:46 PM

All replies

  • Hi,

    The account you are using to connect the new server in the farm having DB Creator and Security admin rights assigned on Admin Content DB ?

    Try to run PSConfig wizard using "Run as administrator" mode.

    or try with following command

    psconfig.exe -cmd configdb -connect -server <Server_name> -database <Database_name> -dbuser <DOMAIN\username> -dbpassword <password>


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Tuesday, July 5, 2011 6:38 AM
  • Hi Pratik,

     

    Thank you for your response. Unfortunately, the account I’m using to join the farm is the SETUP account and yes he has the db creator access and security admin and dbo on all databases. I tried running psconfig.exe using –dbuser instead of –user and it didn’t work…

     

    I tried this morning to uninstall and reinstall WSS, but same thing.

     

    Tuesday, July 5, 2011 2:02 PM
  • Hi,

    I might have something. I find out that if I go to the Servers in Farm page (_admin/FarmServers.aspx), on top where it says "Configuration database server" i see the SQLSERVERNAME\Instancename.

    On an other farm, I use the same SQL server and instance name, but in "Configuration database server" i only see SQLSERVERNAME. I tried adding my new server to this farm and it worked.

    One more thing, on the Farm where i'm having an issue, again in the Servers in Farm page, in the server list i see two entries for my SQL server. One saying only SQLSERVERNAME and one more with SQLSERVERNAME\Instancename. On the working Farm with the same SQL server, i only see SQLSERVERNAME. But in both farm, if i go to Operations - Default Database Server, I see SQLSERVERNAME\Instancename.

    I tried removing the entry of SQLSERVERNAME\Instancename in the Servers in Farm page by clicking on Remove Server, but for a reason i don't know, it's coming back?!

    Do you know where can i edit the Configuration Database Server and remove the instancename?

    Thank you

    Wednesday, July 6, 2011 1:12 PM
  • Hi,

    try following method

    1.  Log on locally to the server you want to remove.
    2.  Open a Command Promt to C:\program files\common files\microsoft shared\web server extensions\12\bin
    3.  Type the following command: psconfig -cmd configdb -disconnect


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Monday, July 11, 2011 9:46 PM