locked
Publishing RMS 1.0 SP2 to extranet over TMG 2010 over HTTPS RRS feed

  • General discussion

  • Hello, Iam having trouble with publishing RMS throught TMG 2010 over HTTPS. I did the steps destribed here >

    http://technet.microsoft.com/en-us/library/cc753490(v=ws.10).aspx

    But i have the question. I dont have any special certificate in Trusted Certification Authorities for export (only stadrad certs there) on RMS server. So I created my own  web server certificate on my CA and added to IIS on server for 443. Then exported this cert to TMG, personal and trusted authorities. Assigned on listener. When i try to reach RMS from extranet client on HTTP, it works perfect. When i try to reach it on HTTPS on TMG there only appears 2 infos: "The operations completed succesfully - Initiated connection" and in the same time the second info log is "A connection was gracefully closed in an orderly shutdown process with a three-way FIN-initiated handshake - closed connection"

    On RMS server there nothing in network monitor. No packet arrives there.

    I tried it with apache reverse proxy and its the same. HTTP ok, HTTPS dont work. It stops on apache server.

    When trying to reach the extranet url with web browser on HTTPS it works fine! Its not working only with the office rms client :-( ...

    Can anybody pls give me some hint what can be wrong? THX!!





    • Edited by Skubanek Tuesday, February 28, 2012 7:38 AM
    Monday, February 27, 2012 2:18 PM

All replies

  • Hi Skubanek,

    sounds to me as the TMG rule has only the dns configured but not the IP address of the internal server. Check the To tab in the publishing rule.

    The name in "This rule applies to this published site " must match the common name in the SSL certificate on the internal RMS server.

    Do you see errors when you run "Test rule"?

    Regards,

    Lutz

    Wednesday, August 8, 2012 4:59 AM