none
how to get DPM cmdlts running within remote PS ISE or common powershell RRS feed

  • Question

  • Hey guys,

    I'm usually using the DPM MGMT Shell on s specific DPM machine.

    Now I'm started to learn PS stuff but I'm facing issues and lack of knowledge.
    Hopefully you guys can give me a hint.

    First... I tried to run a cmdlt within the common powershell on a DPM Server.

    get-datasources ->

    Get-Datasource : Unable to connect to dpm-09.contoso.com. (ID: 948)
    Verify that the DPM service is running on this computer.
    At line:1 char:1
    + Get-Datasource
    + ~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Get-DPMDatasource], DlsException
        + FullyQualifiedErrorId : ConnectionToServerFailed,Microsoft.Internal.EnterpriseStorage.Dls.UI.Cmdlet.Common.GetDa
       tasource

    After trying to load DPM Module import-module dataprotectionmanager the same error came up.
    But why? Whats the difference between the common powershell Environment and the dpm Shell?

    I tried to run DPM cmdlts via my local installed ISE via remote entered pssession but the same error appears.
    Locally installed DPM console and Import DPM Module on my machine won't help either.

    executing the DPM commands within the dpm shell were succesfully.

    Can you give me a hint whats going on?



    Sunday, December 14, 2014 2:59 PM

All replies

  • The following technet link has some information which might be of help to you:

    http://technet.microsoft.com/en-us/library/hh830726.aspx


    Regards, Trinadh [MSFT] This posting is provided AS IS with no warranties, and confers no rights. If you found the reply helpful, please MARK IT AS ANSWER. Looking for source of information for DPM? http://blogs.technet.com/b/dpm/ http://technet.microsoft.com/en-in/library/hh758173.aspx

    Monday, December 22, 2014 10:51 AM
    Moderator