locked
Anyone else seen the Explorer bug where you must hit F5 to see a rename or delete? RRS feed

  • Question

  • I have seen an intermittent problem with the released version of Win7 x64. After renaming or deleting or creating a file, I have to hit F5 for Explorer to show the changes to the folder. I saw this a long time ago in XP and it was a real pain to get rid of and the solution never felt good. This problem was on the local C: drive and not some remote drive. I have seen this several times though can't repro right now as it comes and goes so have not pinned this down to any particular cause. Last time I had a lot of web pages open but I have 6G memory and lots of CPU and disk resources so don't think it was a resource issue.
    • Edited by CodeSlinger Monday, October 19, 2009 4:32 AM
    Thursday, October 8, 2009 1:24 AM

All replies

  • Hi,

    Can you try this for me....

    1, Open Explorer
    2, Click Organize -> Folder and search options -> View [tab] then 'Reset Folders'

    I experienced the exact same issue and doind that simple step solved it. I never did find out what may have caused it as I never make changes to folder views, only in my 'Movies' folders.

    Hope it helps :)


    Jeff
    If anyone is helpful, please click the 'Vote as helpful' icon. If anyone has answered, please click 'Suggest as answer' at the bottom of the post involved :) Thanks
    • Marked as answer by Robinson Zhang Monday, October 19, 2009 3:50 AM
    • Unmarked as answer by CodeSlinger Monday, October 19, 2009 4:21 AM
    Thursday, October 8, 2009 2:03 AM
  • I can try that next time but can't repro the problem right now. Also, my "reset folders" button is grayed out on a folder on C: that I just looked at.

    Thanks, Dave
    Thursday, October 8, 2009 7:11 AM
  • If you open up a library folder or favorite folder (downloads is a good one) you should have that option available
    If anyone is helpful, please click the 'Vote as helpful' icon. If anyone has answered, please click 'Suggest as answer' at the bottom of the post involved :) Thanks
    Thursday, October 8, 2009 8:34 AM
  • Jeff, I'm not convinced this is the "answer" and until I run into this again and try what you suggested, I don't want to assume this will address the issue. In any event, I feel this is a serious bug, one of many Explorer issues that have been around for too long, and am hoping more people comment and the cause pinned down and it is fixed. Explorer needs some serious attention imo. It has been getting worse, not better. My task bar often won't hide or unhide when it should. Things like aero glass look swell but it is not actually an improvement when it cause you to too easily click on the wrong window. Thanks, Dave
    Monday, October 19, 2009 4:31 AM
  • Tried it, but it didn't help (much).
    Bug re-appeared after a few minutes.

    Bug first appeared after changing the setting to display the file extensions.

    Other accounts on same same PC are not affected.

    Why me???
    Friday, December 11, 2009 3:01 PM
  • I have seen this behavior intermittently as well.

    Most of the time, when I see it, is when I add a picture from somewhere to a folder in the library view. If that folder is already open when the file is added, I have to refresh Explorer sometimes to get the file to show up in the folder. The biggest problem is that it's INTERMITTENT! You can try applying folder view, file assoc, registry changes..etc, but you'll not really know if any one of them fixes it as it will work for awhile and then suddenly..it's Back! Frustrating

    I came in looking for posts concerning WMP not sizing properly, but I had to let you know this isn't an isolated issue by any means! Many posters on my other W7 forums also report this as a problem, obviously it is a bug somewhere and hopefully it can be found and fixed in an update.

    Dave
    Monday, December 21, 2009 12:57 AM
  • Yes, it occurs on every 7 Pro 64-bit machine I have set up, and it is already there directly after clean install. With deletes it is almost 100% reproducible, with renames it occurs sometimes. IMHO it is a Libraries problem, at least in all my cases. It occurs when you have arrived in a folder via the Libraries route. If I take the classic folder route from C:\Users\username\ it does not occur.

    Cheers, Willem

    Monday, August 16, 2010 6:42 PM
  • Hey Microsoft - are you going to fix this? Happens when using Libraries paths. Period!
    Sunday, January 16, 2011 5:40 PM
  • On Sun, 16 Jan 2011 17:40:05 +0000, CodeSlinger wrote:

    Hey Microsoft - are you going to fix this? Happens when using Libraries paths. Period!

    This isn't Microsoft you're addressing. This is a peer support forum.
    We are all just users of this version of Windows here, helping each
    other if and when we can. We are not Microsoft employees (not even
    those of us with "Microsoft MVP" behind our names; that's an honorary
    title for having provided consistently helpful advice) except for an
    occasional employee.

    If you want to complain to Microsoft about something, please contact
    them directly. Trying to do it here is just a waste of (figurative)
    breath.


    Ken Blake, Microsoft MVP
    Sunday, January 16, 2011 6:00 PM
  • Don't be condescending. I know what an MVP is and that this is a peer forum. Lots of MSFT'ies here as well though on these forums!
    Sunday, January 16, 2011 7:44 PM