locked
C-Media Audio Chipset Driver RRS feed

  • Question

  • Hi all,

    I need a driver for my sound card on windows vista beta 2 build 5384.4
    The sound card is: C-Media CMI 9880 HD Audio

    regards,

    Friday, June 9, 2006 6:18 AM

All replies

  •  

    I am in the same situation needing drivers for Vista for my C-Media CMI 9880 HD Audio on-board sound. The generic Windows Vista drivers applied automatically do not instal correctly.

    Have tried to install the latest Win X driver by startingmthe setp program in Win XP SP2 compatibility mode, but has caused some blue screen crashes at times.

    Sunday, June 18, 2006 1:46 PM
  • I used the 5.12.01.0008.56 (UDAX008(Logo56.62)) driver. It works perfectly so far. I should point out that im only using 2-channel analog output and have not tested digital output or microphone input. The Xear program is accessible through the control panel. This is where I downloaded the driver http://www.softwarepatch.pl/plik/2486/56/4//C-Media_Sound_Card_CMI9880_-_v_51201_WHQL.html    Hope this works for you guys too!

    Edit: I forget to mention that you have to set the setup.exe to windows xp SP2 compatibility for it to work. (right click setup.exe> properties> compatibility> run this program in compatibilty mode for "Windows XP (Service Pack 2)

    Sunday, July 23, 2006 12:30 AM
  • I installed the new version of the cmedia driver software with flexbass and it seems to be working fine, although every now and then I get an annoying smartjack pop-up saying one of the jacks does not support background speakers; unplug it and move it to another jack. I'm running the RCI 32-bit edition. I'm also using the digital coax audio output on the mobo.
    Thursday, September 28, 2006 4:48 PM
  •  Professor X wrote:

    Hi all,

    I need a driver for my sound card on windows vista beta 2 build 5384.4
    The sound card is: C-Media CMI 9880 HD Audio

    regards,

    Sunday, December 17, 2006 6:44 PM
  • Still nothing! :-( no beta driver for CMI 9880! :-(
    I'll never buy ASUS motherboead anymore!!!

    Please sing the petition: http://www.petitiononline.com/CMVista/petition.html

    thanx guys
    Thursday, February 8, 2007 10:45 AM
  • Try these drivers, they worked for me.
    http://raptor6od.free.fr/pilote/Pilote_I9880_Vista.rar
    Sunday, February 11, 2007 9:44 PM
  •  

    As listed by Diskodunk these drivers worked perfectly for me also.

     

    CMI 9880 on ASUS P5AD2 Premium

     

    http://raptor6od.free.fr/pilote/Pilote_I9880_Vista.rar

     

    I had to download a free trial version of a decompression program to extract, but that was no biggie.

     

    Thanks & Good Luck Everyone!

    Thursday, March 29, 2007 12:26 AM
  • sssss
    Friday, May 11, 2007 10:23 AM
  •  danpond wrote:
     

    As listed by Diskodunk these drivers worked perfectly for me also.

     

    CMI 9880 on ASUS P5AD2 Premium

     

    http://raptor6od.free.fr/pilote/Pilote_I9880_Vista.rar

     

    I had to download a free trial version of a decompression program to extract, but that was no biggie.

     

    Thanks & Good Luck Everyone!

    It works! You're really a great guy!!

    Wednesday, May 23, 2007 5:58 AM
  • Hi Bartman_ITA

     

    I was having the same issue with Windows Server 2008 (built on Vista). I eventually downloaded an XP version of the drivers and right clicked on it and selected properties, in the compatability section, I selected run as window XP SP2, I also selected run as administrator, violla, she worked. Hope this helps.

     

    Regards

    pmweston@iinet.net.au

    Thursday, May 24, 2007 3:23 AM
  • I found the real solution!
    It really works...

    - Computer/Properties/Device Manager

    - Then, we click on "Sound, video and game controllers" and search our Audio Device and right-click/properties
    http://img440.imageshack.us/img440/6594/untitledfb5.jpg

    - Then go to "driver", the in "update driver", then in "search my computer for driver software" and finally put the CD (whit the driver) in the location box and click in "Next". Vista'll find the driver and will work correctly .
    Don' t use the C-Media files instalations (the .exe' s from C-Media are corrupted in Vista) install the drivers by this way.

    Bye!
    Sunday, July 29, 2007 6:06 AM
  • "put the CD (whit the driver"....

    What CD?

    What driver?
    Thursday, August 9, 2007 4:01 PM
  • GOD bless you dude. Thanks a lot.Smile

    Monday, August 13, 2007 5:21 PM
  • Damn u are a Pro!!!!it works for me.....

     

    God bless u dude..

     

    Full of Respect for uStick out tongueBig Smile

     

    Thanks a lot.

    Wednesday, September 12, 2007 7:03 PM
  • I found a solution for model CMI9880 on two posts at the manufacturer fora:

    http://www.cmedia.com.tw/forums/viewtopic.php?t=1251
    http://www.cmedia.com.tw/forums/viewtopic.php?t=1411

    Hope it helps.
    Wednesday, February 6, 2008 11:27 PM
  •  

    nyari chipset audio buat nvidia pentium4 seri lama

    Tuesday, April 1, 2008 5:28 AM
  • If it's possible upload this file (http://raptor6od.free.fr/pilote/Pilote_I9880_Vista.rar) again, please. The link doesn't work any more.
    Sunday, September 14, 2008 1:12 PM
  • Hi all,

    I need a driver for my sound card on windows vista beta 2 build 5384.4
    The sound card is: C-Media CMI 9880 HD Audio

    regards,


    Friday, April 24, 2009 5:46 AM