LHPv2 Hunt Group


  • I am trying to setup a hunt group and have set the agents using powershell ( The hunt group will play the message, and it acts like it is ringing the agents but it doesn't ring any of the agents. When it times out it forwards to my cell phone.

    Everything is working except ringing the agents. It is set to informal and all the agents are signed in, enabled for enterprise voice, and current "Active".

    I don't see any errors in the event viewer and I ran a SIPStack trace on it and don't really see anything that stands out nor do I see any logs saying it tried to route to the agents.

    What could possibly be the issue and how would I investigate this further?

    My Environment:

    1 Edge pool (two servers)

    1 Mediation pool (two servers)

    1 Front end pool (two servers)

    1 Director pool (two servers)

    Load Balancing

    Using DNS load balancing

    Mediation next hop server is the Front end pool

    Thursday, July 11, 2013 3:01 PM

All replies

  • It looks to me that it is unable to find agents that are signed in or pull their presence. Not sure where to go from there htough
    Friday, July 12, 2013 3:33 AM
  • Did you configure the queue for Hunt Group?

    Please try to use Lync control panel to create the hunt grou workflow by the following link.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, July 12, 2013 6:18 AM
  • Yes I configured the group, queue and then the hunt group work flow. I tried using a distribution group for the queue and also manually adding the the sip users name via powershell. I also made sure the distribution group I tried had tenantid, objectid, and groupingid set The work flow works except for ringing the agents. I can set a welcome message, forward to voicemail and all that works Also for the contact on my workflow I made sure all the same attributes were set and that the contact was in the tenants OU
    Friday, July 12, 2013 12:47 PM
  • This may be the same problem I am having.

    Lync 2013 Response Group not ringing first agent/group (randomly)

    If it is, so far I have been able to make things work (temporarily) by restarting RGS Services on the FE server.

    Friday, July 12, 2013 8:25 PM
  • I've  tried distribution group and manually adding agents via powershell. It won't ring any of them.

    I ran the logger and see some timeouts on checking agents statuses so it is unable to find any agents that are "signed in". But this is a informal group.

    Have you tried response group on LHPv2? I can get it to forward, greeting and everything but it just won't ring agents. I have tried a default contact and a contact that I've applied the TenantId,GroupingId, and ObjectId of the Tenant's GUID to

    Friday, July 12, 2013 8:32 PM
  • By the way the agents will even show that they have been added to the hunt group
    Friday, July 12, 2013 8:35 PM
  • Restarting the service didn't work. I'm guessing since this is multi-tenant there is some reason the response group can't access the agents. Is there a way to set the tenantid, groupid, etc on the response group workflow?
    Friday, July 12, 2013 8:54 PM
  • I gathered some logs. It can't find an agent but my SQL query shows the agent is signed in!

    Check out these logs:


    Entering the Queue:

    TL_INFO(TF_COMPONENT) [2]199C.0D0C::07/13/2013-16:34:41.524.0001d1ce (RgsMatchMakingService,CallHandler.EnterQueue:717.idx(733)) (00000000024300E5)Start queue timer Queue ID [47f23aec-01cc-4f22-9ed7-624d22c9ad99]. Call ID [87b40c05-02fa-411e-bcf5-c8c2104592a4]


    Trying to find Agent:

    TL_INFO(TF_COMPONENT) [2]199C.0D0C::07/13/2013-16:34:41.524.0001d1dd (RgsMatchMakingService,GroupCallHandler.GetNextAvailableAgent:3136.idx(417)) (0000000000119A0B)Try to find available agent on group: Name = [COMGroup] using [Parallel] method.


    No available Agent:

    TL_INFO(TF_COMPONENT) [2]199C.0D0C::07/13/2013-16:34:41.524.0001d1ec (RgsMatchMakingService,GroupCallHandler.GetNextAvailableAgent:3136.idx(461)) (0000000000119A0B)No available agent found on group: Name =[COMGroup], Guid =[5e4a960f-8d4b-4725-bccd-7f341c48d9f9] CallID=[87b40c05-02fa-411e-bcf5-c8c2104592a4]


    Trying Again:

    TL_INFO(TF_COMPONENT) [2]199C.0D0C::07/13/2013-16:34:41.524.0001d1f0 (RgsMatchMakingService,GroupCallHandler.GetNextAvailableAgent:3136.idx(417)) (0000000000119A0B)Try to find available agent on group: Name = [COMGroup] using [Parallel] method.


    Failed Again:

    TL_INFO(TF_COMPONENT) [2]199C.0D0C::07/13/2013-16:34:41.524.0001d1ff (RgsMatchMakingService,GroupCallHandler.GetNextAvailableAgent:3136.idx(461)) (0000000000119A0B)No available agent found on group: Name =[COMGroup], Guid =[5e4a960f-8d4b-4725-bccd-7f341c48d9f9] CallID=[87b40c05-02fa-411e-bcf5-c8c2104592a4]





    So I go into the rgsdyn database on my SQL server and run this query:

    SELECT Groups.Name, Agents.DisplayName, [State] FROM rgsdyn.dbo.AgentGroupSignInStates AS States JOIN rgsconfig.dbo.Agents AS Agents ON Agents.ID = States.AgentId JOIN rgsconfig.dbo.AgentGroups AS Groups ON Groups.ID = States.GroupId ORDER BY GroupId, States.State DESC



    Which returns:


    Name    DisplayName     State

    COMGroup         Jacob Dixon        1



    So as you can see I am signed in.

    Saturday, July 13, 2013 4:55 PM
  • Basically the same thing I am seeing, I think, only for me it is intermittent. Also I don't have a hybrid environment, not sure how LHPv2 effects RGS.

    Have you tried debugging with clscontroller.exe at all?

    Try the RGS Subcomponents..

    Monday, July 15, 2013 12:29 PM
  • I found out that I can put it in Attendant routing method and it works. Only because that method doesn't check the agent status.

    I have a ticket open with Microsoft and they are currently looking into it

    Friday, July 19, 2013 1:42 PM
  • I don't have a hybrid environment either. Did you ever find anything out about this? Still same problem here, workings in attendant but not parallel. Logs show it can't detect agent status.

    Case still open with Microsoft. Been going on over a week with just trying to get them log files.

    Wednesday, July 24, 2013 3:39 AM
  • No. I posted about this on the Microsoft Partner support board and was asked by a Microsoft Engineer for various log files. I have sent many logs and heard nothing back other than, "Thanks, were looking into it."

    We suspected hyper-v networking and I just got done moving all Lync vm's to a new host with dedicated nics. I have been very busy working out all the little bugs that moving the vms seems to have caused so I haven't had much of a chance to look at this issue but it does not seem to be any better.

    Wednesday, July 24, 2013 12:56 PM
  • My case with Microsoft is still open. It seems it is looking like a bug (mentioned by the Microsoft tech).

    I'll keep you updated on the status

    Friday, August 02, 2013 5:38 PM
  • Jackpot! I was able to resolve my issue changing the setting on my front end/mediation server to "use all configured ip addresses".

    100% resolved my issue.

    Friday, October 11, 2013 8:24 PM