none
mail bouncing between servers before it goes to smart host for outbound.

    Question

  • I have 3 mailbox servers in a DAG.

    2 of them are in the same datacenter.
    Servers A & B

    Server C is in a different location but on the same VLAN as SERVERS A & B (vlan for front end and replication). As such they are all in the same AD site.

    Server C has no active copies of any mailboxes currently in the DAG.

    But mail being generated from Servers A and B go to Server C then out to the smart host(proofpoint in our case) for internet delivery.  Sometimes I even see it go from A > C > A and then to internet.

    The default(*) send connector in exchange has all 3 as allowed senders.  So before I added Server C(last month) mail was routing out from its initiating server(A or B).

    The only reason i'm asking is because on that SERVER C i am now seeing "insufficient resources" in the queue containing emails stuck waiting to go out or in.  Server has plenty of memory ram and drive space on all drives.

    I guess the question is why would mail be routing out Server C and can mailflow out this server be setup as passive?

    Thursday, June 1, 2017 8:45 PM

Answers

  • Why?  Because Exchange doesn't know that Server C isn't really in the same site.  If you don't want it in the same site, change that.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    • Marked as answer by OldSchoola Friday, June 2, 2017 5:54 PM
    Friday, June 2, 2017 3:27 AM
    Moderator

All replies

  • Why?  Because Exchange doesn't know that Server C isn't really in the same site.  If you don't want it in the same site, change that.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    • Marked as answer by OldSchoola Friday, June 2, 2017 5:54 PM
    Friday, June 2, 2017 3:27 AM
    Moderator
  • That would require re-ip'ing the server correct?

    Would i still be able to join that server to the original dag(being in another ip subnet)?

    Friday, June 2, 2017 5:53 PM
  • Actually, not.  You could create a site with a single IP address, that of the server.  But you'd also want to add the IP address of at least one DC to that site as well.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Friday, June 2, 2017 10:01 PM
    Moderator
  • Got it thanks.  Do you have a link to any documentation for setting up a dag when its across datacenters like this, the correct way?

    Monday, June 5, 2017 3:50 PM
  • The DAG has nothing to do with mail flow.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Monday, June 5, 2017 9:29 PM
    Moderator