locked
Modify registry on windows 7 64 bits dont affect the good keys. RRS feed

  • Question

  • Hello,

     

    I just would to edit the Registry Keys to improve a Autologon on a windows 7 64 bits Notebook.

    I want to modify the following registry keys :

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon 

    DefaultUserName

    DefaultDomainName

    AutoAdminLogon

     

    But after i executed my batchfile, the keys doenst take effect to the : "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" but it writes the keys in the HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\

    and after i restart my Notebook the Autologon doesnt work.

    Here is the batchfile script that i use:

    @echo off
    echo yes | reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon"  /v AutoAdminLogon /t REG_SZ /d 1 /f
    echo yes | reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon"  /v DefaultDomainName /t REG_SZ /d Domain /f
    echo yes | reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon"  /v DefaultUserName /t REG_SZ /d User /f
    echo yes | reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon"  /v DefaultPassword /t REG_SZ /d Password/f



     

    Thank you very much and sorry for my bad english.

    Monday, June 15, 2015 9:07 AM

Answers

  • Hi

    try to specify registry view when running reg command

     /reg:32  Specifies the key should be accessed using the 32-bit registry view.
     /reg:64  Specifies the key should be accessed using the 64-bit registry view.

    I guess you will need to run the second parameter


    M.


    • Edited by MStoppl Monday, June 15, 2015 9:29 AM
    • Marked as answer by LeeHong1 Monday, June 15, 2015 11:01 AM
    Monday, June 15, 2015 9:29 AM

All replies

  • Hi

    try to specify registry view when running reg command

     /reg:32  Specifies the key should be accessed using the 32-bit registry view.
     /reg:64  Specifies the key should be accessed using the 64-bit registry view.

    I guess you will need to run the second parameter


    M.


    • Edited by MStoppl Monday, June 15, 2015 9:29 AM
    • Marked as answer by LeeHong1 Monday, June 15, 2015 11:01 AM
    Monday, June 15, 2015 9:29 AM
  • That is not a scripting question and is caused by the fact that you are running the 2 bit version of the command prompt.  If you want to address the 64 bit system you have to be running in a 64 bit process.

    Post end user uestions about how to use Windows in http://answers.microsoft.com


    \_(ツ)_/

    Monday, June 15, 2015 9:54 AM
  • Thanks :)
    Monday, June 15, 2015 11:02 AM