locked
Unexpected page break whEn using headings for TOC RRS feed

  • Question

  • Word 2013

    I am using headings for multiple indent and TOC. Here is my issue:

    1. I am at heading 2 and enter the content; then new line
    2. I enter Normal text under heading 2 at the new line
    3. I enter text and declare it heading 3; it creates the correct numbering for the text and indents
    4. Heading 3 immediately begins on a new page

    How do I remove the automatic page break for heading 3 if and only if I add the "normal" text before going to heading 3. Without any "normal" text, there is no page break.I looked at properties and cannot see it.

    THX


    John Lenz


    • Edited by JohnLenz Thursday, March 27, 2014 4:04 PM
    Thursday, March 27, 2014 3:41 PM

Answers

  • By default, (some of the) heading styles are formatted as "Keep with next," which means each of them will display on the same page as the following text paragraph.

    If you always see a page break before Heading 3 paragraphs, clear the "Page break before" option in the Modify Style dialog box. In the Apply Styles pane (Ctrl+Shift+S), type in Heading 3 and click Modify. Click Format and then Paragraph.


    Stefan Blom, Microsoft Word MVP

    Thursday, March 27, 2014 8:16 PM
  • Your document is set up with mostly built-in heading styles with no intervening text (that is, no text in some other style, such as Normal or Body Text). This is causing trouble with the "Keep with next" setting, which is enabled for most headings by default. You have to clear that setting from the style definitions.


    Stefan Blom, Microsoft Word MVP

    Tuesday, April 8, 2014 11:37 PM

All replies

  • By default, (some of the) heading styles are formatted as "Keep with next," which means each of them will display on the same page as the following text paragraph.

    If you always see a page break before Heading 3 paragraphs, clear the "Page break before" option in the Modify Style dialog box. In the Apply Styles pane (Ctrl+Shift+S), type in Heading 3 and click Modify. Click Format and then Paragraph.


    Stefan Blom, Microsoft Word MVP

    Thursday, March 27, 2014 8:16 PM
  • I looked at the heading 3 paragraph style and Page break before is NOT checked. I turned on "paragraph" Show/Hide  and see no indication of a forced page break.

    This only happens if I type "normal" text after advancing to a new line after heading 2. type the text  and then enter text and select as heading 3.

    It has to be something with following "normal" text?

    Any thoughts appreciated.


    John Lenz

    Monday, March 31, 2014 4:05 PM
  • Do you see any paragraphs (or styles) with "Keep with next" and/or "Keep lines together"?


    Stefan Blom, Microsoft Word MVP

    Monday, March 31, 2014 5:33 PM
  • I selected a Heading 3 entry that skipped to a new page after a normal paragraph written under Heading 2. In Modify style, I see:

    • Style based on: Heading 2
    • Style for following paragraph: Normal

    In format I see checked:

    • Window/Orphan control
    • Keep with Next
    • Keep lines together

    Page Break Before is unchecked.

    Any other info that would be helpful?


    John Lenz

    Monday, March 31, 2014 5:54 PM
  • If multiple successive paragraphs have "Keep with next" and "Keep lines together" enabled, paragraphs will be "chasing" each other onto the following page, and that may result in unexpected page breaks.


    Stefan Blom, Microsoft Word MVP

    Monday, March 31, 2014 5:58 PM
  • If I uploaded a sample of the paragraphs to SkyDrive, could someone look at an advise me of corrective action?
    THX

    John Lenz

    Thursday, April 3, 2014 1:25 PM
  • Sure.

    Stefan Blom, Microsoft Word MVP

    Thursday, April 3, 2014 6:02 PM
  • I extracted 2 sections form the document. One where there is a page break and one when it did not. This is form a RFP I am working on, so please keep confidential.

    Any guidance on why the page break is very much appreciated.

    https://onedrive.live.com/redir?resid=418500A441DD106A!2799&authkey=!AEDFrRDSiCCSQd0&ithint=folder%2c.docx


    John Lenz

    Friday, April 4, 2014 1:37 PM
  • Your document is set up with mostly built-in heading styles with no intervening text (that is, no text in some other style, such as Normal or Body Text). This is causing trouble with the "Keep with next" setting, which is enabled for most headings by default. You have to clear that setting from the style definitions.


    Stefan Blom, Microsoft Word MVP

    Tuesday, April 8, 2014 11:37 PM
  • Thanks. this did it. I'll use this for future RFP documents. They all follow the same template.

    John Lenz

    Thursday, April 10, 2014 3:04 PM
  • You are welcome. Thanks for the follow-up.

    Stefan Blom, Microsoft Word MVP

    Thursday, April 10, 2014 9:27 PM