none
"stopped-extension-dll-exception" error in almost all the MA sync runs RRS feed

  • Question

  • Hello Everyone,

    Need your help/guidance in one of the issues I had encountered recently. I have to test few things on an assigned development server having FIM 2010 installed. This server is not in regular use.

    Almost all of the MA sync runs are failing with "stopped-extension-dll-exception" error. Below are more details:

    Event Log for one of the failed MA sync run is :

    General Tab

    "

    The management agent "NED Emp MA" failed on run profile "delta sync" because of a problem with the initialize method on the extension object. The extension dll is "MVExtension.dll" and the stack trace is: 
     
     System.NullReferenceException: Object reference not set to an instance of an object.
       at Mms_Metaverse.MVExtensionObject.Initialize()

    "

    Details Tab

    "

    Log Name:      Application
    Source:        FIMSynchronizationService
    Date:          9/18/2015 10:44:17 AM
    Event ID:      6159
    Task Category: Management Agent Run Profile
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      FQDN of the server was here
    Description:
    The management agent "NED Emp MA" failed on run profile "delta sync" because of a problem with the initialize method on the extension object. The extension dll is "MVExtension.dll" and the stack trace is: 
     
     System.NullReferenceException: Object reference not set to an instance of an object.
       at Mms_Metaverse.MVExtensionObject.Initialize()

    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="FIMSynchronizationService" />
        <EventID Qualifiers="49152">6159</EventID>
        <Level>2</Level>
        <Task>1</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2015-09-18T14:44:17.000000000Z" />
        <EventRecordID>3358406</EventRecordID>
        <Channel>Application</Channel>
        <Computer>FQDN OF THE FIM SYNC SERVER WAS HERE</Computer>
        <Security />
      </System>
      <EventData>
        <Data>NED Emp MA</Data>
        <Data>delta sync</Data>
        <Data>MVExtension.dll</Data>
        <Data>System.NullReferenceException: Object reference not set to an instance of an object.
       at Mms_Metaverse.MVExtensionObject.Initialize()
    </Data>
      </EventData>
    </Event>

    "

    From the imported user records, I had tried to project one of the user record into Metaverse using Joiner, and the projection is of type  "Declared" for the MA i tried with, but still getting same error in the joiner as well, below is the screen shot:

    Any help in this regards is highly appreciated.

    Regards,

    RS

    Friday, September 18, 2015 3:22 PM

All replies

  • Hello RS,

    Could you please provide little more information.

    Like your ,

    MA Type ?

    How many MA you have ?

    Connected Data Source ?

    Provisioning via Sync eng or FIM Portal ?

    Regards,

    Pramod Chandra Das


    With Best Regards, Pramod Chandra Das

    Friday, September 18, 2015 4:40 PM
  • I believe I had this type of issue (or similar) with an earlier version of the 2010 R2 Sync engine.  It would stop on an error rather than log and continue.  Patched to a newer build and it went away.  Sorry light on details.
    Friday, September 18, 2015 5:10 PM
  • Thank you for your response Pramod, please find details below:

    MA Type ?  

    Ans: SQL Server MA

    How many MA you have ?

    Ans: 20+

    Connected Data Source ?

    Ans: SQL DB for this case

    Provisioning via Sync eng or FIM Portal ?

    Ans: Sync engine

    The example event log i had shared is for SQL server type MA, however, this is happening for other MA types as well.

    Friday, September 18, 2015 5:23 PM
  • Hello,

    since the error states some issues in the Initialize() Method of MV Extension it could help if you post that part of your extension code.

    The reference instanz error is very generic at does not help much in diagnosis.

    /Peter


    Peter Stapf - ExpertCircle GmbH - My blog: JustIDM.wordpress.com

    Friday, September 18, 2015 7:29 PM
  • Hello RS,

    could you please share your MV extention code for a review? and one more thing have you checked the account permission using in sync for MV to CD ?


    With Best Regards, Pramod Chandra Das

    Saturday, September 19, 2015 5:06 PM
  • Thank you for the response Peter.

    I am analysing the MV Extension code and it seems that XML file having configurations which are referred in MV Extension code have some issue. Will post the final root cause and solution once I have it.

    Thanks again!!

    Monday, September 21, 2015 12:29 PM
  • Thank you Pramod.

    I am analysing the MV Extension code and it seems that XML file having configurations which are referred in MV Extension code have some issue. Will post the final root cause and solution once I have it.

    Thanks again!!

    Monday, September 21, 2015 12:30 PM