none
"Mail Contact" Registration in SPO

    Question

  • Hello!

    It appears an organization (with DirSync) cannot create both a "Mail Contact" (in on-prem AD) and a "SPO Registered External User" with the same email address.

    You get a honkin' "Identity Synchronization Error".

    What gives? Anyone experience this before.

    I think I get it: two accounts in the same "Azure AD" cannot have the same proxy attribute - and both MailContact & ExternalUser are stored there... but what happens when you WANT to have a Mail Contact registered as an SPO External User?

    Thanks for being here!


    Joe

    Thursday, March 31, 2016 7:38 PM

Answers

  • I hear you. If you want that user to e added as s mail contact then I do not think it will work for you. 
    • Marked as answer by Joe Crockett Thursday, April 28, 2016 2:19 PM
    Wednesday, April 27, 2016 5:39 PM
    Moderator

All replies

  • Azure AD uses your Proxy Attribute for Soft matching the users when performing dirsync and hence you cannot have your Primary SMTP address to be the same. You can probably try setting up Alternate email address and see if that helps.
    Wednesday, April 20, 2016 7:57 PM
    Moderator
  • Thank you Amit!

    I don't follow one part though - if an end-user 'shares' content from SPO (thereby registering a new external user) -

    then that external user needs to be added to the directory as a 'Mail Contact' -

    Are you proposing creating a Mail Contact, with an alternate email address? I don't see how that would work; wouldn't Outlook always want to use the Primary SMTP address of the 'Mail Contact', which we can't use, as it's already in the directory.

    The key here being the roles:

    • an end-user registered the external user by sharing SharePoint content;
    • I, as admin, am now adding that user (unbeknownst to me hitherto registered) as a 'Mail Contact' - and cannot, because the proxy attribute is already taken.

    Joe

    Wednesday, April 27, 2016 5:04 PM
  • I hear you. If you want that user to e added as s mail contact then I do not think it will work for you. 
    • Marked as answer by Joe Crockett Thursday, April 28, 2016 2:19 PM
    Wednesday, April 27, 2016 5:39 PM
    Moderator
  • Thanks for confirming Amit! I appreciate your help

    Joe

    Thursday, April 28, 2016 2:19 PM