locked
SCSM 2012 PORTAL DOES NOT WORK. AM I DOING SOMETHING WRONG? PLEASE HELP RRS feed

  • Question

  • Ok, so SCSM 2012 Beta is now released and available. I downloaded and installed it. No brainer, everything pretty much straightforward. THen I installed Portal, and selected both options - SharePoint and Silverlight pieces. All installed with no errors. ALl looks good. Now when I open SMPortal WEB page, all I get is this:

    As you can see, it works somehow, partially. I tried different browsers, no luck. I even completely removed SCSM 2012 and SharePoint 2010 and re-installed everything up to last byte - still the same. I'm wondering if I may be doing something wrong?

    My URL for self-service portal I use is: https://<server_FQDN>:444/SMPortal as shown on the picture. This is what I got at the end of installation process. Is this is right URL? I know in SCSM 2010 it used to be https://<server_FQDN>/EndUser but I think this is now changed to SMPortal.

    Does anybody have any issue with SMPortal? Does it work? I start thinking that this thing just does not work, or maybe I'm missing something? Do I need any connector? I established AD connector so far.

    Thanks!

     

    Wednesday, November 2, 2011 12:38 PM

Answers

  • Hi Alexgarin

    I can confirm that the solution that Jesper suggest is working.
    If you want to do it another way, directly in the IIS, there is a very fast and simple way to do it.

    You can look in my blog post how it´s done:
    http://www.scsm.se/?p=646

     


    Stefan Allansson, Lumagate, Sweden, www.lumagate.com Blog: www.scsm.se
    • Marked as answer by lync15 Monday, November 7, 2011 4:40 PM
    Friday, November 4, 2011 2:22 PM

All replies

  • Checj your application log, look like issue with authorization.
    http://www.scsmsolutions.com/ freemanru (at) gmail (dot) com
    Wednesday, November 2, 2011 1:33 PM
  • I'm having the exact same issue. Anton, can you provide more detail on where I should be looking?

    Thanks.

    Thursday, November 3, 2011 12:49 AM
  • I have had this problem as well and have put alot of effort into solving it.

    This is my discoveries so far:

    1. The webpart and the webservices cant be installed on the same server.

    2. When installing the Webpart you must use a FQDN for the webservice including the port

    Example: https://scsm01.contoso.com dont work as webservice url but https://scsm01.contoso.com:443 does work

    3. When you install it like this you also need goto the server where the webservice is installed and edit the web.config file in the contenthost application with the fqdn.

    I used the default location so my web.config file is placed at C:\inetpub\wwwroot\System Center Service Manager Portal\ContentHost\Web.config

    Example:

    Edit from

    <add key="ContentHostAbsoluteUri" value="https://SCSM01:443/ContentHost" />

    To

    <add key="ContentHostAbsoluteUri" value="https://SCSM01.contoso.com:443/ContentHost" />

    I needed to edit this otherwise i could not open KA on the portal.

    I hope it helps

     


    Friday, November 4, 2011 7:17 AM
  • Hi Alexgarin

    I can confirm that the solution that Jesper suggest is working.
    If you want to do it another way, directly in the IIS, there is a very fast and simple way to do it.

    You can look in my blog post how it´s done:
    http://www.scsm.se/?p=646

     


    Stefan Allansson, Lumagate, Sweden, www.lumagate.com Blog: www.scsm.se
    • Marked as answer by lync15 Monday, November 7, 2011 4:40 PM
    Friday, November 4, 2011 2:22 PM
  • Fantastic, this solved the problem!

    I spend so much time on this, and at the end with the help from this forum it was fixed under 1 minutes!

    Good stuff! Thank you very much! I'm sure this will help lost of other people too!

    P.S. Now I'm wondering if the same issue will happen when RTM is released :-)

    Monday, November 7, 2011 4:42 PM
  • This also solved my problem - Thank you for the post.

    I'm now having the same problem with my request offerings.  Even if I click on the generic "Create a request" button on the Portal home page, I end up with the same blank portal page.  Basically, any request offerings end up with the blank Silverlight portion of the page.  The page does get redirected to the request offering page, but no silverlight content.

    Does anyone have any thoughts?

    Thanks.

    Monday, November 7, 2011 5:39 PM
  • Hi Dale!

    i´m sorry, I haven´t been able to recreate your problem.
    I´ll let you know if I find something out.


    Stefan Allansson, Lumagate, Sweden, www.lumagate.com Blog: www.scsm.se
    Tuesday, November 8, 2011 9:14 AM
  • Have you done this?

    2. When installing the Webpart you must use a FQDN for the webservice including the port

    Example: https://scsm01.contoso.com dont work as webservice url but https://scsm01.contoso.com:443 does work

    Tuesday, November 8, 2011 12:00 PM
  • Thanks for your responses.

    Your post helped me make a little progress.  I added in the request offering sharepoint web part and I now see content on my request offering page.  However, now I can't open the form when I click on "Go to request form".  See screenshots below.

    All that happens when I click on "Go to request form" is that the page changes to include "This request belongs to:".

    Sorry for all the questions and if I'm missing something simple.  I'm new to SM.

    Thanks.


    • Edited by Dale_Kiefer Tuesday, November 8, 2011 4:36 PM
    Tuesday, November 8, 2011 4:26 PM
  • I have followed your steps. But still have a blank page.  I am recieving Silverlight error as well.

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; GTB7.1; SLCC2; .NET CLR 2.0.50727; .NET4.0C; .NET4.0E; .NET CLR 3.5.30729; .NET CLR 3.0.30729)
    Timestamp: Thu, 10 Nov 2011 21:29:27 UTC


    Message: Sys.InvalidOperationException: InitializeError error #2104 in control 'ctl00_m_g_5dc162c6_4314_4975_bfb8_f3688d8cfb74_SilverlightCotrol': 2104 An error has occurred.
    Line: 437
    Char: 17
    Code: 0

    Could this be the problem?


    Jim Gilbert EmpireCLS Worldwide Chauffeured Services Secaucus, NJ
    Thursday, November 10, 2011 9:30 PM
  • I'm having the same problem in Internet Explorer. But the strange thing is that the silverlight part IS working in Firefox. I also installed both components on 1 computer.

    • Edited by Bjkoekkoek Thursday, November 17, 2011 10:19 AM
    Thursday, November 17, 2011 10:18 AM
  • I'm not sure if this helps but it did for me:
    http://www.code4ward.net/main/Blog/tabid/70/EntryId/139/Service-Manager-2012-Self-Service-Portal-not-working-blank.aspx

    cheers,
    Stefan

    http://www.code4ward.net


    • Edited by Stefan KoellMVP Tuesday, February 14, 2012 12:26 PM
    • Proposed as answer by RonaldJT Saturday, February 25, 2012 8:21 AM
    Tuesday, February 14, 2012 12:25 PM
  • I fixed the emtpy portal problem to install the IIS feature: IIS Common HTTP features, Directory browsing

    Saturday, February 25, 2012 8:31 AM
  • I have followed your steps. But still have a blank page.  I am recieving Silverlight error as well.

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; GTB7.1; SLCC2; .NET CLR 2.0.50727; .NET4.0C; .NET4.0E; .NET CLR 3.5.30729; .NET CLR 3.0.30729)
    Timestamp: Thu, 10 Nov 2011 21:29:27 UTC


    Message: Sys.InvalidOperationException: InitializeError error #2104 in control 'ctl00_m_g_5dc162c6_4314_4975_bfb8_f3688d8cfb74_SilverlightCotrol': 2104 An error has occurred.
    Line: 437
    Char: 17
    Code: 0

    Could this be the problem?


    Jim Gilbert EmpireCLS Worldwide Chauffeured Services Secaucus, NJ
    I have a same problem. This solution not valid, i´m search a correct.

    Thiago Carvalho Freitas MCP | MCTS CIO at BlueHat

    Tuesday, March 20, 2012 11:13 AM
  • Hi All,

    After Follow above solution my problem still not resolved.

    Give any Good Suggestion to resolve this issue 

    Saturday, June 16, 2012 5:23 PM
  • Your page is still blank?

    Can you submit a screenshot of your portal?

    And then aswer these 3 questions 

    1. what is the url of your portal?

    2. what is the name of your server hosting the scsm web content service?

    3. have you configured the portal to use SSL?


    // Work smarter not harder // www.litware.dk // Twitter: @litwaredk

    Monday, June 18, 2012 5:57 AM
  • Check your port numbers. The web.config file, the bindings on SCSMWebContentServer (in IIS), the Application Settings in the Service Manager Portal site in IIS need to match up.

    The Service Manager Portal bindings port number does not need to match up (shouldnt match up?). However, this is the port number you use when accessing the website from a client.

    For my install 443 is the port for the former and 444 for the latter.

    • Edited by Trana010 Wednesday, July 11, 2012 3:18 AM
    Tuesday, July 10, 2012 2:52 AM
  • this should be fixed by changing the SharePoint Site name on the Application management and add it as FQDN

    IA

    Monday, August 10, 2015 9:57 AM
  • this should be fixed by changing the SharePoint Site name on the Application management and add it as FQDN

    IA

    Monday, August 10, 2015 9:58 AM