none
Chaos exporting VM on Windows Server 2008

    Question

  • Here is my problem. We have been exporting our VM's to a new hdd over the past week. Everything was going fine until we got to this one particular server. When we tried to export this VM through Hyper-V it said it could not export. Ok, no problem. So we forgot about trying to move this one for the moment. Well, after a few days we needed to shut all the VM's down to improve some file transfers to those physical disks. When the VM's were booted back up, the server that failed to export has reverted to (what I can only assume) its original vhd state. We have lost a lot of really important data.

    I do have a copy of the vhd before this happened and a copy of the vm and snapshots folder. So back to the original problem is that the export failed in the beginning. Is there any way to get the data off of these snapshots or get the server back running like it was before the revert?

    We have no official server admin here so I do what I can but don't expect me to know the deep insights of hyper-v. I appreciate any help anyone can give.

    Tuesday, February 28, 2017 2:40 PM

All replies

  • So, I just asked one of the guys that works with me about it and he said that he had previously manually moved the vhd for this server to a different drive. This was before it was where it sits now. I inspected a few of the .xml files for the vm and sure enough some of them point to the old location of the vhd. Some of the snapshots do point to where the vhd now resides though. I'm thinking that these new snapshots are not the ones that contain any of the data I need.
    Tuesday, February 28, 2017 2:45 PM
  • Hi Sir,

    In this case , I need to confirm that vhd and avhd file of that VM are all copied out .

    If yes , please follow the article below to merge them manually (then , mount vhd file to get the files you need):

    https://social.technet.microsoft.com/wiki/contents/articles/6257.manually-merge-avhd-to-vhd-in-hyper-v.aspx

    If you only have avhd file that VM using currently , I'm afraid you could not get all the files you need .

     

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, March 1, 2017 1:00 PM
    Moderator