locked
Set unique permissions to pages(tabs) in meeting workspace in SharePoint 2007 RRS feed

  • Question

  • Hi, 

    I need to set unique permissions to pages in a meeting workspace.

    On opening the site using SP designer 2007 and right clicking the page in the left navigation at SP designer, I get the option "security" under properties, only for the pages library itself and not for individual pages. I am able to set permissions for the library itself but not for individual pages.

    Could someone please suggest me a method to set unique permissions to individual pages/tabs in a meeting workspace.

    Thanks!


    Fig: Properties of page window on right clicking at left nav in designer.

    :


    Ganesh.M

    Tuesday, May 22, 2012 1:01 PM

Answers

  • Hi Ganesh,

    Based on your description, I can reproduce this issue. In SharePoint 2007, Meeting Workspace Pages library is a special library in Meeting Workspace site and set to be hidden by default, you can set the individual page’s permissions neither on Pages from user interface nor SharePoint Designer 2007. In addition, it’s difficult to get the item and set its permissions through programming. However, SharePoint Designer 2010 supports to set the individual page’s permissions of SharePoint 2010 Meeting Workspace site.

    Thanks,


    Qiao Wei

    TechNet Community Support

    • Marked as answer by Ganesh.M Thursday, May 31, 2012 11:58 AM
    Wednesday, May 23, 2012 10:06 AM
    Moderator

All replies

  • Hi Ganesh,

    Where do you store those pages? in any document library or they are under pages folder.

    • Browse the site in IE and go to the container which contains these pages.
    • hover mouse on the pages and go to property of the page.
    • on the property page you will get manage permissions option and from here you can stop permission inheritance from the parent and assign an unique permission. this is called item level permission 

    hope this helps.


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/ | Posting is provided "AS IS" with no warranties, and confers no rights

    Wednesday, May 23, 2012 6:11 AM
  • Hi Ganesh,

    Where do you store those pages? in any document library or they are under pages folder.

    • Browse the site in IE and go to the container which contains these pages.
    • hover mouse on the pages and go to property of the page.
    • on the property page you will get manage permissions option and from here you can stop permission inheritance from the parent and assign an unique permission. this is called item level permission 

    hope this helps.


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/ | Posting is provided "AS IS" with no warranties, and confers no rights

    I cannot view the Workspace Pages library via the browser. Have you done or tried this. If so, please let me know how.

    I can view the pages library at the designer, but not in the browser (in view all site content)

    Also, just FYI publishing feature is not enabled.

    T


    Ganesh.M


    • Edited by Ganesh.M Wednesday, May 23, 2012 9:44 AM Grammar
    Wednesday, May 23, 2012 9:43 AM
  • Hi Ganesh,

    Based on your description, I can reproduce this issue. In SharePoint 2007, Meeting Workspace Pages library is a special library in Meeting Workspace site and set to be hidden by default, you can set the individual page’s permissions neither on Pages from user interface nor SharePoint Designer 2007. In addition, it’s difficult to get the item and set its permissions through programming. However, SharePoint Designer 2010 supports to set the individual page’s permissions of SharePoint 2010 Meeting Workspace site.

    Thanks,


    Qiao Wei

    TechNet Community Support

    • Marked as answer by Ganesh.M Thursday, May 31, 2012 11:58 AM
    Wednesday, May 23, 2012 10:06 AM
    Moderator
  • Hi Ganesh,

    Based on your description, I can reproduce this issue. In SharePoint 2007, Meeting Workspace Pages library is a special library in Meeting Workspace site and set to be hidden by default, you can set the individual page’s permissions neither on Pages from user interface nor SharePoint Designer 2007. In addition, it’s difficult to get the item and set its permissions through programming. However, SharePoint Designer 2010 supports to set the individual page’s permissions of SharePoint 2010 Meeting Workspace site.

    Thanks,


    Qiao Wei

    TechNet Community Support

    Thanks for the reply Qiao. Im not sure about the accuracy of the answer, so i will let someone else mark this as an answer, for now, if they agree.

    Thanks again:)


    Ganesh.M

    Wednesday, May 23, 2012 10:31 AM