locked
LocalDB api in my virtual application can't run properly RRS feed

  • Question

  • In my application I have code to call LocalDBStartInstance. I packed my app with appV sequencer. When I run my app from the package, this api call need to start sqlservr.exe. But this call failed, sqlservr.exe didn't get launched. I tried to pack my app with sqllocaldb installed in the package, and also tried to pack my app without localdb installed but install it on the machine separately. None of them works. sqlservr.exe didn't get launched, so this LocalDBStartInstance faile. Any idea? Thanks
    Wednesday, September 13, 2017 11:53 PM

All replies

  • Did you install sqlservr.exe on your sequencer before you started to sequence sqllocaldb?

    Roy Essers

    Thursday, September 14, 2017 8:45 AM
  • Thanks for reply. What do you mean install sqlservr.exe on my sequencer?

    I use two different way to pack my application, one is I have clean machine without sqlservr installed, my application's setup.exe will install sql client and localdb during sequencing.  When using this way to pack and install, sqlservr.exe is in appV directory. LocalDB instance get created, but when launch sqlservr.exe, there's an error message box said there's problem to launch it properly.

    The second way is I install sql client and localdb on the clean machine first, then sequence my application's setup.exe. The setup.exe will detect if there's sql server stuff already installed on the machine. If they are then setup.exe won't install them anymore. So in this way my appV package won't have sqlservr.exe packed in the package. When I install this package on the clean machine, I also need to install sql stuff separately onto the machine, then install appV. When using this way to pack and install, sqlservr.exe is installed in program files directory, and LocalDB instance didn't even created. Seems LocalDB api didn't even figure out where is the localdb server. No error message box show sqlservr.exe can't launch properly, but it doesn't launch. Any idea? Thanks

    Thursday, September 14, 2017 4:51 PM
  • SqlServer includes boot time services and these are incompatible with App-V.  You need to treat that component of your application as an external dependency.

    Tim


    Tim Mangan MVP for App-V and Citrix CTP Author of AppV books: "PowerShell with App-V 5 (5.1 Edition)", "The Client Book (4.x)" and "OSD Reference Book" (http://www.tmurgent.com/Books )

    Sunday, September 17, 2017 3:51 PM
    Moderator