none
DHCP and DNS setup RRS feed

  • Question

  • I am new to windows server setups.  I am doing self-study and taking online courses for my MCSA.  I have watched a few  dhcp and dns setup videos. So here is my setup.  I have my modem ip which is the usual 192.168.0.1 address and this is the default gateway and dhcp server from my ISP.  Behind the router I have a Win 10 pro desktop which I have setup virtualbox since it is free and I can't afford VMware. 

    I have setup 2 servers, server A and server B.  Server A is my first domain controller and server B is the 2nd for failover.  I have my own domain xyz.com.  I setup both the AD DS, DHCP and DNS on both servers.  I connected both servers to my xyz.com domain.  I have setup and authorized the DHCP servers and DNS scopes.  I then added my first client to AD and connected it to the domain.  Initially it did not see the AD DC for xyz.com domain.  I went to the ethernet adapter settings and went to advanced properties for the IPV4 settings and pointed it to the static ip addresses I set for my dns servers and I was able to move the client from the workgroup to my domain.

    Then to test my new setup I setup an ip reservation for the client, but it is still pulling the ip from my router.  I am not sure what I am doing wrong but I need to know how to get the client to pull the ip settings from the DHCP servers rather than the modem from my isp?

    Saturday, June 4, 2016 4:05 AM

Answers

  • Ideally, you should have a firewall or router between your modem and your internal home network.

    In your case, set up a free Linux firewall router to use as a virtual router. Give it 2 NICs, one that connects to the real network and one that is virtual internal NIC.  Put your other VMs on the same internal network.

    IPfire or IPcop are both free and easy to set up.  They will isolate your VMs from your regular network.


    Edit: Since you're using VirtualBox, the internal network is called a host-only network
    • Edited by essjae Tuesday, June 7, 2016 5:20 AM
    • Marked as answer by drewzz00 Wednesday, April 4, 2018 6:30 PM
    Tuesday, June 7, 2016 5:19 AM