none
programs and features gone

    Question

  • Hi,

    I need to access Program and Features on Server 2012 R2.

    Checked couple of 2012s no go...

    on one that I really need to access P and F, tried appwiz.cpl under admin prompt.

    No error ... and not window...

    What I am missing? The server is always patched.

    Don't remember when it worked last time... may be some update "killed" it.

    Please advise.

    Thx.


    --- When you hit a wrong note its the next note that makes it good or bad. --- Miles Davis

    Thursday, May 17, 2018 6:55 PM

All replies

  • From cmd.exe;

    control appwiz.cpl

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Thursday, May 17, 2018 6:58 PM
  • Hello, user:

    I recommend familiarizing yourself with Powershell and these commands.  Check out DISM too.

    Get-WindowsOptionalFeature -online

    Get-WindowsFeature

    Also, you don't need to proceed appwiz.cpl with control, any files that end with .cpl can be accessed by the full filename.  The DLLs will require proceeding with rundll and rundll32.

    --jp

    Thursday, May 17, 2018 7:17 PM
  • does it works on any of yours servers?

    NO GO on my super clean servers (tried 3 2012 and my W10).

    just returns to prompt (under admin).

    What is going on?


    --- When you hit a wrong note its the next note that makes it good or bad. --- Miles Davis

    Thursday, May 17, 2018 7:22 PM
  • Yes, it works or you can also;

     

     

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Thursday, May 17, 2018 7:24 PM
  • Try it from the run command.  Also, the Powershell commands need to run under a Powershell prompt. 
    Thursday, May 17, 2018 7:25 PM
  • other admin applied GPO for hiding ADD/REMOVE. Need to prevent Office components for installation to users...

    And forgot to exclude Dom Admins for GPO application.

    Sorry.


    --- When you hit a wrong note its the next note that makes it good or bad. --- Miles Davis

    Friday, May 18, 2018 1:33 PM
  • Too funny, glad to hear its sorted.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Friday, May 18, 2018 2:20 PM