none
Update As Scheduled - not working as expected RRS feed

  • Question

  • Here is something that I have never seen before.

    The file is an MSP2007 file that has been saved from MSP2010 and it all looks good.

    Say I have a task with 10 days duration that is scheduled entirely in the past relative to the status date.

    It may have 0% Complete or some other % Complete less that 100%.

    I want to use the update as scheduled button on the tracking toolbar to make it update to 100% complete.

    I expect this to count all of the remaining duration to the scheduled finish date as actual duration and to update the actual finish to be the scheduled finish, which of course should be earlier than the status date.

    What I don't expect is that the task will be spread all the way to the status date and the actual finish will be the status date, and the actual duration will become the duration from the actual start to the status date, but that's what happens.

    Some tasks in the file get updated as I expect, while others do not. There is nothing obvious about the tasks that is causing this unexpected result. There are no resources assigned, no weird predecessors or successors or lag. New tasks that I create get updated as I expect, as far as I can tell.

    The only way I can find to get around this is to paste the scheduled finish, from the split bottom pane, into the actual finish in the tracking table, or set the actual duration to the total duration and the remaining duration to 0.

    Puzzled. Reproducible? Reason/causes? All suggestions greatly appreciated.

    Sunday, August 28, 2011 12:52 AM

Answers

  • Trevor,

    Even though you already checked the option, "edits to .....", and found that it was off, you might try turning it on, doing some edits, saving the file and then turning it off again? That might be worth a shot.

    Nonetheless, the fact that this issue is showing for some tasks only and your file has ballooned to 75M points to file corruption. I'd give FAQ 43 - Handling project file bloat and/or corruption, a shot. You'll find it on the MVP website at, http://www.mvps.org/project/faqs.htm.

    John

    Sunday, August 28, 2011 3:29 PM

All replies

  • Hi Trevor,

     

    In Project 2007 (I assume this is where you are using update as scheduled?) try Tools, Options, Calculations tab and deselect Edits to total task % complete will be spread to the status date. This is off by default.


    Rod Gill

    The one and only Project VBA Book Rod Gill Project Management
    Sunday, August 28, 2011 5:45 AM
    Moderator
  • Rod,

    Thanks for giving it a shot, but unfortunately that was the first thing I checked, and it's off.

    Also, the thing happens to some/many tasks but not all. Some tasks update as expected.

    I would send you the file but it has ballooned from 2MB to 75MB after nothing more than half an hour of ordinary editing.

    What fun.

    Sunday, August 28, 2011 2:41 PM
  • Trevor,

    Even though you already checked the option, "edits to .....", and found that it was off, you might try turning it on, doing some edits, saving the file and then turning it off again? That might be worth a shot.

    Nonetheless, the fact that this issue is showing for some tasks only and your file has ballooned to 75M points to file corruption. I'd give FAQ 43 - Handling project file bloat and/or corruption, a shot. You'll find it on the MVP website at, http://www.mvps.org/project/faqs.htm.

    John

    Sunday, August 28, 2011 3:29 PM