none
Trying to backup Sharepoint 3 by DPM 2010 RRS feed

  • Question

  • Hi,

    I am getting the following error on the Sharepoint server in the WssCmdletsWrapperCurr.errlog.

    185C 1508 10/08 02:21:16.068 31 wsscmdletswrapper.cpp(144) [00DC2718]  WARNING Failed: Hr: = [0x8013151a] : F: lVal : hr
    295C 2E00 10/08 02:21:16.099 31 wsscmdletswrapperfactory.cpp(235)   ACTIVITY Principal name HOST/SPWW01
    295C 3358 10/08 02:21:31.667 31 wsscmdletswrapper.cpp(143) [00CF2718]  WARNING CoCreateInstance failed for CLSID_CWSS3Cmdlets : {40B0FC9C-A853-3F52-B677-A81B2D0F17AE}
    295C 3358 10/08 02:21:31.667 31 wsscmdletswrapper.cpp(144) [00CF2718]  WARNING Failed: Hr: = [0x8013151a] : F: lVal : hr
    1B38 2168 10/25 02:01:37.830 31 wsscmdletswrapperfactory.cpp(235)   ACTIVITY Principal name HOST/SPWW01
    1B38 2AFC 10/25 02:01:54.654 31 WSSCmdlets.cs(1183)   NORMAL Sql Instance Name = dbww02
    1B38 2AFC 10/25 02:01:54.654 31 WssSqlAliasHelper.cs(442)   NORMAL SqlAliasResolutionDisabled = False
    1B38 2AFC 10/25 02:01:55.919 31 WssSqlAliasHelper.cs(295)   WARNING Could not connect to the farm database dbww02\SSO
    1B38 2AFC 10/25 02:01:55.919 31 WSSCmdlets.cs(1281)   WARNING --------------------------------------------------
    1B38 2AFC 10/25 02:01:55.919 31 WSSCmdlets.cs(1282)   WARNING Exception Message   =
    1B38 2AFC 10/25 02:01:55.919 31 WSSCmdlets.cs(1282)   WARNING Cannot open database "SSO" requested by the login. The login failed.
    1B38 2AFC 10/25 02:01:55.919 31 WSSCmdlets.cs(1282)   WARNING Login failed for user 'DOMAIN\Wss_siteacct'.
    1B38 2AFC 10/25 02:01:55.919 31 WSSCmdlets.cs(1283)   WARNING Exception Stack     =
    1B38 2AFC 10/25 02:01:55.919 31 WSSCmdlets.cs(1283)   WARNING    at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)
    1B38 2AFC 10/25 02:01:55.919 31 WSSCmdlets.cs(1283)   WARNING    at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
    1B38 2AFC 10/25 02:01:55.919 31 WSSCmdlets.cs(1283)   WARNING    at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
    1B38 2AFC 10/25 02:01:55.919 31 WSSCmdlets.cs(1283)   WARNING    at System.Data.SqlClient.SqlInternalConnectionTds.CompleteLogin(Boolean enlistOK)
    1B38 2AFC 10/25 02:01:55.919 31 WSSCmdlets.cs(1283)   WARNING    at System.Data.SqlClient.SqlInternalConnectionTds.AttemptOneLogin(ServerInfo serverInfo, String newPassword, Boolean ignoreSniOpenTimeout, Int64 timerExpire, SqlConnection owningObject)

    I have 3 hosts: dpm server (win2008R2), sharepoint 3 server (Win2008 SP2), DB server (Win2003, SQL 2005 SP4). My sharepoint DB is running on the SQL 2005sp4 host. When i create a protection group, the Sharepoint server does not show me the sharepoint farm to be able to protect. It shows me the other drives and system state. The Wss_siteacct is an administrator account on the sharepoint server and dbo on the SQL 2005 Sharepoint SQL 2005 DBs. SQL 2008 tools are installed on the SP server. The DOMAIN\Wss_siteacct is also used by the Windows SP Timer services. Sharepoint works successfully except I cant back it up using DPM 2010. You help would be much appreciated.

    THANK U for this,

    Elvis99

    Wednesday, June 1, 2011 7:54 AM

All replies

  • Hi,

    you mentioned that you do not see the SharePoint Farm itself for protection. Quite often this is the case if you have not run the "configureSharePoint -enableSharePointprotection" command on one of the WFE or your SharePoint Farm.

    Wednesday, June 1, 2011 8:04 AM
  • Thankyou for replying to my post. Yes I have executed the configuresharepoint - enablesharepointprotection command and it returns successfully completed. However I did notice the DPMRACurr reported the following from executing the command:

    770 0C1C 06/01 06:16:18.426 03 runtime.cpp(891) [01214330]  ACTIVITY InitializeSecurity added DM perm for DPMRADmTrustedMachines
    1770 0C1C 06/01 06:16:18.426 03 runtime.cpp(94)   NORMAL Found 3 writer account(s) under VSS access control.
    1770 0C1C 06/01 06:16:18.426 03 runtime.cpp(161)   NORMAL Added writer account [0] 'NT Authority\NetworkService' to the DACL.
    1770 0C1C 06/01 06:16:18.426 03 runtime.cpp(161)   NORMAL Added writer account [1] 'domain\wss_siteacct' to the DACL.
    1770 0C1C 06/01 06:16:18.442 03 runtime.cpp(161)   NORMAL Added writer account [2] 'domain\spscrawler' to the DACL.
    1770 0C1C 06/01 06:16:18.504 22 genericthreadpool.cpp(804) [01214330]  NORMAL Hr: = [0x80070002] CGenericThreadPool::m_dwMaximumNumberOfThreads[20]
    1770 0C1C 06/01 06:16:18.504 22 agentutils.cpp(2624)   WARNING Failed: Hr: = [0x80070645] : U: lVal : hr
    1770 1434 06/01 06:16:18.504 03 timer.cpp(490)   ACTIVITY CTimerMgr::TimerThread
    1770 1434 06/01 06:16:18.504 03 timer.cpp(503) [01269948]  ACTIVITY CTimerMgr::TimerThreadInternal
    1770 0C1C 06/01 06:16:18.504 20 cc_base.cpp(913)   NORMAL DM: - Spotted QoS IPv6, Index:4
    1770 0C1C 06/01 06:16:18.504 20 cc_base.cpp(908)   NORMAL DM: - Spotted QoS IPv4, Index:5
    ...........

     

    Wednesday, June 1, 2011 11:26 AM
  • Hi Elvis99,

     

    Just to be sure. Even after running ConfigureSharePoint.exe -enablesharepointprotection you are still not able to see the SharePoint Datasource when expanding the SharePoint server while creating the protection group.

    If you log into your SQL Server using account WSS_SITEACCT and open SQL Server Management Studio re you able to access SSO content database?


    Thanks, Wilson Souza - MSFT This posting is provided "AS IS" with no warranties, and confers no rights
    Thursday, June 2, 2011 5:59 AM
    Moderator
  • HI Wilson Souza,

    First of all THANK-U for your help. This is my situation:

    When I create a protection group for my Sharepoint 3 implementation (Windows 2008 Ent), on my dpm2010 (Win 2008 R2 server)I get the following messages and no sharepoint to select:

    DPM could not resolve Sharepoint datasources on the protected computer ID:967, DPM could not enumerate SQL server instances using Windows Management Instrumentation on the protected computer ID: 965, DPM is unable to enumerate Virtual SP Search Writer on computer ID: 3055, and DPM is unable to enumerate Virtual SSP Writer on computer ID: 3055. 

    Another problem that I have is when I execute configureSharepoint.exe -resolveallsqlaliases I get the error messages "SQL alias resolution for Database name: WSS_Content and Alias Name: dbww02 failed with error 80004003 please fix alias. I get the same error message for Database names WSS_Content_KB, SharePoint_AdminContent_d15d2c77-c57f-4fa8-a6d8-957d9613cb2e, WSS_Content_SSP1, SharedServices1_DB, SharedServices1_Search_DB, WSS_Content_SSP2, SharedServices2_DB, SharedServices2_Search_DB, WSS_Search_HOSTNAME.

    WE currently use Window Sign-in.

    This morning I spoke with Microsoft professional services and I can now select Sharepoint to backup from DPM 2010. The Microsoft professional did 2 things:

    1) imported the SQL wmi class by executing the following command on the Sharepoint 3 server:

    C:\Program Files\Microsoft SQL Server\100\Shared>mofcomp  sqlmgmproviderxpsp2up.mof 

    2) Created the following string value in the Registry to tell dpm not to look for alaises on the sharepoint 3 server:

      HKLM\Software\Microsoft\Microsoft Data Protection Manager\Agent\2.0\SQLAliasResolutionDisabled

    I still get alias resolution problem, I am hoping to find a way of removing these aliases I dont need them, and also a way of resolving the issue of getting Single Sign On error messages in the event logs when I dont use Single Sign On. If anyone can help with either of these 2 remaining problems that would be appreciated.

    THANKS, Elvis99

     

     

     

     

    Friday, June 3, 2011 7:25 AM
  • Are you using SQL Alias on your SharePoint farm to get to the SQL server?

     


    Thanks, Wilson Souza - MSFT This posting is provided "AS IS" with no warranties, and confers no rights
    Friday, June 3, 2011 7:30 AM
    Moderator
  • Hi Wilson,

    I dont think so, can you please tell me how I find out if I am using aliases?

    Regards...

    Sunday, June 5, 2011 10:00 AM