locked
KB4467107 fails with error code 80004005 RRS feed

  • Question

  • Hello,

    Here's what I've tried so far.

    1.)Attempted to install the update manually.
    2.)I've ran an sfc /scannow. It told me that it repaired some corrupted files.
    3.) Tried the contents of the Software Distribution folder.

    At least one other computer on my network was able to install this update successfully. Any suggestions? Thanks.
    Monday, November 19, 2018 9:24 PM

All replies

  • Sfc doesn't work w/o the cmd:  CHKDSK C: /F  the repairs are made in pc re-start/MS-DOS..Reason being,the OS files/folders are in use in Windows Explorer...So,after you run Sfc /Scannow  type: CHKDSK C: /F  agree to restart,type:  EXIT  restart pc...
    Also,Windows 7 has a update for Windows,its: windowsupdateagenr-7.6-x86

    Download from Microsoft.Plus,  .NET  must be enabled thru Windows components Add/Remove/L.sub-menu,plus,download: kb890830

    http://catalog.update.microsoft.com/v7/site/Search.aspx?q=890830

    • Edited by Andrew E. _ Tuesday, November 20, 2018 5:15 AM
    Tuesday, November 20, 2018 5:11 AM
  • Hi KAG,

    Thanks for your posting here.

    1. install this update manually or automatically?

    2. please turn off the third party antivirus software.

    3.After run “sfc /scannow” and checksur (also named as system update readiness tool), reboot the machine to take effect.

    4. Use Fix it tool to reset the Windows Update Components.
      -----------------------------------------------------------------
     https://support.microsoft.com/en-us/help/971058/how-do-i-reset-windows-update-components 

    5. Ensure that you have installed the latest servicing stack update, please refer to the KB4467107 article.

    6.perform a clean boot to install the patch again.

    7. If the patch still cannot be installed, please check the system event log and setup log in the event viewer to see if there is any error message during the installation of the patch. Also, upload the CBS log(C:\Windows\logs\CBS) to OneDrive and share the link.

    Hope can help you.

    Best regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, November 20, 2018 6:39 AM
  • I've tried all of the above with no luck. Here's the link to my logs. https://1drv.ms/u/s!AkMbKvqAlU2NcuX7a2JtkmnX2qo
    Tuesday, November 20, 2018 4:38 PM
  • Hi KAG,

    Thanks for your replying.

    I have checked the CBS log and found the following error:

    2018-11-20 10:45:36, Error      [0x018008] CSI    000000eb (F) Failed execution of queue item Installer: Generic Command (uninstall) ({c145fd5d-1b9b-4738-9961-64034a3da28f}) with HRESULT HRESULT_FROM_WIN32(14109).  Failure will not be ignored: A rollback will be initiated after all the operations in the installer queue are completed; installer is reliable (2)[gle=0x80004005]

    1.Please back up and delete the following registry key, then try to install the update manually.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WINEVT\Publishers\{c145fd5d-1b9b-4738-9961-64034a3da28f}

    2.please uninstall the third party antivirus. Have you installed PQD agent? From my experience, uninstall it and the update should be patched successfully.

    Best regards,

    Cora


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Thursday, November 22, 2018 2:59 AM
  • Hi KAG,

    How is everything going?

    Would my advice be helpful?

    If you have any questions, please feel free to reply.

    Best regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, November 30, 2018 7:49 AM
  • It ended up being an installed program called PDQ Deploy that was causing the issue. As soon as I uninstalled it, the problem was resolved.
    Friday, November 30, 2018 1:57 PM
  • Hi KAG,

    I am glad that your issue is solved. 

    If you have any questions, please feel free to post in our forum.

    Best regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, December 3, 2018 1:31 AM