Error during data loading from Analysis Services engine

    General discussion

  • Hi,

    for a my workbook, when I open it I've the error message about "it cannot load the embedded data from Analysis Services engine". Then it is proposed to me to recover the data structure. I do it, then refresh all tables, save all, save the workbook, reopen it and then I've the same case with the same error message. I'm looping on this error.

    Any suggests to me, please?


    Friday, May 27, 2011 7:22 AM

All replies

  • The error is related to an unique workbook. With another workbook I don't have this error. So it isn't about PowerPivot installation. If I choose to do no actions I can see this message:

    Exception from HRESULT: 0x800A03EC

    Call Stack:

    Server stack trace:
       in System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
       in System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
       in Microsoft.AnalysisServices.Modeler.FieldList.GeminiProxy.MethodInvokeCallBack(String memberName, String dispID, BindingFlags flags, Object[] args, Boolean ignoreRetry)
       in Microsoft.AnalysisServices.Modeler.FieldList.GeminiProxy.HandleMethodInvoke(IMethodCallMessage callMessage)

    Exception rethrown at [0]:
       in System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       in System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       in Microsoft.Office.Interop.Excel.OLEDBConnection.Reconnect()
       in Microsoft.AnalysisServices.Modeler.FieldList.InProcServer.LoadOLEDBConnection(Boolean raiseCompleteEvent)


    Any helps to me, please?

    Friday, May 27, 2011 9:59 AM
  • Hi,

    I've go back with the development history of my workbook and I've solved. In an imported table I've a calculated column that calculate the product between a field of this table and the related field of another related table (the relationship exists in PowerPivot!), using the RELATED statement. With this calculated column the data loading fails but without it no. I haven't error when I specify the calculation! I think to use other times the RELATED to create calculated column without any problems. It seems a strange issue.

    Any idea, please? Thanks

    Friday, May 27, 2011 11:02 AM
  • Pscorca,

    Is this still an issue?

    Thank you!

    Ed Price, Power BI & SQL Server Customer Program Manager (Blog, Small Basic, Wiki Ninjas, Wiki)

    Answer an interesting question? Create a wiki article about it!

    Sunday, November 24, 2013 6:30 AM