locked
Event MSExchangeSubmission 16024 RRS feed

  • Question

  • Good afternoon, I deployed a clean installation of three Exchanges 2016 CU 15 servers and collected them DAG.

    Every time I reboot, I get the following event:

    Event MSExchangeSubmission 16024

       

    The description for Event ID 16024 from source MSExchangeSubmission cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event: 

    Faulted
    Exceptions Encountered - System.AggregateException: One or more errors occurred. ---> System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Forefront.AntiSpam.SpamEngine, Version=15.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
       at Microsoft.Exchange.Transport.Agent.Malware.SubmissionMalwareAgentFactory..ctor()
       --- End of inner exception stack trace ---


    The next event that I receive is MSExchangeSubmission 1000

    "The Microsoft Exchange Mailbox Transport Submission service has successfully started."

    I just can not deal with this error and ask for help.

    Monday, March 16, 2020 7:59 PM

All replies

  • Hi,

    Do this event ID exist on other DAG members?

    Do all services work well? Do you have any issues about the mail flow?

    Please go to Register Editor to check if MSExchangeSubmission is listed under the application subkey. You should find it under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\EventLog\Application.

    Check the registry value named EventMessageFile, verify that the path to the .dll file is correct and the name of the .dll is correct. For your reference: HOWTO: Troubleshooting the "Event Message Not Found" Message.

    If you have other Exchange servers which don't have this event ID, copy Microsoft.Exchange.MailboxTransport.Submission.Eventlog.dll file from other server to check if the issue persists. Here is a similar issue, you can check for more information: Exchange 2016 - Transport service will not start / Error.

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.

    Regards, 

    Lydia Zhou


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, March 17, 2020 4:56 AM
  • Just checking in to see if above information was helpful. If you have any questions or need further help on this issue, please feel free to post back. 

    Regards,

    Lydia Zhou


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, March 23, 2020 11:21 AM