none
SBS 2011 Standard Server RWA Problem RRS feed

  • Question

  • Hi,

    I having a problem from time to time with RWA. After the user logs in remotely . Clicking on PC to remote to does not work.

    If I restart  World Wide Web Publishing Service, Which restarts Remote Desktop Gateway, Or restart server it works again.

    Any ideas,

    Thanks

    Dexter

    Wednesday, July 29, 2015 6:32 PM

Answers

  • Hi,

    In general, increasing memory consumption on an SBS Server may cause the server to run slow, or, some of the services/features stop working correctly. 

    Besides, have you updated the .NET Framework 4.5.1 recently? If so, you may try to modify the Remote Web Access web.config file using the following steps: 
    1. Open web.config file located at: “%ProgramFiles%\Windows Small Business Server\Bin\WebApp\RemoteAccess”.
    2. Search in Web.config for "<serviceHostingEnvironment aspNetCompatibilityEnabled="true" />", change this line to "<serviceHostingEnvironment aspNetCompatibilityEnabled="true" minFreeMemoryPercentageToActivateService="0"/>"
    3. Save changes and close the file.
    4. Run IISRESET from an elevated Command Prompt window.

    A blog about SBS 2011 AFTER .NET 4.5.1, just for your reference:
    http://blogs.msmvps.com/bradley/2013/12/21/sbs-2011-after-net-4-5-1/

    If you don't have .NET Framework 4.5.1 installed, you may try to analyze the memory usage(using performance monitor) of different processes running on the server and fine tune them. Or, install available Windows Update on the server might also be helpful.

    If the problem persists, check the Event Viewer and confirm that if any related event has been logged.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, July 31, 2015 7:09 AM
    Moderator
  • Eve,

    I Have . Net Framework 4.5.2.  I have made Changes in Web.config restarted IISreset. I am monitoring. I am also not using exchange on this SBS 2011 box. May try stopping those services.

    Thanks

    Dexter

    Monday, August 10, 2015 2:03 PM

All replies

  • Hi,

    In general, increasing memory consumption on an SBS Server may cause the server to run slow, or, some of the services/features stop working correctly. 

    Besides, have you updated the .NET Framework 4.5.1 recently? If so, you may try to modify the Remote Web Access web.config file using the following steps: 
    1. Open web.config file located at: “%ProgramFiles%\Windows Small Business Server\Bin\WebApp\RemoteAccess”.
    2. Search in Web.config for "<serviceHostingEnvironment aspNetCompatibilityEnabled="true" />", change this line to "<serviceHostingEnvironment aspNetCompatibilityEnabled="true" minFreeMemoryPercentageToActivateService="0"/>"
    3. Save changes and close the file.
    4. Run IISRESET from an elevated Command Prompt window.

    A blog about SBS 2011 AFTER .NET 4.5.1, just for your reference:
    http://blogs.msmvps.com/bradley/2013/12/21/sbs-2011-after-net-4-5-1/

    If you don't have .NET Framework 4.5.1 installed, you may try to analyze the memory usage(using performance monitor) of different processes running on the server and fine tune them. Or, install available Windows Update on the server might also be helpful.

    If the problem persists, check the Event Viewer and confirm that if any related event has been logged.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, July 31, 2015 7:09 AM
    Moderator
  • Eve,

    I Have . Net Framework 4.5.2.  I have made Changes in Web.config restarted IISreset. I am monitoring. I am also not using exchange on this SBS 2011 box. May try stopping those services.

    Thanks

    Dexter

    Monday, August 10, 2015 2:03 PM