locked
Blank Recipients in Exchange Logs RRS feed

  • Question

  • Hi, can anyone tell me what it means if the Recipients field is blank in the exchange 2010 email logs? We have an app that is generating emails to internal users and for some reason some of them are showing as blank recipients in the logs. The only reason I knew of for this was if they were being filtered by the spam filter, but I've checked and that's not the case.

    Any thoughts appreciated... cheers.

    Friday, September 21, 2012 12:44 PM

Answers

All replies

  • Maybe the messages have only BCC recipients, like some mailshots do?  I wouldn't expect to find those in the logs.

    Mobile OWA For Smartphone
    www.leederbyshire.com
    email a@t leederbyshire d.0.t c.0.m

    Friday, September 21, 2012 2:13 PM
  • Thanks for reply Lee. That would make sense, but in this case the app that is sending the emails doesn't have the facility to 'bcc', it just sends directly 'To' users.
    Friday, September 21, 2012 2:23 PM
  • When you say email logs which logs, receive logs, message tracking? Message tracking is showing blank recipient? Message tracking will show bcc recipients, not sure if that is the problem since you mentioned the app is not using bcc. In outlook is the to: blank?

    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Friday, September 21, 2012 3:04 PM
  • It's the Message Tracking logs. If I look at the message tracking log for emails sent from the email address the app uses, it shows some emails as having a blank recipient (not all are blank just some). Yeah the app doesn't use bcc so I'm assuming that won't be the issue. As the emails are generated from the app we can't view the sent items in Outlook (I assume that's what you meant?).
    Friday, September 21, 2012 3:32 PM
  • As far as outlook, I guess I was asking when the app sends, the emails with the blank senders, do the users who receive the email actually receive the email but when they look at the email the to: is blank? Or the email the app sends with a blank recipient they are never sent at all?

    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Friday, September 21, 2012 3:35 PM
  • Hi, yeah the emails with the blank recipient field in the message tracking logs appear to never be sent (at least nobody receives them). But within the app everything looks ok i.e. the app suggests that the email should have been generated and sent to the appropriate person.
    Friday, September 21, 2012 3:52 PM
  • I would have to say it's an issue with the app, maybe some parsing format error with the recipient. The app is sending to one recipient at a time? Maybe turn up pipline tracing to see if it shows any additional info.

    http://technet.microsoft.com/en-us/library/bb125018.aspx


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Friday, September 21, 2012 4:33 PM