locked
Hyper V with VM Ware RRS feed

  • Question

  • First off, i'm new to the whole virtualization thing. So i'm working on setting up some labs on my home PC. This is teh PC set up.

    Asus F1A55-M LE board with an AMD A6-3650 APU quad core, Windows 7 Professional, 4g Ram and I am using VMWare's VMware Player. I've also updated the BIOS to the latest version.

    I have installed Server 2008 R2 SP1 with no problems. I can add roles, etc, all of that works. However, I cannot get get Hyper Visor to work after installing the role. No matter what I do, unisntall the role, reinstall it, delete the host VM machine and create a new one, the same two items show up in the device manager.

    Virtual Machine Bus and Virtualization Infrastructure Driver. Both show the same following error.

    Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

    I've tried updating the Server install, all 156+ windows updates. Still no change. Tried locating the drivers on the Server image file, states I already have the latest working version. When checking the Event viewer, they both read this;

    'Virtualization Infrastructure' driver required by the Virtual Machine Management service is not installed or is disabled. Check your settings or try reinstalling the Hyper-V role.

    Log Name:      Microsoft-Windows-Hyper-V-VMMS-Admin
    Source:        Microsoft-Windows-Hyper-V-VMMS
    Date:          5/8/2014 5:21:35 PM
    Event ID:      14098
    Task Category: None
    Level:         Error
    Keywords:      
    User:          SYSTEM
    Computer:      WIN-2I0PJCH7JHI
    Description:
    'Virtualization Infrastructure' driver required by the Virtual Machine Management service is not installed or is disabled. Check your settings or try reinstalling the Hyper-V role.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-Hyper-V-VMMS" Guid="{6066F867-7CA1-4418-85FD-36E3F9C0600C}" />
        <EventID>14098</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8000000000000000</Keywords>
        <TimeCreated SystemTime="2014-05-08T21:21:35.723425800Z" />
        <EventRecordID>17</EventRecordID>
        <Correlation />
        <Execution ProcessID="1296" ThreadID="1648" />
        <Channel>Microsoft-Windows-Hyper-V-VMMS-Admin</Channel>
        <Computer>WIN-2I0PJCH7JHI</Computer>
        <Security UserID="S-1-5-18" />
      </System>
      <UserData>
        <VmlEventLog xmlns:auto-ns2="http://schemas.microsoft.com/win/2004/08/events" xmlns="http://www.microsoft.com/Windows/Virtualization/Events">
          <Parameter0>Virtualization Infrastructure</Parameter0>
        </VmlEventLog>
      </UserData>
    </Event>

    I've searched TechNet and Google. Found a few items that were close to my issue, but nothing exactly. 

    All i'm trying to accomplish is, to have one virtual PC using Hyper V and the Server running in the VM Player so I can play.

    Any idea's why these two drivers will not start? I've even downloaded multiple copies of the Server 2008 R2 from Microsoft.



    • Edited by rrice2004 Thursday, May 8, 2014 9:37 PM
    Thursday, May 8, 2014 9:34 PM

All replies

  • Hi Rice,

    First thing you need to check is ? VT support on your Motherboard and Processor, If its available, ensure its enabled on BIOS.

    Without VT technology, you will not be able to create Nested VM 

    Friday, May 9, 2014 6:55 AM
  • Yes, I went in before and after the BIOS update to make sure the SVM was enabled. 

    I'm wondering if it might have something to do with the network card? As the two VM player nic's show unidentified network. So I uninstalled the VM Player and reinstalled. Both are back, still showing unidentified netowrk and were hard coded with a 192.168 IP that isn't part of the routers subnet. So I set them both to auto obtain. I am in the process of reinstalling Server 2008 R2 from scratch and will try again.

    Friday, May 9, 2014 5:37 PM
  • Went back and did some more research and reading. According to AMD and ASUS, both the CPU and the Board support virtualization. So i thought, maybe something in the the way of how the Server 2008 R2 virtual was configured. 

    I added the following to the VXD file and reinstalled Hyper V. Hyper V has always installed just fine. However, those two drivers still fail.

    hypervisor.cpuid.v0 = "FALSE"

    mce.enable = "TRUE"

    vhv.enable= "TRUE"

    I went back and triple checked all of my system drivers to make sure I had the newest versions, and I do. 

    Though this isn't life or death, it's the only way I can think of, to where I can learn some things I need for certification. 



    Friday, May 9, 2014 7:40 PM
  • Hi

    Can you try on Vm ware workstation as you can download trial.

    Saturday, May 10, 2014 1:21 AM
  • Haven't tried that yet. Let me download it and get back. Just heard back again from Asus, they said to try that over the VMWare Player as well. So let's see. 
    Saturday, May 10, 2014 7:03 PM
  • Just installed the newest version of VMWare Workstation and have the exact same issue with the exact same error codes. 

    Guess i'm not going to be able to get this running. 

    Saturday, May 10, 2014 7:42 PM
  • On vmware workstation did you enable VT in processor 
    Sunday, May 11, 2014 6:49 PM
  • Yes. Tried it set to the following:

    Virtualization Engine Options:

    1. Preferred Mode Automatic

    2. Preferred Mode Automatic, checked Virtualize Intel VT-x/EPT or AMD-V/RVI

    3. Preferred Mode Intel VT-x or AMD-V

    4. Preferred Mode Intel VT-x or AMD-V, checked Virtualize Intel VT-x/EPT or AMD-V/RVI

    5. Preferred Mode Intel VT-x/EPT or AMD-V/RVI

    If i check the Virtualize CPU performance counters, it won't start. States that the CPU doesn't allow for that. 

    If the system hardware does not allow for virtualization, then even by enabling it in the BIOS, then the Hyper V should not install correct?

    Processor selection is set to 1 processor and 4 cores. I've even switched it to 2 cores with the above options and still nothing. 

    Sunday, May 11, 2014 7:05 PM
  • Hi just to test

    Install esxi on top of vmware workstation to find if this is a hardware problem. 

    Sunday, May 11, 2014 7:13 PM
  • Ok, will try. be back with an answer in a bit.
    Sunday, May 11, 2014 7:15 PM
  • Nothing. Still can't get it to run. installed it both on the host machine as well as on the virtual server. Hyper V still won't start those two drivers.

    not going to waste any more time on it. I'll just rely on reading the books.

    Thanks for the help and input. 

    Sunday, May 11, 2014 9:47 PM
  • https://support.microsoft.com/en-us/kb/2568088
    Sunday, November 20, 2016 7:33 PM
  • Remove the Vm from the inventory then edit the vmx file as required

    Add the vm to the inventory again and it should be able to install the hyper-v role.

    http://www.settlersoman.com/how-to-installrun-hyper-v-host-as-a-vmnested-on-vsphere-5-or-6/

    the link is based on v-shere but it works in vmworkstation

    Sunday, November 20, 2016 7:44 PM