locked
Cannot access RemoteApp using Web Access with VDI (using RDS) RRS feed

  • Question

  • Hi,

    i have setup VDI. Personal and Virtual Desktop Pool is working fine when access from outside. Then i decided to install application into RD Session Host (Example: Office 2007). Then use Add RemoteApp program to add Office 2007 application

    On RDBroker, i define the RD RemoteApp source with is my RD Session Host (redirect) server.

    I can see the Application in Web Access but when i click on the application. It display this error message:-
    Windows cannot start the RemoteApp program

    The following RemoteApp program is not in the list of authorized program:

    Office Word

    For assistance, contact your system administrator.

    In my environment, i have setup RD Web Access, RD Gateway, RD Virtualization Host, RD Session (Redirect) and RD Connection Broker

    Any step that i miss out. Pls advise


    laiys
    Tuesday, March 16, 2010 1:47 PM

Answers

  • Hello Laiys,

     

    I think you have chosen a good method for publishing applications and provide virtualization desktops in the same while.

     

    You can also use two RD Connection Brokers for specific goals. This method, of course, is more costly.

     

    Thanks.

     

    ·         Lionel Chen

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfd@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, March 22, 2010 8:09 AM

All replies

  • Hello Laiys,

     

    After configured as “Virtual Machine Redirection” mode, the RD Session Host will not serve RemoteApp. This issue is related to the one of another thread you created:

     

    Publishing Remote Desktop Web Access for VDI

    http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/779f341f-d023-4d59-a97c-065e2440fc96

     

    Thanks.

     

    ·         Lionel Chen

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfd@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, March 18, 2010 8:35 AM
  • Hi Lionel,

    correct. It is almost identical but this is related to Application.
    If i still want Application, can i deploy another RD Session Host without redirection mode?
    That's mean i will have 2 RD Session Host.

    I have deployed another RD Session Host(not redirect mode) and Add Calculator.
    On RD Broker, i have add RemoteApp source to this new RD Session Host. Once i click the calculator, i see "Remote Login are currently disabled". Any idea?

    pls advise 
    laiys
    Thursday, March 18, 2010 10:08 AM
  • Hello Laiys,

     

    Have you tried to directly add the new RD Session Host to the Web Access sourc, without RD Connection Broker? (That will cause the virtualization environment temporarily not visible on Web Access)

     

    If that works, the issue is related to the RD Connection Broker. Please check if you have add the RD Connection Broker computer’s account into the “TS Web Access Computers” group of the new RD Session Host.

     

    Thanks.

     

    ·         Lionel Chen

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfd@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, March 18, 2010 10:57 AM
  • Hi Lionel,

    I have performed that. By doing that, i can only see the calculator. All VDI pool is gone.
    Then access to the calculator is " Access is Denied" in the RemoteApp.

    Then i revert back and without changing the WeB UI source- Broker and only add the RD Connection Broker computer’s account into the “TS Web Access Computers” group of the new RD Session Host. I'm will be able to get VDI pool and calculator. It display Waiting for RemoteApp.."Access is denied".

    laiys
    Thursday, March 18, 2010 1:30 PM
  • Hello Laiys,

     

    From your post, I understand that even Connection Broker is not used, the “Access is Denied” issue happens when you try to access the RemoteApp applications.

     

    Have you tried to use Remote Desktop Connections to access the RD Session Host without using RemoteApp? Please confirm if the user has the permission to access the server remotely. Please add the user to the Remote Desktop Users group or Local Administrators group of the new session host.

     

    Thanks.

     

    ·         Lionel Chen

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfd@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, March 19, 2010 6:51 AM
  • Hi,

    When i use RDC to access to new RD Session host using vdiuser account, i will get error message "remote login are currently disable".

    I have added the vdigroup into Remote Desktop Users or Local Administrator group.


    laiys
    Friday, March 19, 2010 8:38 AM
  • Hi Lionel,

    I notice the RDS is put into drain mode. The user mode is dimmed and the default option is "“Allow reconnections, but prevent new logons until the server is restarted”. So I have go to command prompt and key in " “chglogon /ENABLE". Now the option is “Allow all connections" and I can use Web Access UI and remoteApp to access the application.

    I'm assumed this is the way of accessing the Application. Any other method available?

    "Great learning curve of learning."

    Thanks 


    laiys
    Sunday, March 21, 2010 1:16 PM
  • Hello Laiys,

     

    I think you have chosen a good method for publishing applications and provide virtualization desktops in the same while.

     

    You can also use two RD Connection Brokers for specific goals. This method, of course, is more costly.

     

    Thanks.

     

    ·         Lionel Chen

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfd@microsoft.com


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, March 22, 2010 8:09 AM