none
Global Templates Corrupted in Project 2010 RRS feed

  • Question

  • Has anyone had an issue with project templates, associated with EPT's, causing Project Pro 2010 to crash whenever the drop-down selection on a column (field) is chosen?

    I am running Project Server/Pro 2010 SP1 patched to Oct 2012.

    I have 3 templates that are similar (small, medium, large).  The medium and large when opened as templates were fine, so I simply saved them back and they are working fine.  The small one was corrupted whenever the column drop-down was clicked.  I opened another version of the small template from my lab system (same content as production) and saved it to production and all is good.  I am at a loss to figure what happened prior to this exercise. I saved a copy of the corrupted small template and the corrupted projects for further examination.  Any ideas?  The fix for the projects with the corrupted template requires saving all the PWA and Project Site information, deleting the project and its associated site and starting over from scratch.  Those with actual hours will take even longer.  What a mess.


    Update 4/29/14 - Regarding the corrupted template and project files that occurred recently, Microsoft has stated that this behavior is fixed after installing the April 2014 CU.  I will verify this when the April CU is applied to the test machine in our lab.  The cause of the crashing was related to a null setting in the filter-by and group-by settings.  A null is not a setting that can be selected, so I am unclear as to how it got that way in the template.  There is no answer as to why the selections are null and it cannot be corrected.  This is a bug.
    Thursday, April 17, 2014 11:40 AM

All replies

  • Hi Tom,

    You would have to rebuild the EGlobal Template on Project Server. I would suggest that you raise a support ticket with Microsoft as the changes that needs to be done to rebuild it needs an expert supervision.


    Cheers! Happy troubleshooting !!! Dinesh S. Rai - MSFT Enterprise Project Management

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you. This can be beneficial to other community members reading the thread.


    Friday, April 18, 2014 12:44 PM
  • Dinesh,

    I am painfully aware of the fix to the corruption.  I have removed all the corrupted templates and replaced them with non-corrupted ones.  I am now working to fix 32 projects that have the corrupted template.  Some of these 32 have actual hours posted making the task even more time consuming.

    No I did not initiate a ticket with Microsoft.  My experience after working through several bug tickets with them it is that it takes a lot of effort to provide them what they need (problem description, creating compressed copies of all 4 databases, uploading, fielding calls from the support techs, then dealilng with the folks they hand off to, then getting acknowledgement that it is a bug and will be addressed by the development team and placed in a private fix or CU in an upcoming cycle).  In the meantime, I have projects to fix!  I realize that we are not up-to-date on CU's and SP's.  I am working on that now.

    Thanks.

    Friday, April 18, 2014 1:03 PM