locked
MS Exchange IS error 9667 RRS feed

  • Question

  • We have Exchange 2003.  I have read through several of the forums already posted and can't seem to find a direct answer with the best solution.  Just a few days ago, we started seeing:

    Event Type:         Error

    Event Source:     MSExchangeIS

    Event Category: General

    Event ID:              9667

    Date:                    3/15/2011

    Time:                    5:12:37 PM

    User:                    N/A

    Computer:           servername

    Description:

    Failed to create a new named property for database "First Storage Group\Mailbox Store (name)" because the number of named properties reached the quota limit (8192).

    User attempting to create the named property: "SYSTEM"

    Can someone tell me what the best resolution is?  I've read through this article http://blogs.technet.com/b/exchange/archive/2010/07/29/3410545.aspx and would like someone to tell me if applying the hotfix and doing the regedit described will take care of the problem.  Is there any way to view the table that contains the "named properties"?

    Thanks for your time.

    Friday, March 18, 2011 6:06 PM

Answers

  • Yes you need to do the hotfix and registry, that will stop the promotion of SMTP based named properties. Yes to get the table of named props use MFCMapi and then open your mailbox and run “Property Pane”/”Find All Named Props (SLOW).

    Ensure that you reboot after making the registry change, after you apply the hotfix and registry you can dump the named props table over a course of few days and see if they are still increasing. You may still get some named props from mapi\authenticated submissions so that may be a red herring but you should not see the rapid growth as before which most come from external SMTP based messages.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    • Marked as answer by Sophia Xu Wednesday, April 6, 2011 9:40 AM
    Saturday, March 19, 2011 2:18 PM
  • Hi,

    It is a good way to apply the hotfix and do the regedit described for the problem. And remember that raising the quota can't fix the issue and it just pushes the threshold when you get alerted.

    And  please refer to the article: How to configure quota settings for named properties and for replica identifiers in Exchange Server 2003 and in Exchange Server 2007

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;820379

    Thanks

     

    • Marked as answer by Sophia Xu Wednesday, April 6, 2011 9:41 AM
    Monday, March 21, 2011 2:30 AM

All replies

  • That is a good way to fix the problem.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Saturday, March 19, 2011 3:48 AM
  • Yes you need to do the hotfix and registry, that will stop the promotion of SMTP based named properties. Yes to get the table of named props use MFCMapi and then open your mailbox and run “Property Pane”/”Find All Named Props (SLOW).

    Ensure that you reboot after making the registry change, after you apply the hotfix and registry you can dump the named props table over a course of few days and see if they are still increasing. You may still get some named props from mapi\authenticated submissions so that may be a red herring but you should not see the rapid growth as before which most come from external SMTP based messages.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    • Marked as answer by Sophia Xu Wednesday, April 6, 2011 9:40 AM
    Saturday, March 19, 2011 2:18 PM
  • Hi,

    It is a good way to apply the hotfix and do the regedit described for the problem. And remember that raising the quota can't fix the issue and it just pushes the threshold when you get alerted.

    And  please refer to the article: How to configure quota settings for named properties and for replica identifiers in Exchange Server 2003 and in Exchange Server 2007

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;820379

    Thanks

     

    • Marked as answer by Sophia Xu Wednesday, April 6, 2011 9:41 AM
    Monday, March 21, 2011 2:30 AM
  • The link that I received for the hotfix is broken. (http://hotfixv4.microsoft.com/Exchange%202003/sp3/Fix262720/7655.11/free/407690_ENU_i386_zip.exe)

    I'm getting an HTTP error 500.

    Monday, June 8, 2015 9:10 PM
  • Request the hotfix again.  Make sure the URL doesn't include any extra characters if you cut and paste it.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Monday, June 8, 2015 11:17 PM
  • Request the hotfix again.  Make sure the URL doesn't include any extra characters if you cut and paste it.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    I requested it twice already. The URL as pasted is exactly as I received in the email. Besides, when I tried downloading it, I'm simply clicked the link in the email message.

    Monday, June 8, 2015 11:56 PM
  • Okay, the link to the article is now:

    https://support.microsoft.com/en-us/kb/972077

    When I request the hotfix, I get the same thing you do.

    I'll report it, but I can't guarantee that it'll be fixed.  Perhaps a Microsoft moderator will see this and alert someone that it's broken as well.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Tuesday, June 9, 2015 12:13 AM