locked
How to change port bindings for remote workplace in SBS 2008 RRS feed

  • Question

  • Hi all, I'd like to change port:80 for Remote Workplace access to port:8080. Is anyone can explain to me how to that. All answers will be very appreciate. 
    Monday, November 29, 2010 5:58 PM

Answers

  • Guess the question has to be why?

    http://blogs.technet.com/b/nking/archive/2008/11/26/remote-web-workplace-sbs-port-settings.aspx

    http://technet.microsoft.com/en-us/sbs/cc817589.aspx 


    What are the ports I need to open on my firewall?

    You may need to open the following ports, depending on the services you want to make available:

    • Port 25 TCP – SMTP (Outgoing Exchange e-mail)
    • Port 80 TCP – HTTP
    • Port 443 TCP – HTTPS (RWW, OWA, remote desktop or Terminal Server sessions)
    • Port 987 TCP – External secure Companyweb access
    • Port 1723 TCP – PPTP (VPN)

    If port 80 is not open, then you must specify https:// for RWW connections; otherwise if port 80 is open you can use http:// and the session will be redirected automatically to port 443. If your router is configured to use UPnP, the Internet Address Management Wizard (IAMW) will open port 80.

    Larry Struckmeyer

    Please post the resolution to your issue so that everyone can benefit

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Sean Zhu - Monday, December 13, 2010 6:09 AM
    Monday, November 29, 2010 7:45 PM
  • Hi Nino_Richie, I'd like to inform you that it is not recommended to change default port from 80 to 8080. If you want to change it, you can go to Administrative Tools - IIS manager - locate the website - right click on it and choose "Edit binding" - highlight HTTP 80 site - click Edit.

    After that,  you can edit relevant port setting on the router.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Sean Zhu - Monday, December 13, 2010 6:09 AM
    Wednesday, December 1, 2010 7:53 AM

All replies

  • Guess the question has to be why?

    http://blogs.technet.com/b/nking/archive/2008/11/26/remote-web-workplace-sbs-port-settings.aspx

    http://technet.microsoft.com/en-us/sbs/cc817589.aspx 


    What are the ports I need to open on my firewall?

    You may need to open the following ports, depending on the services you want to make available:

    • Port 25 TCP – SMTP (Outgoing Exchange e-mail)
    • Port 80 TCP – HTTP
    • Port 443 TCP – HTTPS (RWW, OWA, remote desktop or Terminal Server sessions)
    • Port 987 TCP – External secure Companyweb access
    • Port 1723 TCP – PPTP (VPN)

    If port 80 is not open, then you must specify https:// for RWW connections; otherwise if port 80 is open you can use http:// and the session will be redirected automatically to port 443. If your router is configured to use UPnP, the Internet Address Management Wizard (IAMW) will open port 80.

    Larry Struckmeyer

    Please post the resolution to your issue so that everyone can benefit

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Sean Zhu - Monday, December 13, 2010 6:09 AM
    Monday, November 29, 2010 7:45 PM
  • Hi Larry, first thanks for your answer.

    The reason I want to change ports for RWW is because I've another server in my Domain that hosting application which already uses ports 80 and 443.

    So the question is it possible to change ports for RWW?

    Monday, November 29, 2010 8:26 PM
  • Hi Nino_Richie, I'd like to inform you that it is not recommended to change default port from 80 to 8080. If you want to change it, you can go to Administrative Tools - IIS manager - locate the website - right click on it and choose "Edit binding" - highlight HTTP 80 site - click Edit.

    After that,  you can edit relevant port setting on the router.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Sean Zhu - Monday, December 13, 2010 6:09 AM
    Wednesday, December 1, 2010 7:53 AM
  • Dear sir,

     

    Can you explain how can I open all the port which you have describes on the small bussinesss server 2008.

    When I trying to "configure Setup your internet" on SBS server2008 and I got an warning......

    (Window small busiiness server 2008 can not open the port 25,80, 443, and 987 to the Ip address to the server, In order to recive Email or other information over the internet,you must manualy open the port. To manually open the port see the documatation from your router manufacture)

     

  • Port 25 TCP – SMTP (Outgoing Exchange e-mail)
  • Port 80 TCP – HTTP
  • Port 443 TCP – HTTPS (RWW, OWA, remote desktop or Terminal Server sessions)
  • Port 987 TCP – External secure Companyweb access
  • Port 1723 TCP – PPTP (VPN)

    can you tell me how can I do this.

    Thanking You

    AAKASH JAIN

    Skype: jain_it


    Network Administrator
Wednesday, May 11, 2011 6:24 AM
  • You have a firewall/router in front of the SBS 2008? Access its setup and configure the port forwarding as described. Opening port 80 is not really needed and can be a security risk.

    Steve

    <AAKASH JAIN 'INDIA'> wrote in message news:17dd77e3-efb4-4ed4-8cbf-9795caaaca36@communitybridge.codeplex.com...

    Dear sir,



    Can you explain how can I open all the port which you have describes on the small bussinesss server 2008.

    When I trying to "configure Setup your internet" on SBS server2008 and I got an warning......

    (Window small busiiness server 2008 can not open the port 25,80, 443, and 987 to the Ip address to the server, In order to recive Email or other information over the internet,you must manualy open the port. To manually open the port see the documatation from your router manufacture)


    * Port 25 TCP - SMTP (Outgoing Exchange e-mail)
    * Port 80 TCP - HTTP
    * Port 443 TCP - HTTPS (RWW, OWA, remote desktop or Terminal Server sessions)
    * Port 987 TCP - External secure Companyweb access
    * Port 1723 TCP - PPTP (VPN)

    can you tell me how can I do this.

    Thanking You

    AAKASH JAIN

    Skype: jain_it


     Network Administrator

    Wednesday, May 11, 2011 3:51 PM
  • I hv resolve my problem. by using this steps-

    1.open ur internet exploler-

     2.write ur modem Ip address.

    3.username-password

     4.click -advance setup

     5.NAT

    6.Vertual Server with this page now u can open the all port which u want. we can say that it is type of {port forwording}

    . Rule Index : use as per serial NO.

    Application : select any port which u want {for Example u have select SMTP}

    Protocol : select TCP Start Port Number : for SMTP u will have to select port {25}

     End Port Number : it will also {25}

     Local IP Address : your server Ip address

    Start Port Number(Local) : {25}

    End Port Number(Local): {25}

     Click save and go to the- mantinance click sysrestart-current setting.

    Thanks AAKASH JAIN


    Network Administrator

    Monday, June 13, 2011 7:34 AM
  • Hello,

     

    I have a similar problem to the original poster. My modem/router has ports 80 and 443 hard-wired to it for remote access. It does NOT allow forwarding those ports to the SBS box (or anywhere else). My ISP does not offer any other kind of modem and I do not have the option of changing ISP. There is no firmware update for the modem/router I can find that allows me change this.

     

    I'd like more detailed steps as to how to change the binding(s) in IIS. I need to change both port 80 and port 443.


    Aide
    Tuesday, January 24, 2012 3:54 PM