none
Display Template Will Not Publish

    Question

  • We're upgrading to SharePoint 2016.  Our 2013 site has a customized display for the Search Results.  This was customized by editing the “Item_CommonItem_Body.html”  display template located in the Master Page Gallary-> Display Templates -> Search directory and then publishing it.

    I've done the same thing on the new SharePoint 2016 server.  However, when I view the search results the changes are not there.  The changes appear in in the Master Page gallery, but when I go to the Design Manager and download a copy the changes are not there.  I tried checking it out from the Design Manager:Edit Display Templates pages as well and then publishing a Major version without success.

    Does anyone know what I’m doing wrong by chance or if this needs to be done differently in 2016?

    Thanks


      

    Friday, February 17, 2017 7:03 PM

All replies

  • Hi Jamezn,

    I added a <div> in the “Item_CommonItem_Body.html” in my SharePoint Server 2016, however the <div> showed correctly in the search results page. And the changes appear in Design Manager also.

    Could you please let me know what customizations you have done on the “Item_CommonItem_Body.html” so that I could test in my environment?

    You can just test by adding a <div> in your “Item_CommonItem_Body.html” to see what happens.

    Best Regards,

    Victoria

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, February 22, 2017 5:23 AM
    Moderator
  • Hi Jamezn,

    I am checking to see how things are going there on this issue. Please let us know if you would like further assistance.

    Best Regards,

    Victoria


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, February 27, 2017 9:56 AM
    Moderator