Server 2012 - IE content adviser grayed out - how to set it?


  • I am trying to set the content adviser on group policy within Windows Server 2012 so it passes onto all the domain accounts. I have looked at other posts and there is no answer to this question. The settings for Internet Explorer are set at this location below in Group Policy as far as I am aware for Windows Server 2012: 

    User Configuration\Preferences\Control Panel Settings\Internet Settings 

    But when you go to create "new IE10" and go to the content tab in properties "Content Adviser" is grayed out so you cannot set the sites to allow/restrict etc for all the users, the only method seems to be going around each individual PC and manually adding it to the local Group Policy which will be a pain and not good if other sites need to be added later.

    There must be some easy way to enable the content advisor?


    Wednesday, July 29, 2015 10:59 AM

All replies

  • Hi Jase,

    As it's known to us, since Windows 8, the IEM settings have been deprecated in favor of Group Policy Preferences, Administrative Templates (.admx), and the Internet Explorer Administration Kit 10 or above.

    Regarding this point, the following article can be referred to for more information.

    Appendix B: Replacements for Internet Explorer Maintenance

    To configure Content Advisor settings for IE10, we can try to use IEAK10 to do this.

    Regarding IEAK and configuring Content Advisor settings, the following article can be referred to for more information.

    Configuring Content Advisor Settings

    Internet Explorer Administration Kit (IEAK) Information and Downloads

    Configuring Content Advisor Settings

    Best regards,

    Frank Shen

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact

    Thursday, July 30, 2015 7:20 AM

  • Thanks for the reply Frank, I have however done the majority of that and Im at the last stage"Configuring Content Advisor Settings" but as I mentioned the Content Adviser box is grayed out. There's no way I can go through that final link as I can't click on enable.

    I have looked at a number of forums asking the same thing but there is no answer, can anyone from Microsoft assist with this? Heres a screenshot below of the issue for anyone who doesn't understand what I mean.

    • Edited by Jase-888 Thursday, July 30, 2015 8:52 AM
    Thursday, July 30, 2015 8:52 AM