locked
windows 2008 R2 server can access ONLY https sites, any of http sites CANNOT be accessed!! RRS feed

  • Question

  • I am having a strange problem with my server machine. It is with all of the browsers Chrome, firefox, ie. I have been working on this issue for many hours and this is what I have done so far.

    1. CAN ping www.google.com, www.youtube.com or any non http or https sites.
    2. Installed and ran almost all malwares and tools: hitmanpro, HiJackThis, msert,tdsskiller FOUND NOTHING
    3. malwarebyes-cannot download the latest file but ran 120 day old - FOUND NOTHING
    4. eset does not run as it cannot connect to its site.
    5. Ran MS "test internet connection" indicated some policy need to fixed and after the fix applied, no connection to http sites 
    6. Ran fiddler tool for any http request "error: 504 prot: http site:www.google.com
    7. I can go to any bank/credit card sites, www.gmail.com and they all work fine.

    Any suggestion, help will be greatly appreciated. Searched and searched the net for solution did tried almost all but no mustard.

    Friday, August 23, 2013 6:00 AM

Answers

  • Hi,

    According to your description, I recommend you check the following steps:

    1. Uncheck "automatically detect settings" in Local Area Network (LAN) Settings in Internet Options.
    2. Please check no antivirus program or firewall that is blocking use of HTTP protocol. By default, HTTP uses port 80 and HTTPS uses port 443. Please make sure both the two ports are enabled.

    Best regards,

    Susie Long

    • Marked as answer by Susie Long Sunday, September 1, 2013 5:08 AM
    Wednesday, August 28, 2013 8:42 AM

All replies

  • Have you checked firewall ports 80 and 443?

    Use network monitor to catch network communication. Wireshark will suffice to do your tests.

    Regards

    Milos

    Friday, August 23, 2013 5:32 PM
  • Hi,

    According to your description, I recommend you check the following steps:

    1. Uncheck "automatically detect settings" in Local Area Network (LAN) Settings in Internet Options.
    2. Please check no antivirus program or firewall that is blocking use of HTTP protocol. By default, HTTP uses port 80 and HTTPS uses port 443. Please make sure both the two ports are enabled.

    Best regards,

    Susie Long

    • Marked as answer by Susie Long Sunday, September 1, 2013 5:08 AM
    Wednesday, August 28, 2013 8:42 AM