none
ID3169 Exceeded the threshold value 90% RRS feed

  • Question

  • Hi,

    I am getting the error below.

    The used disk space on the computer running DPM for the recovery point volume of SQL Server 2008 database APLDPMIV\MSDPM2012\model has exceeded the threshold value of 90% (DPM accounts 600 MB for internal usage in addition to free space available). If you do not allocate more disk space, synchronization jobs may fail due to insufficient disk space. (ID 3169)

    The model database is only 3MB and I have 3.4TB of storage left in the storage pool. I don't understand what this is trying to tell me. We are running Data Protection Manager 2012.

    Any help would be much appreciated. I know I will need to grow the volume. Will it auto grow once the issue is resolved?

    Best wishes

    Michael


    Friday, January 24, 2014 4:22 PM

All replies

  • Hi,


    The error is showing that the recovery point volume is out of space. Most likely the SQL DB's are co-located so that means they also share the same recovery point volume.


    We log autogrow activity in the application event log.  Autogrow grows - 10GB or 25% of volume whichever is larger.

    Look to see if you have any events around the time of the failure.

    Log Name:      Application
    Source:        MSDPM
    Date:          MM/DD/YY HH:MM:SS AM
    Event ID:      33143
    Task Category: None
    Level:         Information
    Keywords:      Classic
    User:          N/A
    Computer:      DPMSERVER.DOMAIN.com
    Description:   The volume for load5 has grown from 1.62 GB to 11.62 GB.

    Log Name:      Application
    Source:        MSDPM
    Date:          MM/DD/YY HH:MM:SS AM
    Event ID:      33144
    Task Category: None
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      DPMSERVER.DOMAIN.com
    Description:   DPM was unable to expand the volume for <DataSource_name>.


    I have seen instances where DPM did autogrow - but not quite in time so the alert gets posted anyways.

    If that is the case, then inactivate the alert and all should be ok,  else add more space to the recovery point volume, then inactivate the alert.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, January 24, 2014 5:09 PM
    Moderator
  • Hi Mike,

    I don't have any of those event ids, but I do have 4222 and 4420.

    The description for Event ID 4222 from source MSDPM cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event: 

    DPM has run out of free recovery point space and will fail snapshots for APLSQLIII\servicedesk_group in order to prevent existing recovery points from getting recycled.  1) Increase the space allocated for the recovery point volume for APLSQLIII\servicedesk_group. 
    2) Retry the operation after increasing the space for the recovery point volume.

    Problem Details:
    <DpmWriterEvent><__System><ID>30</ID><Seq>25282</Seq><TimeCreated>1/27/2014 8:08:50 AM</TimeCreated><Source>d:\btvsts\14920\private\product\tapebackup\dpswriter\vssfunctionality.cpp</Source><Line>815</Line><HasError>True</HasError></__System><DetailedCode>-2147212300</DetailedCode></DpmWriterEvent>


    the message resource is present but the message is not found in the string/message table

    Best wishes

    Michael


    Monday, January 27, 2014 10:59 AM
  • Hi,

    Perhaps outo grow feature is not seelcted for that protection group or data source.  Can you check by clicking that data source under the protection group, select the "modify disk allocation..." option, then see if the "automatically grow the volumes" is checked.   Besides the event logs, all auto heal activity is logged in the DPMAccessManagerCurr.errlog in the C:\Program Files\DPM_INSTALLATION_FOLDER\DPM\Temp folder.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, January 27, 2014 4:20 PM
    Moderator
  • Hi Mike,

    Auto grow is enabled. I gave the recovery point an extra 2GB and removed the alert. It is still failing. I can see auto healing happening in the log, but not sure what I am looking for?

    Best wishes

    Michael


    Monday, January 27, 2014 5:52 PM
  • Hi,


    There are several situations in which autogrow may not happen and this activity is also logged in DPMAccessManagerCurr.errlog

    1. If another alert of the same type for the same datasource was raised and resolved within 15 minutes of the current alert, then it will fail.  Retry another backup after 15 minutes.  In this case, the following would have been logged:
    AutoHeal: A grow alert was recently resolved; AlertId=[GUID]

    2. The ProtectionGroup that contains the data source does not have AutoGrow enabled.  If so, the following will be logged:
    AutoHeal: AutoGrow not enabled for datasource. AlertId=[GUID]

    3. The Disk threshold exceeded or Recovery point volume threshold exceeded alert was not raised.  This can be checked from the DPM alerts.

       (The DPM AccessManager Service is not started or is crashing)  

    4. If the system is close to hitting the LDM limit, then the autogrow will fail and log the following:
    AutoHeal: LDM database within error threshold, skipping grow; AlertId=[GUID]

    If you are going to manually grow a volume I would use the same formula as auto-grow.  Either 10GB or 25% of the volume size that needs growing which ever is larger 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.


    Monday, January 27, 2014 6:21 PM
    Moderator
  • Hi Mike,

    I have no references to any of those lines in my log file. I am going to manually grow it by 10GB and see what happens.

    Best wishes

    Michael


    Tuesday, January 28, 2014 11:17 AM
  • Hi Mike,

    In the end I deleted the protection group and remade it. Later I was doing an upgrade on a product that complained it transaction log was full. This was a database that was going inconsistent all the time. Is that likely to be related to my issue? The database model was full.

    Best wishes

    Michael


    Tuesday, January 28, 2014 5:17 PM
  • Hi Mike,

    Well that didn't work. It stayed good for about a day and half. Now the errors have returned.

    Best wishes

    Michael


    Thursday, January 30, 2014 1:09 PM
  • Hi Mike,

    I know have a file replica doing the same thing. I do have a (!) on my disk allocation, but 3TB of space. Is this likely to my issue. 3TB sounds like a lot of spare space.

    Best wishes

    Michael


    Thursday, January 30, 2014 1:11 PM
  • Hi,

    You are going to have to find equilibrium - where the amount of new data coming is about equal of old recovery points expiring that gets deleted. Once the proper space is allocated for the desired retention period, then things should smooth out. I still cannot explain why auto-grow does not see to be working for you.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, February 3, 2014 7:44 PM
    Moderator
  • In the end I opened a ticket with support (11402101117123). It turns out this is a known issue. My SQL Server Agent was running under the DPM account that the installer sets up. This has now been changed to a domain admin and it working fine.

    Best wishes

    Michael


    Thursday, February 20, 2014 9:43 AM
  • Hi,

    Well, I will not argue with success, however the MSSQL$MSDPM2012 account that DPM creates during install is the normal account used and should not have any problems with autogrow "unless" some permissions were restricted on that account.  In any case, glad to hear that auto-grow is working again.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, February 20, 2014 4:04 PM
    Moderator