none
None of my computers can join a homegroup RRS feed

  • Question

  • Hi,

    I don't think this has been asked before but it may be a related issue....

    I bought a Surface tablet and successfully connected it to my Windows 7 Homegroup.
    Then I installed another computer with a clean install of Windows 8 Professional, but it couldn't see the existing homegroup and could only create its own. I made sure the homegroup services were running, made sure sharing was enabled on the wireless adapter and made sure network discovery was turned on, but no luck. I wasn't too worried at this point as I thought I'd just deal with that problem later.
    Then I upgraded my original Windows 7 PC to Windows 8, keeping my programs and settings. It lost the homegroup and my Surface started telling me it couldn't find other computers on the homegroup.
    So I recreated the homegroup on my upgraded Win7-Win8 PC and it can see its own shared files but nothing else can see its homegroup. I tried resetting the homegroup password, leaving it, recreating it and checking my router in case it had mistaken it for some kind of attack but nothing...
    So then I removed all my devices from homegroups and started afresh. Same problem, the Surface obviously can't create a homegroup but now it sees nothing. The other 2 Windows 8 Pro computers can create their own homegroups and see their own shared data but not eachothers. If either of them leaves its homegroup it can't find any others on the network.

    So I am starting to get really tired of this stupidly dumbed down version of Windows where I am having to swipe my mouse all over the place and click on things 200 times just to enable sharing on a wireless network.

    Any help?
    Please please please don't suggest the obvious things. I've tried them all. Every single homegroup related article that might come even close to a solution has been tried. All of them can connect to the Internet through their connection just fine. Ping from one computer to another returns destination host unreachable from the router. Ping the router though, and you get a response. My router doesn't have any kind of wireless privacy seperator, and none of its settings have changed anyway; It was all working fine in Windows 7 using whatever default options come out of the box.

    Has anyone else had the same kind of problem? I'm now stuck with no ability to share files on my home network, rendering my £650 Surface tablet even more useless than it was before.

    Tuesday, November 6, 2012 9:11 AM

All replies

  • Just to add, I am signed into all of the computers using my Microsoft account, though I don't think that should cause a problem as the Surface was always signed in using the Microsoft account even when the Win7 computer was signed in with a local account. I don't want to stop using the Microsoft account since I'd lose half the benefit of being on Win8 if I did that.
    Tuesday, November 6, 2012 9:15 AM
  • It seems there two homegroups on two computers and both of them cannot detect the other hompegoup. Did you try the suggestions in the following website?

    http://windows.microsoft.com/en-US/windows7/Why-can-t-I-join-a-homegroup

    Did you try to temporarily disable firewall?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Wednesday, November 7, 2012 8:32 AM
    Moderator
  • Hi Arthur Thanks for replying, but I think you completely misunderstood my post. There is only one homegroup. My problem was that none of my computers could see any homegroup except the computer I first created it on. They could all access the Internet just fine but couldn't communicate with eachother. After wasting my time trying pretty much everything in every article I found, the solution turned out to be a reboot of the router. Sometimes the simple answers are the best! Thanks for your efforts though... Perhaps this solution could be added to the troubleshooting steps, or better still the suggestion made by the troubleshooting wizard in Windows!
    Wednesday, November 7, 2012 8:40 AM