none
IE display problem RRS feed

  • Question

  • Dear Support,

    We have our website http://shopdrill.com running and displaying properly on Chrome, Firefox, Safari and Opera.

    On IE 8 and other versions the site opens with errors and distorted display.

    We tried debugging at level of HTML but unable to find any error. 

    The website is running on Linux Server with MySql databases and PHP.

    Please help.

    Thanks

    Saturday, October 18, 2014 9:53 AM

Answers

  • Hi Fahad,

    Thanks for your reply. We have tested and found that the website is only behaving badly with IE6, 7, 8 and 9.

    Other browsers are fine with this website including IE10 and IE11.

    We are using MySql with PHP on LINUX server.

    Please tell what other things you want to know.

    Please help us.

    Thanks

    Thanks for your answer. According to your description, I can just say that your site don't supports older versions of Internet Explorer. MySQL with PHP on linux is Ok and should work on older versions of IE but its not a problem. Problem is about your web design! You are using modern design on your site which don't support old browsers. 

    The only the solution which I can suggest you is either downgrade design of your site, or use proper HTML, CSS and JavaScript framework which should support old web browsers. 

    I may not ask you any more questions because now your question is very clear. Also the problem is with your web design. Your web is only supporting Modern Web browsers. So, its not a problem with IE. So we are helpless!


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Proposed as answer by I-Am-LOL Wednesday, October 22, 2014 5:47 PM
    • Marked as answer by Cloud_TSModerator Monday, November 10, 2014 1:48 AM
    Sunday, October 19, 2014 12:25 PM

All replies

  • On IE 8 and other versions the site opens with errors and distorted display.

    What's wrong with IE11?  The only one that looks really bad is the Opera one. 

    https://www.modern.ie/en-us/screenshots#http%3A%2F%2Fshopdrill.com

    BTW none of the phones came through.  I guess your site isn't supporting them?



    Robert Aldwinckle
    ---

    Saturday, October 18, 2014 2:06 PM
    Answerer
  • Hello Vikas Goyal,

    It looks like your site don't supports Internet Explorer. Can you provide us some more information about your site ? Which things did you use for building your site ? Do they support Internet Explorer ?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Edited by Fahadking07 Saturday, October 18, 2014 3:56 PM
    Saturday, October 18, 2014 3:56 PM
  • Cannot reproduce.

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    IE Development Forum (post such questions here instead)
    http://social.msdn.microsoft.com/Forums/ie/en-US/home?forum=iewebdevelopment

    IE Developer Resources
    http://www.modern.ie/en-us

    IE Developer Center - Key features by area
    http://msdn.microsoft.com/en-US/ie/aa740473

    IE11 Guide for Developers
    http://msdn.microsoft.com/en-us/library/ie/bg182636(v=vs.85).aspx

    Scan for common coding problems
    http://msdn.microsoft.com/en-US/ie/


    ~Robear Dyer (PA Bear) MS MVP-Windows Client since 2002 Disclaimer: MS MVPs neither represent nor work for Microsoft

    Saturday, October 18, 2014 6:02 PM
  • Dear Robert,

    Thanks for your answer. The website is only behaving badly with IE 6, 7, 8, 9 and apart from that working fine on all other browsers.

    Yes, we are planning a separate mobile version of our website, so it did not came through for phones.

    Please help us out.

    Thanks

     
    Saturday, October 18, 2014 6:06 PM
  • Hi Fahad,

    Thanks for your reply. We have tested and found that the website is only behaving badly with IE6, 7, 8 and 9.

    Other browsers are fine with this website including IE10 and IE11.

    We are using MySql with PHP on LINUX server.

    Please tell what other things you want to know.

    Please help us.

    Thanks

    Saturday, October 18, 2014 6:09 PM
  • Hi Fahad,

    Thanks for your reply. We have tested and found that the website is only behaving badly with IE6, 7, 8 and 9.

    Other browsers are fine with this website including IE10 and IE11.

    We are using MySql with PHP on LINUX server.

    Please tell what other things you want to know.

    Please help us.

    Thanks

    Thanks for your answer. According to your description, I can just say that your site don't supports older versions of Internet Explorer. MySQL with PHP on linux is Ok and should work on older versions of IE but its not a problem. Problem is about your web design! You are using modern design on your site which don't support old browsers. 

    The only the solution which I can suggest you is either downgrade design of your site, or use proper HTML, CSS and JavaScript framework which should support old web browsers. 

    I may not ask you any more questions because now your question is very clear. Also the problem is with your web design. Your web is only supporting Modern Web browsers. So, its not a problem with IE. So we are helpless!


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Proposed as answer by I-Am-LOL Wednesday, October 22, 2014 5:47 PM
    • Marked as answer by Cloud_TSModerator Monday, November 10, 2014 1:48 AM
    Sunday, October 19, 2014 12:25 PM
  • website is only behaving badly with IE6, 7, 8 and 9.

    Notice that the Modern.IE site is pointing out that the jQuery that you are using is doing "browser sniffing".  Is it really necessary?  Perhaps you are getting some difference in output because of that, especially with the IE9 case.  Then you could try testing an IE9 browser simulating using a UAS from any of the browsers that "work".  To lesser extents that could be done with the other IE too.  For more informed comment about this scenario you could try posting in the MSDN forum for IE web development.



    Robert Aldwinckle
    ---

    Sunday, October 19, 2014 6:02 PM
    Answerer