none
2013: Error syncing PWA permissions to PWA site RRS feed

  • Question

  • Hi

    we have errors in the sync of Project Server users with the PWA site (Project permissions mode, December 2014 CU).

    New users that are added to MPS groups do not get SharePoint permissions.

    ULS log says:

    Project Server Database        ah91z Medium   Successfully got the connection string (database name=[SP_EVAL_Project_Webapp], id=0731eccb-e62a-4ce4-b7f1-abb4c35cca57, type=Consolidated). Requested access level=ReadWrite: Data Source=SP-EVALDB;Initial Catalog=SP_EVAL_Project_Webapp;Integrated Security=True;Enlist=False;Pooling=True;Min Pool Size=0;Max Pool Size=100;Connect Timeout=15 40ddf69c-ac6a-b014-d7ba-02e5cf04174b
    Queue                          b0rk Medium   PWA:, ServiceApp:Unknown, User:Unknown, PSI: UnknownUnknown[QUEUE] noop BeginMessageGroup cdc99145-8ed4-e411-9855-005056b23a86 type = PSPermissionSynchronizePWASite priority = StandardPriority, LogLevelManager Warning-ulsID:0x6230726B has no entities explicitly specified. 40ddf69c-ac6a-b014-d7ba-02e5cf04174b
    Project Server Database        ah91z Medium   Successfully got the connection string (database name=[SP_EVAL_Project_Webapp], id=0731eccb-e62a-4ce4-b7f1-abb4c35cca57, type=Consolidated). Requested access level=ReadWrite: Data Source=SP-EVALDB;Initial Catalog=SP_EVAL_Project_Webapp;Integrated Security=True;Enlist=False;Pooling=True;Min Pool Size=0;Max Pool Size=100;Connect Timeout=15 40ddf69c-ac6a-b014-d7ba-02e5cf04174b
    Sharepoint Integration         adgm4 Medium   PWA:http://servername/pwa, ServiceApp:Project Service Application, User:i:0#.w|domain\adminuser, PSI: ApplyGlobalPermissionState: Synchronize permissions to PWA Site, LogLevelManager Warning-ulsID:0x000C631E has no entities explicitly specified. 40ddf69c-ac6a-b014-d7ba-02e5cf04174b
    Sharepoint Integration         adl8x Medium   PWA:http://servername/pwa, ServiceApp:Project Service Application, User:i:0#.w|domain\adminuser, PSI: [QUEUE] HandlePSPermissionSynchronizePWASiteMessag: Unexpected error occurred while applying global permission states to PWA site, LogLevelManager Warning-ulsID:0x000CB897 has no entities explicitly specified. 40ddf69c-ac6a-b014-d7ba-02e5cf04174b
    Sharepoint Integration         aeqz7 Exception An unexpected exception occured while processing queue messages of type PSPermissionSynchronizePWASite System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.     at System.Collections.Generic.Dictionary`2.get_Item(TKey key)     at Microsoft.Office.Project.Server.BusinessLayer.SharePointSecurityHelper.GetGroupNameByPermissionUID(SPWeb web, Guid feaActUid, String projName)     at Microsoft.Office.Project.Server.BusinessLayer.PSPermissionSynchronizer.<>c__DisplayClass5.<>c__DisplayClass8.<ApplyGlobalPermissionState>b__4(Guid feaActUid)     at Microsoft.Office.Project.Server.BusinessLayer.PSPermissionSynchronizer.ApplyDeltaPermissionsToSPWeb(IPlatformContext context, SPWeb web, SharePointSecurityHelper sharepointHelper, IEnumerable`1 permissions, Func... 40ddf69c-ac6a-b014-d7ba-02e5cf04174b
    Sharepoint Integration         aeqz7 Exception ...`2 getAssociatedGroup)     at Microsoft.Office.Project.Server.BusinessLayer.PSPermissionSynchronizer.<>c__DisplayClass5.<ApplyGlobalPermissionState>b__3()     at Microsoft.SharePoint.SPSecurity.<>c__DisplayClass5.<RunWithElevatedPrivileges>b__3()     at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode)     at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param)     at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode)     at Microsoft.Office.Project.Server.BusinessLayer.PSPermissionSynchronizer.ApplyGlobalPermissionState(IPlatformContext context, SharePointSecurityHelper sharepointHelper, PSPermissionSyncState deltaState)     at Microsoft.Office.Project.Server.BusinessLa... 40ddf69c-ac6a-b014-d7ba-02e5cf04174b
    Sharepoint Integration         aeqz7 Exception ...yer.Queue.ProcessPreparePSPermissionSynchronizationMessage.HandlePSPermissionSynchronizePWASiteMessage(PSPermissionSynchronizePWASiteMessage msg, MessageContext mContext)     at Microsoft.Office.Project.Server.BusinessLayer.Queue.ProcessPreparePSPermissionSynchronizationMessage.HandleMessage(Message msg, Group messageGroup, JobTicket jobTicket, MessageContext mContext) StackTrace:  at Microsoft.Office.Project.Server.Native.dll: (sig=ba14c1d4-b008-457e-b538-7dd2c07bdfe6|2|microsoft.office.project.server.native.pdb, offset=3C16) at Microsoft.Office.Project.Server.Native.dll: (offset=1265D) 40ddf69c-ac6a-b014-d7ba-02e5cf04174b
    Unified Logging Service        c91s Monitorable Watson bucket parameters: Microsoft Project Server 2013, ULSException14, 070f6ea0 "project server", 0f0011db "15.0.4571.0", c180aef3 "mscorlib", 0400766f "4.0.30319.0", 52675671 "wed oct 23 06:54:09 2013", 00002131 "00002131", 0000000c "0000000c", 0560164b "keynotfoundexception", 00110661 "aeqz7" 40ddf69c-ac6a-b014-d7ba-02e5cf04174b
    Queue Jobs                     954l Medium   PWA:http://servername/pwa, ServiceApp:Project Service Application, User:PROJECTSERVER\system, PSI: [QUEUE] Message not processed: Group: cdc99145-8ed4-e411-9855-005056b23a86 MsgId: 1 Type: PSPermissionSynchronizePWASite, LogLevelManager Warning-ulsID:0x3935346C has no entities explicitly specified. 40ddf69c-ac6a-b014-d7ba-02e5cf04174b
    Queue                          b0rl Medium   PWA:, ServiceApp:Unknown, User:Unknown, PSI: UnknownUnknown[QUEUE] noop EndMessageGroup cdc99145-8ed4-e411-9855-005056b23a86 type = PSPermissionSynchronizePWASite priority = StandardPriority, LogLevelManager Warning-ulsID:0x6230726C has no entities explicitly specified. 40ddf69c-ac6a-b014-d7ba-02e5cf04174b
    Queue                          ad3fy Critical Standard Information:PSI Entry Point: <unknown>  Project User: <unknown>  Correlation Id: <unknown>  PWA Site URL:   SA Name: <unknown>  PSError: <unknown> A queue job has failed. This is a general error logged by the Project Server Queue everytime a job fails - for effective troubleshooting use this error message with other more specific error messages (if any), the Operations guide (which documents more details about queued jobs) and the trace log (which could provide more detailed context). More information about the failed job follows. GUID of the failed job: ccc99145-8ed4-e411-9855-005056b23a86. Name of the computer that processed this job: a74eaf15-778d-4809-847b-6fa0a14d7ba0 (to debug further, you need to look at the trace log from this computer). Failed job type: PSPermissionSynchr... 40ddf69c-ac6a-b014-d7ba-02e5cf04174b
    Queue                          ad3fy Critical ...onizePWASite. Failed sub-job type: PSPermissionSynchronizePWASiteMessage. Failed sub-job ID: 1. Stage where sub-job failed:  (this is useful when one sub-job has more than one logical processing stages). 40ddf69c-ac6a-b014-d7ba-02e5cf04174b
    Queue Jobs                     ad3fy Medium   Error is: GeneralQueueJobFailed. Details: Queue Attributes:  ccc99145-8ed4-e411-9855-005056b23a86  a74eaf15-778d-4809-847b-6fa0a14d7ba0  PSPermissionSynchronizePWASite  PSPermissionSynchronizePWASiteMessage  1    40ddf69c-ac6a-b014-d7ba-02e5cf04174b  . Standard Information: , LogLevelManager Warning-ulsID:0x000DD158 has no entities explicitly specified. 40ddf69c-ac6a-b014-d7ba-02e5cf04174b

    Anyone seen that before or having an idea?

    Thanks a lot

    Christoph


    Christoph Muelder | Senior Consultant, MCTS, MCSE | SOLVIN information management GmbH, Germany

    Friday, March 27, 2015 2:58 PM

All replies

  • Hi Christoph,

    had you ever been able to find the reason for this issue and solve it? I have currently a quite similar error.

    Regards
    Barbara

    Thursday, October 5, 2017 2:13 PM
    Moderator
  • Hi

    became partly solved with March 2016 CU or so for Project Server 2013. But is still not working 100% correct....

    Regards

    Christoph


    Christoph Muelder | Senior Consultant, MCTS, MCSE | SOLVIN information management GmbH, Germany

    Thursday, October 5, 2017 7:20 PM
  • Hi Christoph,

    I am sorry for you!

    Fortunately, I was able to find an "access denied in my ULS" pointing me in the good direction. Service Accounts in CA had been mixed up.

    Regards
    Barbara

    Friday, October 6, 2017 4:51 AM
    Moderator
  • Barbara,

    Can you give a little more detail about the service accounts being mixed up?


    Steve


    • Edited by Smizer Wednesday, April 11, 2018 8:18 PM
    Wednesday, April 11, 2018 6:42 PM