locked
Automating Internet Explorer using Selenium C# RRS feed

  • Question

  • Hi all,

     I am facing an issue when automation IE 11 with Selenium C#.

     clicking on a specific link is opening new window, where the expected behaviour is to open the link in a new tab. When manually trying to do the same scenario, the expected result is obtained where as the problem arise when trying to do the same using automation. the behaviour is working fine with automation in Chrome, Firefox and Edge.

    Selenium Webdriver Version :3.3

    IE version: 11

    IEDriverServer version : 3.3.0.0

    Kindly let me know if more information required.

    Thursday, March 30, 2017 7:54 AM

All replies

  • Hi,

    scripted window and hyperlink target outcomes can be affected by

    1. IE Tabs settings.... Internet Options>General tab, Tabs section.

    2. IE Popup blocker settings and third-party popup blocker settings. Run IE in noAddons mode.

    2. IE Security zone settings. Internet Options>Security tab, click "Reset all zones to default". IE has restrictions on navigating into a zone of lower integrity. eg. intranet to internet. Use the File>Properties menu in IE to determine which IE security zone a domain is mapped to. Use the Context menu "Properties" to determine the security zone of embedded content.

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions.

    Developer questions should be posted to http://stackoverflow.com/questions/tagged/internet-explorer


    Rob^_^

    Thursday, March 30, 2017 8:04 PM
  • Hi Rob,

    Kindly find my comments below.

    1. IE tab settings - "When pop is encountered" is set to "Always open pop ups in new tab".

    2. IE pop up blocker is disabled and not hird party add ons are used

    3. Security Zone settings are reset to default for all zones and also  I am using InternetExplorerOptions to ignore the protected mode settings. also the particular url I am using is added in trusted sites and protected mode is off(Shown in Properties-> Zone)

    Still issue persists. Kindly advice me on whether to change any of the above and try again or is there any other work around?

    Friday, March 31, 2017 6:59 AM